summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--x11-plugins/wmsysmon/ChangeLog5
-rw-r--r--x11-plugins/wmsysmon/wmsysmon-0.7.7.ebuild10
2 files changed, 11 insertions, 4 deletions
diff --git a/x11-plugins/wmsysmon/ChangeLog b/x11-plugins/wmsysmon/ChangeLog
index b7184aeb4b9d..16c3fa0b76d8 100644
--- a/x11-plugins/wmsysmon/ChangeLog
+++ b/x11-plugins/wmsysmon/ChangeLog
@@ -1,6 +1,9 @@
# ChangeLog for x11-plugins/wmsysmon
# Copyright 2002-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/x11-plugins/wmsysmon/ChangeLog,v 1.31 2008/08/05 21:14:15 cardoe Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-plugins/wmsysmon/ChangeLog,v 1.32 2009/01/14 13:58:36 s4t4n Exp $
+
+ 14 Jan 2009; Michele Noberasco <s4t4n@gentoo.org> wmsysmon-0.7.7.ebuild:
+ Do not strip binaries during compilation. Fixes bug #252113.
05 Aug 2008; Doug Goldstein <cardoe@gentoo.org> metadata.xml:
add GLEP 56 USE flag desc from use.local.desc
diff --git a/x11-plugins/wmsysmon/wmsysmon-0.7.7.ebuild b/x11-plugins/wmsysmon/wmsysmon-0.7.7.ebuild
index b846ecc7e03a..e54a9fd3534f 100644
--- a/x11-plugins/wmsysmon/wmsysmon-0.7.7.ebuild
+++ b/x11-plugins/wmsysmon/wmsysmon-0.7.7.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2008 Gentoo Foundation
+# Copyright 1999-2009 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/x11-plugins/wmsysmon/wmsysmon-0.7.7.ebuild,v 1.10 2008/06/29 13:46:30 drac Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-plugins/wmsysmon/wmsysmon-0.7.7.ebuild,v 1.11 2009/01/14 13:58:36 s4t4n Exp $
inherit eutils
@@ -17,7 +17,8 @@ RDEPEND="x11-libs/libX11
x11-libs/libXext
x11-libs/libXpm"
DEPEND="${RDEPEND}
- x11-proto/xextproto"
+ x11-proto/xextproto
+ >=sys-apps/sed-4.1.5-r1"
src_unpack()
{
@@ -32,6 +33,9 @@ src_unpack()
cd src
epatch "${FILESDIR}"/${PN}-high-ints.patch
fi
+
+ # Do no strip binaries during compilation, see bug #252113
+ sed -i 's/LDFLAGS += -lXpm -lXext -lX11 -lm -s/LDFLAGS += -lXpm -lXext -lX11 -lm/' "src/Makefile"
}
src_compile()