summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--mail-filter/gld/ChangeLog7
-rw-r--r--mail-filter/gld/files/Makefile.in42
-rw-r--r--mail-filter/gld/files/gld-1.5.2-mxgrey-fix.patch34
-rw-r--r--mail-filter/gld/gld-1.5.2.ebuild65
-rw-r--r--mail-filter/gld/gld-1.6.ebuild63
-rw-r--r--mail-filter/gld/gld-1.7.ebuild7
6 files changed, 9 insertions, 209 deletions
diff --git a/mail-filter/gld/ChangeLog b/mail-filter/gld/ChangeLog
index b6938502f4db..48a298bbbc83 100644
--- a/mail-filter/gld/ChangeLog
+++ b/mail-filter/gld/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for mail-filter/gld
# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/mail-filter/gld/ChangeLog,v 1.39 2008/05/21 16:03:03 dev-zero Exp $
+# $Header: /var/cvsroot/gentoo-x86/mail-filter/gld/ChangeLog,v 1.40 2008/06/15 09:34:55 dertobi123 Exp $
+
+ 15 Jun 2008; Tobias Scherbaum <dertobi123@gentoo.org>
+ -files/gld-1.5.2-mxgrey-fix.patch, -files/Makefile.in, -gld-1.5.2.ebuild,
+ -gld-1.6.ebuild, gld-1.7.ebuild:
+ Remove useless dep on mail-mta/postfix (#225965), fix quoting, cleanup
21 May 2008; Tiziano Müller <dev-zero@gentoo.org> gld-1.5.2.ebuild,
gld-1.6.ebuild, gld-1.7.ebuild:
diff --git a/mail-filter/gld/files/Makefile.in b/mail-filter/gld/files/Makefile.in
deleted file mode 100644
index 983cf3134c21..000000000000
--- a/mail-filter/gld/files/Makefile.in
+++ /dev/null
@@ -1,42 +0,0 @@
-prefix = @prefix@
-bindir = @bindir@
-DESTDIR = @destdir@
-
-INSTALL = @INSTALL@
-INSTALL_PROGRAM = @INSTALL_PROGRAM@ $(AM_INSTALL_PROGRAM_FLAGS)
-INSTALL_DATA = @INSTALL_DATA@
-INSTALL_SCRIPT = @INSTALL_SCRIPT@
-
-CC = @CC@
-MYSQL_CFLAGS = @MYSQL_CFLAGS@
-MYSQL_LIBS = @MYSQL_LIBS@
-MYSQL_PREFIX = @MYSQL_PREFIX@
-CFLAGS = @CFLAGS@ -Wall
-DEFS= @DEFS@
-
-DIST_COMMON = README Makefile.am Makefile.in configure configure.in
-
-DISTFILES = $(DIST_COMMON) $(SOURCES) $(HEADERS) $(TEXINFOS) $(EXTRA_DIST)
-
-all: gld
-
-gld: cnf.o server.o sql.o sockets.o greylist.o gld.h
- $(CC) $(CFLAGS) $(DEFS) server.o sql.o sockets.o cnf.o greylist.o $(MYSQL_LIBS) -o gld
-
-sockets.o: sockets.c sockets.h
- $(CC) $(CFLAGS) $(DEFS) -c sockets.c
-
-cnf.o: cnf.c gld.h
- $(CC) $(DEFS) -c cnf.c
-
-greylist.o: greylist.c gld.h
- $(CC) $(CFLAGS) $(DEFS) -c greylist.c
-
-sql.o: sql.c
- $(CC) $(CFLAGS) $(DEFS) $(MYSQL_CFLAGS) -c sql.c
-
-clean:
- $(RM) gld *.o
-
-distclean: clean
- $(RM) Makefile config.status config.log config.cache
diff --git a/mail-filter/gld/files/gld-1.5.2-mxgrey-fix.patch b/mail-filter/gld/files/gld-1.5.2-mxgrey-fix.patch
deleted file mode 100644
index c33644abb83b..000000000000
--- a/mail-filter/gld/files/gld-1.5.2-mxgrey-fix.patch
+++ /dev/null
@@ -1,34 +0,0 @@
---- gld-1.5.2/greylist.c 2005-04-21 05:41:09.000000000 -0400
-+++ gld-1.5.2/greylist.c 2005-10-20 14:05:05.000000000 -0400
-@@ -181,10 +181,28 @@ else
-
- if(conf->update==1)
- {
-- if(conf->lightd==1 && fnotdomain==1)
-- snprintf(query,sizeof(query)-1,"update greylist set last=%d,n=n+1 where ip='%s' and sender='%s' and recipient='%s'",ts,ip,osender,orecipient);
-+ if(ts-n>conf->mini)
-+ {
-+ if(conf->lightd==1 && fnotdomain==1)
-+ snprintf(query,sizeof(query)-1,"update greylist set last=%d,n=n+1 where ip='%s' and sender='%s' and recipient='%s'",ts,ip,osender,orecipient);
-
-- snprintf(query,sizeof(query)-1,"update greylist set last=%d,n=n+1 where ip='%s' and sender='%s' and recipient='%s'",ts,ip,sender,recipient);
-+ snprintf(query,sizeof(query)-1,"update greylist set last=%d,n=n+1 where ip='%s' and sender='%s' and recipient='%s'",ts,ip,sender,recipient);
-+ }
-+ else
-+ {
-+ //
-+ // We have NOT reached the greylist-timeout, so we do NOT increase the message-counter (SQL-field n),
-+ // because otherwise we will braek the MXGREY-option.
-+ // In fact this means that the THIRD retry will immidiately pass the greylist, as mxgrey checks only for ip and (n>1).
-+ //
-+ // 2005-08-16 martin@it4linux.de
-+ //
-+
-+ if(conf->lightd==1 && fnotdomain==1)
-+ snprintf(query,sizeof(query)-1,"update greylist set last=%d where ip='%s' and sender='%s' and recipient='%s'",ts,ip,osender,orecipient);
-+
-+ snprintf(query,sizeof(query)-1,"update greylist set last=%d where ip='%s' and sender='%s' and recipient='%s'",ts,ip,sender,recipient);
-+ }
-
- SQLQuery(query);
- if(conf->debug==1) printf("%d: Query=(%s)\n",pid,query);
diff --git a/mail-filter/gld/gld-1.5.2.ebuild b/mail-filter/gld/gld-1.5.2.ebuild
deleted file mode 100644
index 37b48645af10..000000000000
--- a/mail-filter/gld/gld-1.5.2.ebuild
+++ /dev/null
@@ -1,65 +0,0 @@
-# Copyright 1999-2008 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/mail-filter/gld/gld-1.5.2.ebuild,v 1.7 2008/05/21 16:03:03 dev-zero Exp $
-
-inherit eutils
-
-DESCRIPTION="A standalone anti-spam greylisting algorithm on top of Postfix"
-HOMEPAGE="http://www.gasmi.net/gld.html"
-SRC_URI="http://www.gasmi.net/down/${P}.tgz"
-
-LICENSE="GPL-2"
-SLOT="0"
-KEYWORDS="amd64 ppc x86"
-IUSE="postgres"
-# Not adding a mysql USE flag. The package defaults to it, so we will too.
-DEPEND="virtual/libc
- sys-libs/zlib
- >=dev-libs/openssl-0.9.6
- postgres? ( virtual/postgresql-server )
- !postgres? ( virtual/mysql )"
-RDEPEND="${DEPEND}
- >=mail-mta/postfix-2.1"
-
-src_unpack() {
- unpack ${A}
- cd ${S}
- epatch ${FILESDIR}/${P}-mxgrey-fix.patch
-}
-
-src_compile() {
- # It's kind of weird. $(use_with postgres pgsql) won't work...
- if use postgres ; then
- myconf="${myconf} --with-pgsql"
- fi
-
- econf ${myconf} \
- || die "econf failed"
- emake || die "emake failed"
-}
-
-src_install() {
- dobin gld
-
- insinto /etc
- newins gld.conf gld.conf.sample
- dosed 's:^LOOPBACKONLY=.*:LOOPBACKONLY=1:' /etc/gld.conf.sample
- dosed 's:^#USER=.*:USER=nobody:' /etc/gld.conf.sample
- dosed 's:^#GROUP=.*:GROUP=nobody:' /etc/gld.conf.sample
-
- dodoc HISTORY README*
-
- insinto /usr/share/${PN}/sql
- doins table*
-
- newinitd ${FILESDIR}/gld.rc gld
-}
-
-pkg_postinst() {
- echo
- elog "Please read /usr/share/doc/${PF}/README.gz for details on how to setup"
- elog "gld."
- elog
- elog "The tables.*sql files are located at /usr/share/${PN}/sql."
- echo
-}
diff --git a/mail-filter/gld/gld-1.6.ebuild b/mail-filter/gld/gld-1.6.ebuild
deleted file mode 100644
index 9035e14539f7..000000000000
--- a/mail-filter/gld/gld-1.6.ebuild
+++ /dev/null
@@ -1,63 +0,0 @@
-# Copyright 1999-2008 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/mail-filter/gld/gld-1.6.ebuild,v 1.7 2008/05/21 16:03:03 dev-zero Exp $
-
-DESCRIPTION="A standalone anti-spam greylisting algorithm on top of Postfix"
-HOMEPAGE="http://www.gasmi.net/gld.html"
-SRC_URI="http://www.gasmi.net/down/${P}.tgz"
-
-LICENSE="GPL-2"
-SLOT="0"
-KEYWORDS="amd64 ppc x86"
-IUSE="postgres"
-# Not adding a mysql USE flag. The package defaults to it, so we will too.
-DEPEND="virtual/libc
- sys-libs/zlib
- >=dev-libs/openssl-0.9.6
- postgres? ( virtual/postgresql-server )
- !postgres? ( virtual/mysql )"
-RDEPEND="${DEPEND}
- >=mail-mta/postfix-2.1"
-
-src_unpack() {
- unpack ${A}
- cd ${S}
-# cp ${FILESDIR}/Makefile.in ${S}/Makefile.in
-}
-
-src_compile() {
- # It's kind of weird. $(use_with postgres pgsql) won't work...
- if use postgres ; then
- myconf="${myconf} --with-pgsql"
- fi
-
- econf ${myconf} \
- || die "econf failed"
- emake || die "emake failed"
-}
-
-src_install() {
- dobin gld
-
- insinto /etc
- newins gld.conf gld.conf.sample
- dosed 's:^LOOPBACKONLY=.*:LOOPBACKONLY=1:' /etc/gld.conf.sample
- dosed 's:^#USER=.*:USER=nobody:' /etc/gld.conf.sample
- dosed 's:^#GROUP=.*:GROUP=nobody:' /etc/gld.conf.sample
-
- dodoc HISTORY README*
-
- insinto /usr/share/${PN}/sql
- doins table*
-
- newinitd ${FILESDIR}/gld.rc gld
-}
-
-pkg_postinst() {
- elog
- elog "Please read /usr/share/doc/${PF}/README.gz for details on how to setup"
- elog "gld."
- elog
- elog "The sql files have been installed to /usr/share/${PN}/sql."
- elog
-}
diff --git a/mail-filter/gld/gld-1.7.ebuild b/mail-filter/gld/gld-1.7.ebuild
index 6ead6c9d9f93..493726e2f2c9 100644
--- a/mail-filter/gld/gld-1.7.ebuild
+++ b/mail-filter/gld/gld-1.7.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2008 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/mail-filter/gld/gld-1.7.ebuild,v 1.7 2008/05/21 16:03:03 dev-zero Exp $
+# $Header: /var/cvsroot/gentoo-x86/mail-filter/gld/gld-1.7.ebuild,v 1.8 2008/06/15 09:34:55 dertobi123 Exp $
DESCRIPTION="A standalone anti-spam greylisting algorithm on top of Postfix"
HOMEPAGE="http://www.gasmi.net/gld.html"
@@ -16,7 +16,6 @@ DEPEND="virtual/libc
>=dev-libs/openssl-0.9.6
postgres? ( virtual/postgresql-server )
!postgres? ( virtual/mysql )"
-RDEPEND=">=mail-mta/postfix-2.1"
src_compile() {
# It's kind of weird. $(use_with postgres pgsql) won't work if you don't
@@ -42,9 +41,9 @@ src_install() {
dodoc HISTORY README*
insinto /usr/share/${PN}/sql
- doins *.pgsql *-whitelist.sql ${FILESDIR}/tables.sql
+ doins *.pgsql *-whitelist.sql "${FILESDIR}"/tables.sql
- newinitd ${FILESDIR}/gld.rc gld
+ newinitd "${FILESDIR}"/gld.rc gld
}
pkg_postinst() {