summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--app-shells/sash/files/digest1
-rw-r--r--app-shells/sash/sash-3.4-r2.ebuild44
2 files changed, 45 insertions, 0 deletions
diff --git a/app-shells/sash/files/digest b/app-shells/sash/files/digest
index d8d6a75468ab..7974abfbe86e 100644
--- a/app-shells/sash/files/digest
+++ b/app-shells/sash/files/digest
@@ -1 +1,2 @@
MD5 9c631eb171371b69276ff6692100beb6 sash-3.4.tar.gz
+MD5 43cbfb670d42e6e15b58f3b528f75ca0 sash-3.x-readline.diff.gz
diff --git a/app-shells/sash/sash-3.4-r2.ebuild b/app-shells/sash/sash-3.4-r2.ebuild
new file mode 100644
index 000000000000..9b054b4b292b
--- /dev/null
+++ b/app-shells/sash/sash-3.4-r2.ebuild
@@ -0,0 +1,44 @@
+# Copyright 1999-2000 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License, v2 or later
+# Author Achim Gottinger <achim@gentoo.org>
+# $Header: /var/cvsroot/gentoo-x86/app-shells/sash/sash-3.4-r2.ebuild,v 1.1 2000/08/15 16:11:14 achim Exp $
+
+P=sash-3.4
+A="${P}.tar.gz sash-3.x-readline.diff.gz"
+S=${WORKDIR}/${P}
+DESCRIPTION="A small UNIX Shell with readline suppport"
+SRC_URI="http://www.canb.auug.org.au/~dbell/programs/${P}.tar.gz
+ http://dimavb.st.simbirsk.su/vlk/sash-3.x-readline.diff.gz"
+
+HOMEPAGE="http://www.canb.auug.org.au/~dbell/ http://dimavb.st.simbirsk.su/vlk/"
+CATEGORY="app-shells"
+
+src_unpack() {
+ unpack ${P}.tar.gz
+ cd ${S}
+ gzip -dc ${DISTDIR}/sash-3.x-readline.diff.gz | patch -p1
+ cp Makefile Makefile.orig
+ sed -e "s:-O3:${CFLAGS}:" \
+ -e "s:-ltermcap:-lncurses:" Makefile.orig > Makefile
+}
+src_compile() {
+ cd ${S}
+
+ make
+}
+
+src_install() {
+ cd ${S}
+ into /
+ dobin sash
+ into /usr
+ doman sash.1
+ dodoc README
+
+}
+
+
+
+
+
+