summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--app-misc/pyge/ChangeLog11
-rw-r--r--app-misc/pyge/Manifest5
-rw-r--r--app-misc/pyge/files/digest-pyge-0.6.1.21
-rw-r--r--app-misc/pyge/files/help_file_location-0.6.1.2.diff23
-rw-r--r--app-misc/pyge/metadata.xml6
-rw-r--r--app-misc/pyge/pyge-0.6.1.2.ebuild38
6 files changed, 84 insertions, 0 deletions
diff --git a/app-misc/pyge/ChangeLog b/app-misc/pyge/ChangeLog
new file mode 100644
index 000000000000..0ac4f1195ef3
--- /dev/null
+++ b/app-misc/pyge/ChangeLog
@@ -0,0 +1,11 @@
+# ChangeLog for app-misc/pyge
+# Copyright 2000-2004 Gentoo Technologies, Inc.; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/app-misc/pyge/ChangeLog,v 1.1 2004/06/20 06:29:31 pythonhead Exp $
+
+*pyge-0.6.1.2 (19 Jun 2004)
+
+ 19 Jun 2004; Rob Cakebread <pythonhead@gentoo.org> +metadata.xml,
+ +files/help_file_location-0.6.1.2.diff, +pyge-0.6.1.2.ebuild:
+ Initial commit bug# 54044. Thanks Tim Cera <timcera@earthlink.net> for the
+ ebuild
+
diff --git a/app-misc/pyge/Manifest b/app-misc/pyge/Manifest
new file mode 100644
index 000000000000..647eb231ed0c
--- /dev/null
+++ b/app-misc/pyge/Manifest
@@ -0,0 +1,5 @@
+MD5 50d6d555e53cdec96cfe73ae885eb0d5 ChangeLog 370
+MD5 32ba5ade82b89e6676d47aa3e8179558 metadata.xml 259
+MD5 c278c75951d7843c1f4994f25b5dc392 pyge-0.6.1.2.ebuild 1019
+MD5 ca969589b19856ea4d1bbfca575b1582 files/help_file_location-0.6.1.2.diff 997
+MD5 ebf2a39f875d0725058cb69912784e25 files/digest-pyge-0.6.1.2 64
diff --git a/app-misc/pyge/files/digest-pyge-0.6.1.2 b/app-misc/pyge/files/digest-pyge-0.6.1.2
new file mode 100644
index 000000000000..c67138c1e6d3
--- /dev/null
+++ b/app-misc/pyge/files/digest-pyge-0.6.1.2
@@ -0,0 +1 @@
+MD5 3c164b166df02034b0e9d2b5daece821 PyGE-0.6.1.2.tar.gz 720970
diff --git a/app-misc/pyge/files/help_file_location-0.6.1.2.diff b/app-misc/pyge/files/help_file_location-0.6.1.2.diff
new file mode 100644
index 000000000000..b438cad6a73c
--- /dev/null
+++ b/app-misc/pyge/files/help_file_location-0.6.1.2.diff
@@ -0,0 +1,23 @@
+--- PyGE-0.6.1.2/PyGE/common_gui.py 2004-06-15 18:28:54.409326272 -0400
++++ PyGE-0.6.1.2/PyGE/common_gui.py 2004-06-15 20:41:55.481018952 -0400
+@@ -235,7 +235,7 @@
+ if os.path.isfile(fileName):
+ return fileName
+ else:
+- testList = []
++ testList = ['/usr/share/pyge/']
+ if sys.argv[0]:
+ testList.append(os.path.abspath(sys.argv[0]))
+ testList.append(sys.executable)
+--- PyGE-0.6.1.2/setup.py 2004-06-15 18:28:55.242199656 -0400
++++ PyGE-0.6.1.2/setup.py 2004-06-15 20:49:16.775931928 -0400
+@@ -20,7 +20,8 @@
+ derived from Project Gutenberg source files.
+ """,
+ packages = ["PyGE","PyritePublisher"],
+- data_files = [("", ["SampleData/gutenberg.xml","SampleData/gutenberg.idx",
++ data_files = [("/usr/share/pyge", ["SampleData/gutenberg.xml",
++ "SampleData/gutenberg.idx",
+ "SampleData/gutenberg.hst","SampleData/getty11.pdb",
+ "pygers.htb","pygemz.htb","pygets.htb"])],
+ scripts = scripts,
diff --git a/app-misc/pyge/metadata.xml b/app-misc/pyge/metadata.xml
new file mode 100644
index 000000000000..7379192e82e4
--- /dev/null
+++ b/app-misc/pyge/metadata.xml
@@ -0,0 +1,6 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>python</herd>
+<longdescription>Gutenberg text downloader and viewer with optional speech output.</longdescription>
+</pkgmetadata> \ No newline at end of file
diff --git a/app-misc/pyge/pyge-0.6.1.2.ebuild b/app-misc/pyge/pyge-0.6.1.2.ebuild
new file mode 100644
index 000000000000..3e8b82b2c595
--- /dev/null
+++ b/app-misc/pyge/pyge-0.6.1.2.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2004 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-misc/pyge/pyge-0.6.1.2.ebuild,v 1.1 2004/06/20 06:29:31 pythonhead Exp $
+
+inherit eutils
+
+MY_P=${P/pyge/PyGE}
+
+S="${WORKDIR}/${MY_P}"
+DESCRIPTION="Python Gutenberg E-text (PyGE) project, contains a Gutenberg E-text reader, and utilities for retrieval and compression."
+HOMEPAGE="http://pyge.sourceforge.net"
+SRC_URI="mirror://sourceforge/pyge/${MY_P}.tar.gz"
+LICENSE="Artistic"
+SLOT="0"
+KEYWORDS="~x86"
+IUSE=""
+DEPEND=">=dev-lang/python-2.1
+ >=dev-python/wxPython-2.4"
+
+src_install() {
+ python setup.py install --root=${D} --prefix=/usr || die "setup.py install failed"
+}
+
+src_unpack() {
+ unpack ${A}
+ cd ${S}
+ epatch ${FILESDIR}/help_file_location-${PV}.diff
+ mv pygers.pyw pygers
+ mv pygets.pyw pygets
+ mv pygemz.pyw pygemz
+ sed -i "s/.pyw//g" setup.py || die "Failed on sed setup.py"
+}
+
+pkg_postinst() {
+ einfo "You can find a sample database in /usr/share/pyge/gutenberg.xml"
+ einfo "For speech output you may optionally install app-accessibility/festival"
+}
+