summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--net-analyzer/ntop/ChangeLog9
-rw-r--r--net-analyzer/ntop/files/globals-core.c.diff11
-rw-r--r--net-analyzer/ntop/files/ntop-3.2-build.patch243
-rw-r--r--net-analyzer/ntop/files/ntop-3.2-snmp.patch34
-rw-r--r--net-analyzer/ntop/files/ntop-3.3.6-gentoo.patch41
-rw-r--r--net-analyzer/ntop/files/ntop-3.3.8-gentoo.patch41
-rw-r--r--net-analyzer/ntop/ntop-3.2-r3.ebuild102
-rw-r--r--net-analyzer/ntop/ntop-3.3.6.ebuild116
-rw-r--r--net-analyzer/ntop/ntop-3.3.8.ebuild115
-rw-r--r--net-analyzer/ntop/ntop-3.3.9-r2.ebuild7
10 files changed, 11 insertions, 708 deletions
diff --git a/net-analyzer/ntop/ChangeLog b/net-analyzer/ntop/ChangeLog
index 47252f81cd28..bf6e08c51dd5 100644
--- a/net-analyzer/ntop/ChangeLog
+++ b/net-analyzer/ntop/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for net-analyzer/ntop
# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-analyzer/ntop/ChangeLog,v 1.77 2009/04/27 15:37:00 jer Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-analyzer/ntop/ChangeLog,v 1.78 2009/05/02 08:32:46 mrness Exp $
+
+ 02 May 2009; Alin Năstac <mrness@gentoo.org> -files/ntop-3.2-build.patch,
+ -files/ntop-3.2-snmp.patch, -files/ntop-3.3.6-gentoo.patch,
+ -files/ntop-3.3.8-gentoo.patch, -files/globals-core.c.diff,
+ -ntop-3.2-r3.ebuild, -ntop-3.3.6.ebuild, -ntop-3.3.8.ebuild,
+ ntop-3.3.9-r2.ebuild:
+ Remove nls USE flag and correct tcpd configure argument (#267660).
27 Apr 2009; Jeroen Roovers <jer@gentoo.org> ntop-3.3.9-r2:
Stable for HPPA (bug #265704).
diff --git a/net-analyzer/ntop/files/globals-core.c.diff b/net-analyzer/ntop/files/globals-core.c.diff
deleted file mode 100644
index 778c4bbc57c2..000000000000
--- a/net-analyzer/ntop/files/globals-core.c.diff
+++ /dev/null
@@ -1,11 +0,0 @@
---- globals-core.c.old 2004-12-13 19:05:33.000000000 +0100
-+++ globals-core.c 2005-01-14 13:21:41.133917120 +0100
-@@ -473,7 +473,7 @@
- _mtuSize[DLT_ATM_RFC1483] = 9180 /* LLC/SNAP encapsulated atm */;
- _headerSize[DLT_ATM_RFC1483] = 0;
-
-- /* _mtuSize[DLT_RAW] = ? raw IP */
-+ _mtuSize[DLT_RAW] = 1500; /* raw IP */
- _headerSize[DLT_RAW] = 0;
-
- /* Others defined in bpf.h at tcpdump.org as of the resync - it would be NICE
diff --git a/net-analyzer/ntop/files/ntop-3.2-build.patch b/net-analyzer/ntop/files/ntop-3.2-build.patch
deleted file mode 100644
index eae246978929..000000000000
--- a/net-analyzer/ntop/files/ntop-3.2-build.patch
+++ /dev/null
@@ -1,243 +0,0 @@
-cleanup autotools
-
---- plugins/Makefile.am
-+++ plugins/Makefile.am
-@@ -101,96 +101,31 @@ libxmldumpPlugin_la_CFLAGS = $(AM_CFLAGS
- # by default ntop looks for plugins in the plugins/ subdirectory
- #
-
-+%Plugin.so$(EXEEXT): .libs/lib%Plugin.so
-+ $(LN_S) $< $@
-
--.libs/libicmpPlugin.so@SO_VERSION_PATCH@:
-- @if test -f libicmpPlugin_la-icmpPlugin.o; then \
-- $(CC) @MAKE_SHARED_LIBRARY_PARM@ -o .libs/libicmpPlugin.so@SO_VERSION_PATCH@ libicmpPlugin_la-icmpPlugin.o; \
-- else \
-- $(CC) @MAKE_SHARED_LIBRARY_PARM@ -o .libs/libicmpPlugin.so@SO_VERSION_PATCH@ icmpPlugin.o; \
-- fi
--
--icmpPlugin.so$(EXEEXT): .libs/libicmpPlugin.so@SO_VERSION_PATCH@
-- @$(LN_S) .libs/libicmpPlugin.so icmpPlugin.so
--
--.libs/liblastSeenPlugin.so@SO_VERSION_PATCH@:
-- @if test -f liblastSeenPlugin_la-lastSeenPlugin.o; then \
-- $(CC) @MAKE_SHARED_LIBRARY_PARM@ -o .libs/liblastSeenPlugin.so@SO_VERSION_PATCH@ liblastSeenPlugin_la-lastSeenPlugin.o; \
-- else \
-- $(CC) @MAKE_SHARED_LIBRARY_PARM@ -o .libs/liblastSeenPlugin.so@SO_VERSION_PATCH@ lastSeenPlugin.o; \
-- fi
--
--lastSeenPlugin.so$(EXEEXT): .libs/liblastSeenPlugin.so@SO_VERSION_PATCH@
-- @$(LN_S) .libs/liblastSeenPlugin.so lastSeenPlugin.so
--
--.libs/libnetflowPlugin.so@SO_VERSION_PATCH@:
-- @if test -f libnetflowPlugin_la-netflowPlugin.o; then \
-- $(CC) @MAKE_SHARED_LIBRARY_PARM@ -o .libs/libnetflowPlugin.so@SO_VERSION_PATCH@ libnetflowPlugin_la-netflowPlugin.o; \
-- else \
-- $(CC) @MAKE_SHARED_LIBRARY_PARM@ -o .libs/libnetflowPlugin.so@SO_VERSION_PATCH@ netflowPlugin.o; \
-- fi
--
--netflowPlugin.so$(EXEEXT): .libs/libnetflowPlugin.so@SO_VERSION_PATCH@
-- @$(LN_S) .libs/libnetflowPlugin.so netflowPlugin.so
--
--.libs/libpdaPlugin.so@SO_VERSION_PATCH@:
-- @if test -f libpdaPlugin_la-pdaPlugin.o; then \
-- $(CC) @MAKE_SHARED_LIBRARY_PARM@ -o .libs/libpdaPlugin.so@SO_VERSION_PATCH@ libpdaPlugin_la-pdaPlugin.o; \
-- else \
-- $(CC) @MAKE_SHARED_LIBRARY_PARM@ -o .libs/libpdaPlugin.so@SO_VERSION_PATCH@ pdaPlugin.o; \
-- fi
--
--pdaPlugin.so$(EXEEXT): .libs/libpdaPlugin.so@SO_VERSION_PATCH@
-- @$(LN_S) .libs/libpdaPlugin.so pdaPlugin.so
--
--.libs/librrdPlugin.so@SO_VERSION_PATCH@:
-- @if test -f librrdPlugin_la-rrdPlugin.o; then \
-- $(CC) @MAKE_SHARED_LIBRARY_PARM@ -o .libs/librrdPlugin.so@SO_VERSION_PATCH@ librrdPlugin_la-rrdPlugin.o; \
-- else \
-- $(CC) @MAKE_SHARED_LIBRARY_PARM@ -o .libs/librrdPlugin.so@SO_VERSION_PATCH@ rrdPlugin.o; \
-- fi
--
--rrdPlugin.so$(EXEEXT): .libs/librrdPlugin.so@SO_VERSION_PATCH@
-- @$(LN_S) .libs/librrdPlugin.so rrdPlugin.so
--
--.libs/libsnmpPlugin.so@SO_VERSION_PATCH@:
-- @if test -f libsnmpPlugin_la-snmpPlugin.o; then \
-- $(CC) @MAKE_SHARED_LIBRARY_PARM@ -o .libs/libsnmpPlugin.so@SO_VERSION_PATCH@ libsnmpPlugin_la-snmpPlugin.o; \
-- else \
-- $(CC) @MAKE_SHARED_LIBRARY_PARM@ -o .libs/libsnmpPlugin.so@SO_VERSION_PATCH@ snmpPlugin.o; \
-- fi
--
--snmpPlugin.so$(EXEEXT): .libs/libsnmpPlugin.so@SO_VERSION_PATCH@
-- @$(LN_S) .libs/libsnmpPlugin.so snmpPlugin.so
--
--.libs/libsflowPlugin.so@SO_VERSION_PATCH@:
-- @if test -f libsflowPlugin_la-sflowPlugin.o; then \
-- $(CC) @MAKE_SHARED_LIBRARY_PARM@ -o .libs/libsflowPlugin.so@SO_VERSION_PATCH@ libsflowPlugin_la-sflowPlugin.o; \
-- else \
-- $(CC) @MAKE_SHARED_LIBRARY_PARM@ -o .libs/libsflowPlugin.so@SO_VERSION_PATCH@ sflowPlugin.o; \
-- fi
--
--sflowPlugin.so$(EXEEXT): .libs/libsflowPlugin.so@SO_VERSION_PATCH@
-- @$(LN_S) .libs/libsflowPlugin.so sflowPlugin.so
--
--.libs/libxmldumpPlugin.so@SO_VERSION_PATCH@:
-- @if test -f libxmldumpPlugin_la-xmldumpPlugin.o; then \
-- $(CC) @MAKE_SHARED_LIBRARY_PARM@ -o .libs/libxmldumpPlugin.so@SO_VERSION_PATCH@ libxmldumpPlugin_la-xmldumpPlugin.o; \
-- else \
-- $(CC) @MAKE_SHARED_LIBRARY_PARM@ -o .libs/libxmldumpPlugin.so@SO_VERSION_PATCH@ xmldumpPlugin.o; \
-- fi
-+# Need to make sure autotools doesn't insert rules for us
-+icmpPlugin.so$(EXEEXT): .libs/libicmpPlugin.so
-+lastSeenPlugin.so$(EXEEXT): .libs/liblastSeenPlugin.so
-+netflowPlugin.so$(EXEEXT): .libs/libnetflowPlugin.so
-+pdaPlugin.so$(EXEEXT): .libs/libpdaPlugin.so
-+rrdPlugin.so$(EXEEXT): .libs/librrdPlugin.so
-+snmpPlugin.so$(EXEEXT): .libs/libsnmpPlugin.so
-+sflowPlugin.so$(EXEEXT): .libs/libsflowPlugin.so
-+xmldumpPlugin.so$(EXEEXT): .libs/libxmldumpPlugin.so
-
--xmldumpPlugin.so$(EXEEXT): .libs/libxmldumpPlugin.so@SO_VERSION_PATCH@
-- @$(LN_S) .libs/libxmldumpPlugin.so xmldumpPlugin.so
-+#
-+# Create symlinks for the plugins
-+#
-
- install-data-local:
-- @$(top_srcdir)/mkinstalldirs $(DESTDIR)$(plugindir);
-- @for file in $(noinst_PROGRAMS); do \
-- cp -p $$file $(DESTDIR)$(plugindir)/$$file; \
-- done
--# remove installed libraries
-- @for file in $(lib_LTLIBRARIES); do \
-- rm -f $(DESTDIR)$(libdir)/$$file; \
-- done
-+ for file in $(lib_LTLIBRARIES); do \
-+ rm -f $(DESTDIR)$(libdir)/$$file; \
-+ done
-+ $(top_srcdir)/mkinstalldirs $(DESTDIR)$(plugindir)
-+ for file in $(noinst_PROGRAMS) ; do \
-+ $(LN_S) $(libdir)/lib$$file $(DESTDIR)$(plugindir)/$$file ; \
-+ done
-
- #
- # Special stuff for xml auto-generation of code from the "doc":
---- configure.in
-+++ configure.in
-@@ -180,7 +180,7 @@
- dnl> Test before we use it, below
- AC_ARG_ENABLE(iknowbetter,
- [ --enable-iknowbetter Override WILLFAIL],
-- ac_willfailoverride="yes",
-+ ac_willfailoverride="$enableval",
- ac_willfailoverride="no")
-
- AC_ARG_ENABLE(void,
-@@ -665,63 +665,83 @@
-
- AC_ARG_WITH(ssl,
- [ --without-ssl disable HTPPS support [[default=enabled]]],
-- ac_disable_openssl="yes",
-+ if test "x$withval" = xno; then
-+ ac_disable_openssl="yes"
-+ else
-+ ac_disable_openssl="no"
-+ fi,
- ac_disable_openssl="no")
-
- AC_ARG_WITH(zlib,
- [ --without-zlib disable zlib [[default=enabled]]],
-- ac_disable_zlib="yes",
-+ if test "x$withval" = xno; then
-+ ac_disable_zlib="yes"
-+ else
-+ ac_disable_zlib="no"
-+ fi,
- ac_disable_zlib="no")
-
- AC_ARG_ENABLE(sslv3,
- [ --enable-sslv3 enable ssl v3 support [[default=disabled]]],
-- ac_enable_sslv3="yes",
-+ ac_enable_sslv3="$enableval",
- ac_enable_sslv3="no")
-
- AC_ARG_ENABLE(sslwatchdog,
- [ --enable-sslwatchdog enable Watchdog for ssl hangups [[default=disabled]]],
-- ac_enable_sslwatchdog="yes",
-+ ac_enable_sslwatchdog="$enableval",
- ac_enable_sslwatchdog="no")
-
- AC_ARG_WITH(tcpwrap,
- [ --with-tcpwrap enable use of TCP Wrapper [[default=disabled]]],
-- ac_enable_tcpwrap="yes",
-+ ac_enable_tcpwrap="$withval",
- ac_enable_tcpwrap="no")
-
- AC_ARG_ENABLE(plugins,
- [ --disable-plugins disable compilation of plugins [[default=enabled]]],
-- ac_disable_plugins="yes",
-+ if test "x$enableval" = xno; then
-+ ac_disable_plugins="yes"
-+ else
-+ ac_disable_plugins="no"
-+ fi,
- ac_disable_plugins="no")
-
- AC_ARG_ENABLE( static-plugins,
- [ --enable-static-plugins Enable static linked plugins [sntop, default=dynamic]]],
-- ac_enable_static_plugins="yes",
-- ac_enable_static_plugins="no")
-+ ac_enable_static_plugins="$enableval",
-+ ac_enable_static_plugins="no")
-
- AC_ARG_ENABLE(ignoresigpipe,
- [ --enable-ignoresigpipe Ignore SIGPIPE errors [[default=do not ignore]]],
-- ac_enable_ignoresigpipe="yes",
-+ ac_enable_ignoresigpipe="$enableval",
- ac_enable_ignoresigpipe="no")
-
- AC_ARG_ENABLE(snmp,
- [ --disable-snmp Disable SNMP support [[default=disable]]],
-- ac_disable_snmp="no",
-+ if test "x$enableval" = xno; then
-+ ac_disable_snmp="yes"
-+ else
-+ ac_disable_snmp="no"
-+ fi,
- ac_disable_snmp="yes")
-
- AC_ARG_ENABLE(i18n,
- [ --enable-i18n Enable (limited) internationalization [[default=disabled]]],
-- ac_enable_i18n="yes",
-+ ac_enable_i18n="$enableval",
- ac_enable_i18n="no")
-
- AC_ARG_ENABLE(jumbo-frames,
- [ --enable-jumbo-frames Enable Jumbo (9K) Ethernet frames [[default=disabled]]],
-- ac_enable_jumbo-frames="yes",
-+ ac_enable_jumbo-frames="$enableval",
- ac_enable_jumbo-frames="no")
-
- AC_ARG_ENABLE(ipv6,
- [ --disable-ipv6 use IPv6 [[default=enabled]]],
-- ac_disable_ipv6="yes",
-- ac_disable_ipv6="no")
-+ if test "x$enableval" = xno; then
-+ ac_disable_ipv6="yes"
-+ else
-+ ac_disable_ipv6="no"
-+ fi,
-+ ac_disable_ipv6="no")
-
- dnl>
- dnl> Define the "WITH"s for package root directories ... deal with these later...
-@@ -1011,11 +1011,6 @@
- LOCALEDIR="/usr/lib/locale"
- fi
-
--dnl> Add /usr/local/
--CFLAGS="${CFLAGS} -I/usr/local/include"
--CPPFLAGS="${CPPFLAGS} -I/usr/local/include"
--LDFLAGS="${LDFLAGS} -L/usr/local/lib"
--
-
-
- echo
diff --git a/net-analyzer/ntop/files/ntop-3.2-snmp.patch b/net-analyzer/ntop/files/ntop-3.2-snmp.patch
deleted file mode 100644
index a5b60f71d347..000000000000
--- a/net-analyzer/ntop/files/ntop-3.2-snmp.patch
+++ /dev/null
@@ -1,34 +0,0 @@
---- plugins.orig/snmpPlugin.c 2005-05-28 13:15:02.000000000 +0000
-+++ plugins/snmpPlugin.c 2006-02-01 13:41:13.000000000 +0000
-@@ -46,6 +46,9 @@
- #include "ntop.h"
- #include "globals-report.h"
-
-+// undefine free() wrapper Macro so net-snmp library uses the original free() and not the
-+// ntop_safefree() one.
-+#undef free
-
- #ifdef HAVE_SNMP
-
-@@ -58,11 +61,21 @@
- #include <net-snmp/net-snmp-includes.h>
- #include <net-snmp/agent/net-snmp-agent-includes.h>
-
-+#endif
-+
-+// redefine the Macro so the rest of the file uses it //
-+#define free(a) ntop_safefree((void**)&(a), __FILE__, __LINE__)
-+
-+#ifdef HAVE_SNMP
-+
-+
- // #ifndef NTOP_H
- #define NTOP_H
- // #ifndef NTOP_COLUMNS_H
- #define NTOP_COLUMNS_H
-
-+
-+
- /*
- * column number definitions for table ntopTable
- */
diff --git a/net-analyzer/ntop/files/ntop-3.3.6-gentoo.patch b/net-analyzer/ntop/files/ntop-3.3.6-gentoo.patch
deleted file mode 100644
index fa51578ff6ea..000000000000
--- a/net-analyzer/ntop/files/ntop-3.3.6-gentoo.patch
+++ /dev/null
@@ -1,41 +0,0 @@
-diff -Nru ntop.orig/configure.in ntop/configure.in
---- ntop.orig/configure.in 2008-06-04 09:29:06.000000000 +0200
-+++ ntop/configure.in 2008-07-05 00:40:53.000000000 +0200
-@@ -515,13 +515,6 @@
- LOCALEDIR="/usr/lib/locale"
- fi
-
--dnl> Add /usr/local/
--CFLAGS="${CFLAGS} -I/usr/local/include -I/opt/local/include"
--CPPFLAGS="${CPPFLAGS} -I/usr/local/include -I/opt/local/include"
--LDFLAGS="${LDFLAGS} -L/usr/local/lib -L/opt/local/lib"
--
--
--
- echo
- echo "Test the compiler and setup CFLAGS..."
- echo
-diff -Nru ntop.orig/globals-core.c ntop/globals-core.c
---- ntop.orig/globals-core.c 2007-11-24 19:26:29.000000000 +0100
-+++ ntop/globals-core.c 2008-07-05 00:48:09.000000000 +0200
-@@ -427,7 +427,7 @@
- _mtuSize[DLT_ATM_RFC1483] = 9180 /* LLC/SNAP encapsulated atm */;
- _headerSize[DLT_ATM_RFC1483] = 0;
-
-- /* _mtuSize[DLT_RAW] = ? raw IP */
-+ _mtuSize[DLT_RAW] = 1500 /* raw IP */;
- _headerSize[DLT_RAW] = 0;
-
- /* Others defined in bpf.h at tcpdump.org as of the resync - it would be NICE
-diff -Nru ntop.orig/report.c ntop/report.c
---- ntop.orig/report.c 2008-04-05 17:56:58.000000000 +0200
-+++ ntop/report.c 2008-07-05 01:09:36.000000000 +0200
-@@ -2301,7 +2301,7 @@
- if(fetchPrefsValue("dot.path", buf, sizeof(buf)) != -1) {
- snprintf(dotPath, sizeof(dotPath), "%s", buf);
- } else {
-- snprintf(dotPath, sizeof(dotPath), "/usr/local/bin/dot");
-+ snprintf(dotPath, sizeof(dotPath), "/usr/bin/dot");
- storePrefsValue("dot.path", dotPath); /* Set the default */
- }
-
diff --git a/net-analyzer/ntop/files/ntop-3.3.8-gentoo.patch b/net-analyzer/ntop/files/ntop-3.3.8-gentoo.patch
deleted file mode 100644
index 5614ac31a648..000000000000
--- a/net-analyzer/ntop/files/ntop-3.3.8-gentoo.patch
+++ /dev/null
@@ -1,41 +0,0 @@
-diff -ur ntop-3.3.8.orig/configure.in ntop-3.3.8/configure.in
---- ntop-3.3.8.orig/configure.in 2008-10-02 10:54:15.000000000 +0000
-+++ ntop-3.3.8/configure.in 2008-10-05 10:39:47.000000000 +0000
-@@ -504,13 +504,6 @@
- LOCALEDIR="/usr/lib/locale"
- fi
-
--dnl> Add /usr/local/
--CFLAGS="${CFLAGS} -I/usr/local/include -I/opt/local/include"
--CPPFLAGS="${CPPFLAGS} -I/usr/local/include -I/opt/local/include"
--LDFLAGS="${LDFLAGS} -L/usr/local/lib -L/opt/local/lib"
--
--
--
- echo
- echo "Test the compiler and setup CFLAGS..."
- echo
-diff -ur ntop-3.3.8.orig/globals-core.c ntop-3.3.8/globals-core.c
---- ntop-3.3.8.orig/globals-core.c 2008-10-01 21:03:36.000000000 +0000
-+++ ntop-3.3.8/globals-core.c 2008-10-05 10:39:47.000000000 +0000
-@@ -424,7 +424,7 @@
- _mtuSize[DLT_ATM_RFC1483] = 9180 /* LLC/SNAP encapsulated atm */;
- _headerSize[DLT_ATM_RFC1483] = 0;
-
-- /* _mtuSize[DLT_RAW] = ? raw IP */
-+ _mtuSize[DLT_RAW] = 1500 /* raw IP */;
- _headerSize[DLT_RAW] = 0;
-
- /* Others defined in bpf.h at tcpdump.org as of the resync - it would be NICE
-diff -ur ntop-3.3.8.orig/report.c ntop-3.3.8/report.c
---- ntop-3.3.8.orig/report.c 2008-08-17 21:06:33.000000000 +0000
-+++ ntop-3.3.8/report.c 2008-10-05 10:39:47.000000000 +0000
-@@ -2301,7 +2301,7 @@
- if(fetchPrefsValue("dot.path", buf, sizeof(buf)) != -1) {
- snprintf(dotPath, sizeof(dotPath), "%s", buf);
- } else {
-- snprintf(dotPath, sizeof(dotPath), "/usr/local/bin/dot");
-+ snprintf(dotPath, sizeof(dotPath), "/usr/bin/dot");
- storePrefsValue("dot.path", dotPath); /* Set the default */
- }
-
diff --git a/net-analyzer/ntop/ntop-3.2-r3.ebuild b/net-analyzer/ntop/ntop-3.2-r3.ebuild
deleted file mode 100644
index 957e46c2a929..000000000000
--- a/net-analyzer/ntop/ntop-3.2-r3.ebuild
+++ /dev/null
@@ -1,102 +0,0 @@
-# Copyright 1999-2009 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-analyzer/ntop/ntop-3.2-r3.ebuild,v 1.13 2009/03/08 10:31:35 cla Exp $
-
-EAPI="2"
-
-inherit eutils autotools
-
-DESCRIPTION="tool that shows network usage like top"
-HOMEPAGE="http://www.ntop.org/ntop.html"
-SRC_URI="mirror://sourceforge/ntop/${P}.tgz"
-
-LICENSE="GPL-2"
-SLOT="0"
-KEYWORDS="amd64 arm hppa ~ia64 ppc ~ppc64 sh sparc s390 x86"
-IUSE="ipv6 nls snmp ssl tcpd zlib"
-
-COMMON_DEPEND="sys-apps/gawk
- >=sys-libs/gdbm-1.8.0
- net-libs/libpcap
- >=media-libs/gd-2.0.22
- >=media-libs/libpng-1.2.5
- snmp? ( net-analyzer/net-snmp[ipv6] )
- ssl? ( >=dev-libs/openssl-0.9.6 )
- tcpd? ( >=sys-apps/tcp-wrappers-7.6-r4 )
- zlib? ( sys-libs/zlib )"
-DEPEND="${COMMON_DEPEND}
- >=sys-devel/libtool-1.4"
-
-# Needed by xmldumpPlugin - couldn't get it to work
-# dev-libs/gdome2
-# >=dev-libs/glib-2"
-
-RDEPEND="${COMMON_DEPEND}
- media-gfx/graphviz"
-
-pkg_setup() {
- if use snmp ; then
- ewarn "snmp plugin is under development and upstream does not recommend"
- ewarn "it for usage in production environment."
- if ! use ipv6 ; then
- echo
- eerror "snmp plugin has compilation problems without ipv6 support."
- eerror "For additional information see bug #121497."
- die "snmp without ipv6 is broken"
- fi
- fi
- enewgroup ntop
- enewuser ntop -1 -1 /var/lib/ntop ntop
-}
-
-src_unpack() {
- unpack ${A}
- cd "${S}"
- epatch "${FILESDIR}"/globals-core.c.diff
- epatch "${FILESDIR}"/${P}-build.patch
- epatch "${FILESDIR}"/${P}-snmp.patch
- eautoreconf
-
- sed -i \
- -e "s@/usr/local/bin/dot@/usr/bin/dot@" report.c || die "sed failed"
-}
-
-src_configure() {
- # force disable xmldumpPlugin
- export \
- ac_cv_header_glib_h=no \
- ac_cv_header_glibconfig_h=no \
- ac_cv_header_gdome_h=no \
- ac_cv_lib_glib_g_date_julian=no \
- ac_cv_lib_xml2_xmlCheckVersion=no \
- ac_cv_lib_gdome_gdome_di_saveDocToFile=no
-
- econf \
- $(use_enable ipv6) \
- $(use_enable nls i18n) \
- $(use_enable snmp) \
- $(use_with ssl) $(use_enable ssl sslv3) $(use_enable ssl sslwatchdog) \
- $(use_with tcpd) \
- $(use_with zlib) \
- || die "configure problem"
-}
-
-src_install() {
- emake DESTDIR="${D}" install || die "install problem"
-
- keepdir /var/lib/ntop
-
- dodoc AUTHORS CONTENTS ChangeLog MANIFESTO NEWS
- dodoc PORTING README SUPPORT_NTOP.txt THANKS $(find docs -type f)
-
- newinitd "${FILESDIR}"/ntop-initd ntop
- newconfd "${FILESDIR}"/ntop-confd ntop
-}
-
-pkg_postinst() {
- fowners ntop:ntop /var/lib/ntop
- fperms 750 /var/lib/ntop
-
- elog "You need to set a password first by running"
- elog "ntop --set-admin-password"
-}
diff --git a/net-analyzer/ntop/ntop-3.3.6.ebuild b/net-analyzer/ntop/ntop-3.3.6.ebuild
deleted file mode 100644
index 1275ec04839e..000000000000
--- a/net-analyzer/ntop/ntop-3.3.6.ebuild
+++ /dev/null
@@ -1,116 +0,0 @@
-# Copyright 1999-2008 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-analyzer/ntop/ntop-3.3.6.ebuild,v 1.2 2008/07/05 15:03:09 loki_val Exp $
-
-inherit eutils autotools
-
-DESCRIPTION="tool that shows network usage like top"
-HOMEPAGE="http://www.ntop.org/ntop.html"
-SRC_URI="mirror://sourceforge/ntop/${P}.tar.gz"
-
-LICENSE="GPL-2"
-SLOT="0"
-KEYWORDS="~amd64 ~arm ~hppa ~ia64 ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86"
-IUSE="ipv6 nls ssl tcpd zlib"
-#IUSE="ipv6 nls snmp ssl tcpd zlib"
-
-#snmp? ( net-analyzer/net-snmp )
-COMMON_DEPEND="sys-apps/gawk
- >=sys-libs/gdbm-1.8.0
- net-libs/libpcap
- >=media-libs/gd-2.0.22
- >=media-libs/libpng-1.2.5
- net-analyzer/rrdtool
- ssl? ( >=dev-libs/openssl-0.9.6 )
- tcpd? ( >=sys-apps/tcp-wrappers-7.6-r4 )
- zlib? ( sys-libs/zlib )"
-DEPEND="${COMMON_DEPEND}
- >=sys-devel/libtool-1.4"
-
-# Needed by xmldumpPlugin - couldn't get it to work
-# dev-libs/gdome2
-# >=dev-libs/glib-2"
-RDEPEND="${COMMON_DEPEND}
- media-gfx/graphviz"
-
-S="${WORKDIR}/${PN}"
-
-pkg_setup() {
- # snmp doesn't compile in this release, disabled for now
-
- #if use snmp ; then
- # ewarn "snmp plugin is under development and upstream does not recommend"
- # ewarn "it for usage in production environment."
- # if ! use ipv6 ; then
- # echo
- # eerror "snmp plugin has compilation problems without ipv6 support."
- # eerror "For additional information see bug #121497."
- # die "snmp without ipv6 is broken"
- # else
- # if ! built_with_use net-analyzer/net-snmp ipv6 ; then
- # echo
- # eerror "You have both ipv6 and snmp enabled."
- # eerror "This require ipv6 support in net-analyzer/net-snmp."
- # eerror "However, net-analyzer/net-snmp was compiled with ipv6 flag disabled."
- # eerror "Please, re-emerge net-analyzer/net-snmp with USE=\"ipv6\"."
- # die "net-analyzer/net-snmp was build without ipv6."
- # fi
- # fi
- #fi
- enewgroup ntop
- enewuser ntop -1 -1 /var/lib/ntop ntop
-}
-
-src_unpack() {
- unpack ${A}
-
- cd "${S}"
- epatch "${FILESDIR}"/${P}-gentoo.patch
- cat acinclude.m4.in acinclude.m4.ntop > acinclude.m4
- eautoreconf
- touch libtool.m4.in
-}
-
-src_compile() {
- # force disable xmldumpPlugin
- export \
- ac_cv_header_glib_h=no \
- ac_cv_header_glibconfig_h=no \
- ac_cv_header_gdome_h=no \
- ac_cv_lib_glib_g_date_julian=no \
- ac_cv_lib_xml2_xmlCheckVersion=no \
- ac_cv_lib_gdome_gdome_di_saveDocToFile=no
-
- econf \
- $(use_enable ipv6) \
- $(use_enable nls i18n) \
- $(use_with ssl) $(use_enable ssl sslv3) $(use_enable ssl sslwatchdog) \
- $(use_with tcpd) \
- $(use_with zlib) \
- --with-rrd-home=/usr/lib \
- --disable-snmp \
- || die "configure problem"
- # $(use_enable snmp)
- emake || die "compile problem"
-}
-
-src_install() {
- LC_ALL=C # apparently doesn't work with some locales (#191576 and #205382)
- emake DESTDIR="${D}" install || die "install problem"
-
- keepdir /var/lib/ntop
-
- dodoc AUTHORS CONTENTS ChangeLog MANIFESTO NEWS
- dodoc PORTING README SUPPORT_NTOP.txt THANKS $(find docs -type f)
-
- newinitd "${FILESDIR}"/ntop-initd ntop
- newconfd "${FILESDIR}"/ntop-confd ntop
-}
-
-pkg_postinst() {
- fowners ntop:ntop /var/lib/ntop
- fperms 750 /var/lib/ntop
-
- elog "You need to set a password first by running"
- elog "ntop --set-admin-password"
-}
diff --git a/net-analyzer/ntop/ntop-3.3.8.ebuild b/net-analyzer/ntop/ntop-3.3.8.ebuild
deleted file mode 100644
index e16c8d9d2f09..000000000000
--- a/net-analyzer/ntop/ntop-3.3.8.ebuild
+++ /dev/null
@@ -1,115 +0,0 @@
-# Copyright 1999-2008 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-analyzer/ntop/ntop-3.3.8.ebuild,v 1.1 2008/10/05 13:08:44 mrness Exp $
-
-inherit eutils autotools
-
-DESCRIPTION="tool that shows network usage like top"
-HOMEPAGE="http://www.ntop.org/ntop.html"
-SRC_URI="mirror://sourceforge/ntop/${P}.tar.gz"
-
-LICENSE="GPL-2"
-SLOT="0"
-KEYWORDS="~amd64 ~arm ~hppa ~ia64 ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86"
-IUSE="ipv6 nls ssl tcpd"
-#snmp support is disabled
-
-#snmp? ( net-analyzer/net-snmp )
-COMMON_DEPEND="sys-apps/gawk
- dev-lang/perl
- sys-libs/gdbm
- net-libs/libpcap
- media-libs/gd
- media-libs/libpng
- net-analyzer/rrdtool
- ssl? ( dev-libs/openssl )
- tcpd? ( sys-apps/tcp-wrappers )
- sys-libs/zlib"
-DEPEND="${COMMON_DEPEND}
- >=sys-devel/libtool-1.4"
-
-# Needed by xmldumpPlugin - couldn't get it to work
-# dev-libs/gdome2
-# >=dev-libs/glib-2"
-RDEPEND="${COMMON_DEPEND}
- media-fonts/corefonts
- media-gfx/graphviz"
-
-pkg_setup() {
- # snmp doesn't compile in this release, disabled for now
-
- #if use snmp ; then
- # ewarn "snmp plugin is under development and upstream does not recommend"
- # ewarn "it for usage in production environment."
- # if ! use ipv6 ; then
- # echo
- # eerror "snmp plugin has compilation problems without ipv6 support."
- # eerror "For additional information see bug #121497."
- # die "snmp without ipv6 is broken"
- # else
- # if ! built_with_use net-analyzer/net-snmp ipv6 ; then
- # echo
- # eerror "You have both ipv6 and snmp enabled."
- # eerror "This require ipv6 support in net-analyzer/net-snmp."
- # eerror "However, net-analyzer/net-snmp was compiled with ipv6 flag disabled."
- # eerror "Please, re-emerge net-analyzer/net-snmp with USE=\"ipv6\"."
- # die "net-analyzer/net-snmp was build without ipv6."
- # fi
- # fi
- #fi
- enewgroup ntop
- enewuser ntop -1 -1 /var/lib/ntop ntop
-}
-
-src_unpack() {
- unpack ${A}
-
- cd "${S}"
- epatch "${FILESDIR}"/${P}-gentoo.patch
- cat acinclude.m4.in acinclude.m4.ntop > acinclude.m4
- eautoreconf
- touch libtool.m4.in
-}
-
-src_compile() {
- # force disable xmldumpPlugin
- export \
- ac_cv_header_glib_h=no \
- ac_cv_header_glibconfig_h=no \
- ac_cv_header_gdome_h=no \
- ac_cv_lib_glib_g_date_julian=no \
- ac_cv_lib_xml2_xmlCheckVersion=no \
- ac_cv_lib_gdome_gdome_di_saveDocToFile=no
-
- econf \
- $(use_enable ipv6) \
- $(use_enable nls i18n) \
- $(use_with ssl) $(use_enable ssl sslwatchdog) \
- $(use_with tcpd tcpwrapper) \
- --with-rrd-home=/usr/lib \
- --disable-snmp \
- || die "configure problem"
- # $(use_enable snmp)
- emake || die "compile problem"
-}
-
-src_install() {
- LC_ALL=C # apparently doesn't work with some locales (#191576 and #205382)
- emake DESTDIR="${D}" install || die "install problem"
-
- keepdir /var/lib/ntop
-
- dodoc AUTHORS CONTENTS ChangeLog MANIFESTO NEWS
- dodoc PORTING README SUPPORT_NTOP.txt THANKS $(find docs -type f)
-
- newinitd "${FILESDIR}"/ntop-initd ntop
- newconfd "${FILESDIR}"/ntop-confd ntop
-}
-
-pkg_postinst() {
- fowners ntop:ntop /var/lib/ntop
- fperms 750 /var/lib/ntop
-
- elog "You need to set a password first by running"
- elog "ntop --set-admin-password"
-}
diff --git a/net-analyzer/ntop/ntop-3.3.9-r2.ebuild b/net-analyzer/ntop/ntop-3.3.9-r2.ebuild
index be44869413c7..5aa5c39ed942 100644
--- a/net-analyzer/ntop/ntop-3.3.9-r2.ebuild
+++ b/net-analyzer/ntop/ntop-3.3.9-r2.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2009 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-analyzer/ntop/ntop-3.3.9-r2.ebuild,v 1.3 2009/04/27 15:37:00 jer Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-analyzer/ntop/ntop-3.3.9-r2.ebuild,v 1.4 2009/05/02 08:32:46 mrness Exp $
EAPI="2"
@@ -13,7 +13,7 @@ SRC_URI="mirror://sourceforge/ntop/${P}.tar.gz"
LICENSE="GPL-2"
SLOT="0"
KEYWORDS="amd64 arm hppa ia64 ppc ppc64 s390 sh sparc x86"
-IUSE="ipv6 nls ssl tcpd"
+IUSE="ipv6 ssl tcpd"
#snmp support is disabled
#snmp? ( net-analyzer/net-snmp )
@@ -86,9 +86,8 @@ src_configure() {
econf \
$(use_enable ipv6) \
- $(use_enable nls i18n) \
$(use_with ssl) $(use_enable ssl sslwatchdog) \
- $(use_with tcpd tcpwrapper) \
+ $(use_with tcpd tcpwrap) \
--with-rrd-home=/usr/lib \
--disable-snmp \
|| die "configure problem"