summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--dev-lang/gforth/ChangeLog6
-rw-r--r--dev-lang/gforth/files/gforth-0.7.0-make-elc.patch14
-rw-r--r--dev-lang/gforth/gforth-0.7.0.ebuild4
3 files changed, 22 insertions, 2 deletions
diff --git a/dev-lang/gforth/ChangeLog b/dev-lang/gforth/ChangeLog
index 9f4fb31ee4d9..fbe5260e5f7c 100644
--- a/dev-lang/gforth/ChangeLog
+++ b/dev-lang/gforth/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for dev-lang/gforth
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-lang/gforth/ChangeLog,v 1.32 2010/01/02 18:37:41 fauli Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-lang/gforth/ChangeLog,v 1.33 2010/09/11 12:24:17 ulm Exp $
+
+ 11 Sep 2010; Ulrich Mueller <ulm@gentoo.org> gforth-0.7.0.ebuild,
+ +files/gforth-0.7.0-make-elc.patch:
+ With USE=-emacs, don't byte-compile emacs lisp files. Fixes bug 336708.
02 Jan 2010; Christian Faulhammer <fauli@gentoo.org> gforth-0.7.0.ebuild:
Transfer Prefix keywords
diff --git a/dev-lang/gforth/files/gforth-0.7.0-make-elc.patch b/dev-lang/gforth/files/gforth-0.7.0-make-elc.patch
new file mode 100644
index 000000000000..fa558407c258
--- /dev/null
+++ b/dev-lang/gforth/files/gforth-0.7.0-make-elc.patch
@@ -0,0 +1,14 @@
+--- gforth-0.7.0-orig/Makefile.in
++++ gforth-0.7.0/Makefile.in
+@@ -430,7 +430,10 @@
+
+ ENGINES_FAST = gforth-fast$(OPT)$(EC)$(EXE) #gforth-native$(OPT)$(EC)$(EXE)
+
+-GEN = $(ENGINES) $(ENGINES_FAST) gforth.elc
++GEN = $(ENGINES) $(ENGINES_FAST)
++ifneq ($(emacssitelispdir), no)
++GEN += gforth.elc
++endif
+
+ # things that need a working forth system to be generated
+ FORTH_GEN_ENGINE=engine/prim.i engine/prim_lab.i engine/prim_names.i \
diff --git a/dev-lang/gforth/gforth-0.7.0.ebuild b/dev-lang/gforth/gforth-0.7.0.ebuild
index 635661f70197..df5a14287a2d 100644
--- a/dev-lang/gforth/gforth-0.7.0.ebuild
+++ b/dev-lang/gforth/gforth-0.7.0.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2010 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-lang/gforth/gforth-0.7.0.ebuild,v 1.7 2010/01/02 18:37:41 fauli Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-lang/gforth/gforth-0.7.0.ebuild,v 1.8 2010/09/11 12:24:17 ulm Exp $
inherit elisp-common eutils toolchain-funcs flag-o-matic
@@ -22,6 +22,8 @@ SITEFILE=50${PN}-gentoo.el
src_unpack() {
unpack ${A}
+ cd "${S}"
+ epatch "${FILESDIR}/${P}-make-elc.patch"
}
src_compile() {