summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--games-simulation/fgrun/ChangeLog10
-rw-r--r--games-simulation/fgrun/fgrun-1.6.0.ebuild (renamed from games-simulation/fgrun/fgrun-1.5.2.ebuild)29
2 files changed, 23 insertions, 16 deletions
diff --git a/games-simulation/fgrun/ChangeLog b/games-simulation/fgrun/ChangeLog
index 24e6681aaf9e..55499825ffca 100644
--- a/games-simulation/fgrun/ChangeLog
+++ b/games-simulation/fgrun/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for games-simulation/fgrun
-# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/games-simulation/fgrun/ChangeLog,v 1.11 2011/03/20 20:16:57 jlec Exp $
+# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/games-simulation/fgrun/ChangeLog,v 1.12 2012/01/21 15:57:35 reavertm Exp $
+
+*fgrun-1.6.0 (21 Jan 2012)
+
+ 21 Jan 2012; Maciej Mrozowski <reavertm@gentoo.org> +fgrun-1.6.0.ebuild,
+ -fgrun-1.5.2.ebuild:
+ Version bump, remove old, fixes bug 398247
20 Mar 2011; Justin Lecher <jlec@gentoo.org> fgrun-1.5.2.ebuild:
x11-libs/fltk SLOTMOVE 1.1 -> 1, corrected ebuild accordingly
diff --git a/games-simulation/fgrun/fgrun-1.5.2.ebuild b/games-simulation/fgrun/fgrun-1.6.0.ebuild
index 828da1fb2ffb..48ac430cd940 100644
--- a/games-simulation/fgrun/fgrun-1.5.2.ebuild
+++ b/games-simulation/fgrun/fgrun-1.6.0.ebuild
@@ -1,8 +1,8 @@
-# Copyright 1999-2011 Gentoo Foundation
+# Copyright 1999-2012 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/games-simulation/fgrun/fgrun-1.5.2.ebuild,v 1.4 2011/03/20 20:16:57 jlec Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-simulation/fgrun/fgrun-1.6.0.ebuild,v 1.1 2012/01/21 15:57:35 reavertm Exp $
-EAPI=2
+EAPI=3
inherit autotools eutils multilib games
DESCRIPTION="A graphical frontend for the FlightGear Flight Simulator"
@@ -14,23 +14,24 @@ SLOT="0"
KEYWORDS="~amd64 ~x86"
IUSE=""
-DEPEND="
+COMMON_DEPEND="
+ >=dev-games/openscenegraph-3.0.1
+ sys-libs/zlib
+ x11-libs/fltk:1[opengl,threads]
+"
+DEPEND="${COMMON_DEPEND}
>=dev-games/simgear-2
- x11-libs/fltk:1[opengl,threads]"
-RDEPEND="${DEPEND}
- >=games-simulation/flightgear-2"
+ >=dev-libs/boost-1.34
+"
+RDEPEND="${COMMON_DEPEND}
+ >=games-simulation/flightgear-2
+"
src_prepare() {
- epatch "${FILESDIR}/${P}"-fltk.patch
+ epatch "${FILESDIR}/${PN}-1.5.2-fltk.patch"
AT_M4DIR=. eautoreconf
}
-src_configure() {
- egamesconf \
- --with-plib-libraries=/usr/$(get_libdir) \
- --with-plib-includes=/usr/include
-}
-
src_install() {
emake DESTDIR="${D}" install || die "emake install failed"
dodoc AUTHORS NEWS