summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--dev-haskell/quickcheck/ChangeLog9
-rw-r--r--dev-haskell/quickcheck/quickcheck-2.4.2.ebuild33
2 files changed, 40 insertions, 2 deletions
diff --git a/dev-haskell/quickcheck/ChangeLog b/dev-haskell/quickcheck/ChangeLog
index 55a85f0215e4..f15c8815d7fe 100644
--- a/dev-haskell/quickcheck/ChangeLog
+++ b/dev-haskell/quickcheck/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-haskell/quickcheck
-# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-haskell/quickcheck/ChangeLog,v 1.50 2011/12/04 17:11:50 slyfox Exp $
+# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-haskell/quickcheck/ChangeLog,v 1.51 2012/01/22 14:05:49 gienah Exp $
+
+*quickcheck-2.4.2 (22 Jan 2012)
+
+ 22 Jan 2012; Mark Wright <gienah@gentoo.org> +quickcheck-2.4.2.ebuild:
+ Minor version bump.
*quickcheck-2.4.1.1 (04 Dec 2011)
diff --git a/dev-haskell/quickcheck/quickcheck-2.4.2.ebuild b/dev-haskell/quickcheck/quickcheck-2.4.2.ebuild
new file mode 100644
index 000000000000..fd61bd35f0e3
--- /dev/null
+++ b/dev-haskell/quickcheck/quickcheck-2.4.2.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-haskell/quickcheck/quickcheck-2.4.2.ebuild,v 1.1 2012/01/22 14:05:49 gienah Exp $
+
+EAPI="3"
+
+CABAL_FEATURES="lib profile haddock hscolour hoogle"
+inherit haskell-cabal
+
+MY_PN="QuickCheck"
+MY_P="${MY_PN}-${PV}"
+
+DESCRIPTION="Automatic testing of Haskell programs"
+HOMEPAGE="http://code.haskell.org/QuickCheck"
+SRC_URI="http://hackage.haskell.org/packages/archive/${MY_PN}/${PV}/${MY_P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="2"
+KEYWORDS="~alpha ~amd64 ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd"
+IUSE=""
+
+RDEPEND=">=dev-lang/ghc-6.10.1"
+DEPEND="${RDEPEND}
+ >=dev-haskell/cabal-1.6"
+
+# would work with ghc 6.8 (6.6 too?) too if we added this dep
+# dev-haskell/extensible-exceptions. however, we'd prefer not to add more co$
+# packages, as we don't want them upgradeable (leads to trouble).
+#
+# this means that we can only support the architectures which has >=ghc-6.10
+# and unfortunately have to drop the other arches until we get proper ghc su$
+
+S="${WORKDIR}/${MY_P}"