summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--www-client/lynx/ChangeLog8
-rw-r--r--www-client/lynx/lynx-2.8.7_p1.ebuild115
-rw-r--r--www-client/lynx/lynx-2.8.7_rc6.ebuild7
3 files changed, 124 insertions, 6 deletions
diff --git a/www-client/lynx/ChangeLog b/www-client/lynx/ChangeLog
index 85d97a7597c1..4f98d5a38545 100644
--- a/www-client/lynx/ChangeLog
+++ b/www-client/lynx/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for www-client/lynx
# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/www-client/lynx/ChangeLog,v 1.80 2009/07/26 22:55:46 wormo Exp $
+# $Header: /var/cvsroot/gentoo-x86/www-client/lynx/ChangeLog,v 1.81 2009/07/26 23:07:42 wormo Exp $
+
+*lynx-2.8.7_p1 (26 Jul 2009)
+
+ 26 Jul 2009; Stephanie Lockwood-Childs <wormo@gentoo.org>
+ lynx-2.8.7_rc6.ebuild, +lynx-2.8.7_p1.ebuild:
+ Version bump to lynx 2.8.7rel.1
26 Jul 2009; Stephanie Lockwood-Childs <wormo@gentoo.org> metadata.xml,
-lynx-2.8.7_rc4.ebuild, lynx-2.8.7_rc6.ebuild:
diff --git a/www-client/lynx/lynx-2.8.7_p1.ebuild b/www-client/lynx/lynx-2.8.7_p1.ebuild
new file mode 100644
index 000000000000..3b154df1831d
--- /dev/null
+++ b/www-client/lynx/lynx-2.8.7_p1.ebuild
@@ -0,0 +1,115 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/www-client/lynx/lynx-2.8.7_p1.ebuild,v 1.1 2009/07/26 23:07:42 wormo Exp $
+
+EAPI=2
+
+inherit eutils versionator
+
+# VERSIONING SCHEME TRANSLATION
+# Upstream : Gentoo
+# rel. : _p
+# pre. : _rc
+# dev. : _pre
+
+if [[ "${PV/_p[0-9]}" != "${PV}" ]]
+then
+ MY_P="${PN}${PV/_p/rel.}"
+
+elif [[ "${PV/_rc[0-9]}" != "${PV}" ]]
+then
+ MY_P="${PN}${PV/_rc/pre.}"
+
+elif [[ "${PV/_pre[0-9]}" != "${PV}" ]]
+then
+ MY_P="${PN}${PV/_pre/dev.}"
+
+fi
+
+DESCRIPTION="An excellent console-based web browser with ssl support"
+HOMEPAGE="http://lynx.isc.org/"
+SRC_URI="http://lynx.isc.org/current/${MY_P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~sparc-fbsd ~x86 ~x86-fbsd"
+IUSE="bzip2 cjk gnutls ipv6 nls openssl unicode"
+
+RDEPEND="sys-libs/ncurses[unicode?]
+ sys-libs/zlib
+ nls? ( virtual/libintl )
+ openssl? ( >=dev-libs/openssl-0.9.8 )
+ !openssl? (
+ gnutls? ( >=net-libs/gnutls-2.6.4 )
+ )
+ bzip2? ( app-arch/bzip2 )"
+
+DEPEND="${RDEPEND}
+ nls? ( sys-devel/gettext )
+ >=dev-util/pkgconfig-0.23"
+
+S="${WORKDIR}/${PN}$(replace_all_version_separators - $(get_version_component_range 1-3))"
+
+pkg_setup() {
+ if use openssl
+ then
+ if use gnutls
+ then
+ elog "Both openssl and gnutls use-flags specified. Openssl will be used."
+ fi
+ else
+ if ! use gnutls
+ then
+ elog "No SSL library selected, you will not be able to access secure websites."
+ fi
+ fi
+}
+
+src_prepare() {
+ # fix up toplevel makefile to enable parallel make (bug #262972)
+ #
+ # add '+' prefix to lines using $(MAKE_RECUR),
+ # making sure '+' comes after leading whitespace
+ sed -i -e '/$(MAKE_RECUR)/ s/\([[:blank:]]\)/\1+/' makefile.in || \
+ die "failed to update makefile.in"
+}
+
+src_configure() {
+ econf \
+ --enable-cgi-links \
+ --enable-persistent-cookies \
+ --enable-prettysrc \
+ --enable-nsl-fork \
+ --enable-file-upload \
+ --enable-read-eta \
+ --enable-color-style \
+ --enable-scrollbar \
+ --enable-included-msgs \
+ --with-zlib \
+ $(use_enable nls) \
+ $(use_enable ipv6) \
+ $(use_enable cjk) \
+ $(use_enable unicode japanese-utf8) \
+ $(use_with openssl ssl) \
+ $(use_with gnutls) \
+ $(use_with bzip2 bzlib) \
+ $(use unicode && printf '%s' '--with-screen=ncursesw')
+}
+
+src_install() {
+ make install DESTDIR="${D}" || die
+
+ sed -i -e "s|^HELPFILE.*$|HELPFILE:file://localhost/usr/share/doc/${PF}/lynx_help/lynx_help_main.html|" \
+ "${D}"/etc/lynx.cfg || die "lynx.cfg not found"
+ if use unicode
+ then
+ sed -i -e '/^#CHARACTER_SET:/ c\CHARACTER_SET:utf-8' \
+ "${D}"/etc/lynx.cfg || die "lynx.cfg not found"
+ fi
+ dodoc CHANGES COPYHEADER PROBLEMS README
+ docinto docs
+ dodoc docs/*
+ docinto lynx_help
+ dodoc lynx_help/*.txt
+ dohtml -r lynx_help/*
+}
diff --git a/www-client/lynx/lynx-2.8.7_rc6.ebuild b/www-client/lynx/lynx-2.8.7_rc6.ebuild
index d1e1a3ca4d51..690d79550122 100644
--- a/www-client/lynx/lynx-2.8.7_rc6.ebuild
+++ b/www-client/lynx/lynx-2.8.7_rc6.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2009 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/www-client/lynx/lynx-2.8.7_rc6.ebuild,v 1.2 2009/07/26 22:55:46 wormo Exp $
+# $Header: /var/cvsroot/gentoo-x86/www-client/lynx/lynx-2.8.7_rc6.ebuild,v 1.3 2009/07/26 23:07:42 wormo Exp $
EAPI=2
@@ -65,10 +65,7 @@ pkg_setup() {
fi
}
-src_unpack() {
- unpack ${A}
- cd "${S}"
-
+src_prepare() {
# fix up toplevel makefile to enable parallel make (bug #262972)
#
# add '+' prefix to lines using $(MAKE_RECUR),