summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--media-libs/libdvdcss/ChangeLog10
-rw-r--r--media-libs/libdvdcss/files/digest-libdvdcss-1.2.11
-rw-r--r--media-libs/libdvdcss/libdvdcss-1.2.1.ebuild72
3 files changed, 82 insertions, 1 deletions
diff --git a/media-libs/libdvdcss/ChangeLog b/media-libs/libdvdcss/ChangeLog
index 0989a3ab8c3e..cb079df577e4 100644
--- a/media-libs/libdvdcss/ChangeLog
+++ b/media-libs/libdvdcss/ChangeLog
@@ -1,6 +1,14 @@
# ChangeLog for media-libs/libdvdcss
# Copyright 2002 Gentoo Technologies, Inc.; Distributed under the GPL
-# $Header: /var/cvsroot/gentoo-x86/media-libs/libdvdcss/ChangeLog,v 1.5 2002/05/26 18:08:24 azarah Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-libs/libdvdcss/ChangeLog,v 1.6 2002/06/24 16:44:26 wmertens Exp $
+
+*libdvdcss-1.2.1 (24 Jun 2002)
+
+ 24 Jun 2002; Wout Mertens <wmertens@gentoo.org> :
+
+ Bumped to new version, because it was there and it fixes a playing problem
+ for me. Notice that it seems to have changed a lot since 1.1.1, so you might
+ want to try 1.1.1 to see if that works better for you.
*libdvdcss-1.2.0 (26 May 2002)
diff --git a/media-libs/libdvdcss/files/digest-libdvdcss-1.2.1 b/media-libs/libdvdcss/files/digest-libdvdcss-1.2.1
new file mode 100644
index 000000000000..aa2a8bfea500
--- /dev/null
+++ b/media-libs/libdvdcss/files/digest-libdvdcss-1.2.1
@@ -0,0 +1 @@
+MD5 e5c01162806456a03f4bd474ac7e64a3 libdvdcss-1.2.1.tar.gz 204002
diff --git a/media-libs/libdvdcss/libdvdcss-1.2.1.ebuild b/media-libs/libdvdcss/libdvdcss-1.2.1.ebuild
new file mode 100644
index 000000000000..d84df87f9172
--- /dev/null
+++ b/media-libs/libdvdcss/libdvdcss-1.2.1.ebuild
@@ -0,0 +1,72 @@
+# Copyright 1999-2002 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License, v2 or later
+# Author: Martin Schlemmer <azarah@gentoo.org>
+# $Header: /var/cvsroot/gentoo-x86/media-libs/libdvdcss/libdvdcss-1.2.1.ebuild,v 1.1 2002/06/24 16:44:26 wmertens Exp $
+
+S="${WORKDIR}/${P}"
+DESCRIPTION="A portable abstraction library for DVD decryption"
+SRC_URI="http://www.videolan.org/pub/videolan/libdvdcss/${PV}/${P}.tar.gz"
+HOMEPAGE="http://www.videolan.org/libdvdcss/"
+SLOT="0"
+
+DEPEND="virtual/glibc"
+
+
+src_compile() {
+
+ # Dont use custom optimiziations, as it gives problems
+ # on some archs
+ CFLAGS="" \
+ CXXFLAGS="" \
+ ./configure --prefix=/usr \
+ --mandir=/usr/share/man \
+ --infodir=/usr/share/info ||die
+
+ make || die
+}
+
+src_install() {
+
+ make prefix=${D}/usr \
+ mandir=${D}/usr/share/man \
+ infodir=${D}/usr/share/info \
+ install || die
+
+ dodoc AUTHORS COPYING ChangeLog INSTALL README TODO
+
+ ##
+ ## 0.0.3.* and 1.0.0 compat
+ ##
+
+ # NOTE: this should be the last code in src_install() !!!
+
+ if [ -L ${D}/usr/lib/libdvdcss.so ]
+ then
+ # on some locales the name of the file a symlink points to, is in the
+ # tenth field, and not the eleventh (bug #2908)
+ LC_ALL='C'
+ local realname=$(ls -l ${D}/usr/lib/libdvdcss.so |gawk '{print $11}')
+ [ -z "${realname}" ] && \
+ realname=$(ls -l ${D}/usr/lib/libdvdcss.so |gawk '{print $10}')
+ [ -z "${realname}" ] && return 0
+
+ for x in libdvdcss.so.0 libdvdcss.so.1
+ do
+ dosym ${realname} /usr/lib/${x}
+ done
+ fi
+}
+
+pkg_preinst() {
+
+ # these could cause problems if they exist from
+ # earlier builds
+ for x in libdvdcss.so.0 libdvdcss.so.1
+ do
+ if [ -f /usr/lib/${x} ] || [ -L /usr/lib/${x} ]
+ then
+ rm -f /usr/lib/${x}
+ fi
+ done
+}
+