summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--dev-ruby/radius/ChangeLog9
-rw-r--r--dev-ruby/radius/radius-0.6.1-r1.ebuild30
2 files changed, 37 insertions, 2 deletions
diff --git a/dev-ruby/radius/ChangeLog b/dev-ruby/radius/ChangeLog
index e778a480a485..e4ff900f863f 100644
--- a/dev-ruby/radius/ChangeLog
+++ b/dev-ruby/radius/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-ruby/radius
-# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ruby/radius/ChangeLog,v 1.3 2009/12/09 21:36:54 graaff Exp $
+# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/radius/ChangeLog,v 1.4 2010/06/01 07:55:05 graaff Exp $
+
+*radius-0.6.1-r1 (01 Jun 2010)
+
+ 01 Jun 2010; Hans de Graaff <graaff@gentoo.org> +radius-0.6.1-r1.ebuild:
+ Convert to ruby-fakegem.
09 Dec 2009; Hans de Graaff <graaff@gentoo.org> -radius-0.5.1.ebuild:
Remove old version.
diff --git a/dev-ruby/radius/radius-0.6.1-r1.ebuild b/dev-ruby/radius/radius-0.6.1-r1.ebuild
new file mode 100644
index 000000000000..4adc79bc46f6
--- /dev/null
+++ b/dev-ruby/radius/radius-0.6.1-r1.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/radius/radius-0.6.1-r1.ebuild,v 1.1 2010/06/01 07:55:05 graaff Exp $
+
+EAPI=2
+USE_RUBY="ruby18"
+
+RUBY_FAKEGEM_TASK_DOC="docs"
+RUBY_FAKEGEM_DOCDIR="doc"
+RUBY_FAKEGEM_EXTRADOC="CHANGELOG QUICKSTART.rdoc README.rdoc"
+
+inherit ruby-fakegem
+
+DESCRIPTION="Powerful tag-based template system."
+HOMEPAGE="http://radius.rubyforge.org/"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~x86 ~amd64"
+IUSE=""
+
+# Remove newgem related tasks to avoid dependency on it. This is only
+# needed to create and distribute the gem.
+all_ruby_prepare() {
+ sed -i -e '/newgem\/tasks/d' Rakefile || die "Unable to remove newgem code."
+ sed -i -e 's/newgem//' Rakefile || die "Unable to remove newgem code."
+ sed -i -e 's/::Newgem::VERSION/0/' Rakefile || die "Unable to remove newgem code."
+}
+
+ruby_add_bdepend "dev-ruby/hoe"