summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--net-print/hplip/ChangeLog9
-rw-r--r--net-print/hplip/Manifest4
-rw-r--r--net-print/hplip/files/digest-hplip-0.9.102
-rw-r--r--net-print/hplip/hplip-0.9.10.ebuild120
-rw-r--r--net-print/hplip/hplip-0.9.9.ebuild7
5 files changed, 137 insertions, 5 deletions
diff --git a/net-print/hplip/ChangeLog b/net-print/hplip/ChangeLog
index cfb97d9feb13..05ed78ecbce0 100644
--- a/net-print/hplip/ChangeLog
+++ b/net-print/hplip/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for net-print/hplip
# Copyright 1999-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-print/hplip/ChangeLog,v 1.25 2006/03/12 17:43:02 vanquirius Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-print/hplip/ChangeLog,v 1.26 2006/04/01 17:33:44 vanquirius Exp $
+
+*hplip-0.9.10 (01 Apr 2006)
+
+ 01 Apr 2006; Marcelo Goes <vanquirius@gentoo.org> hplip-0.9.9.ebuild,
+ +hplip-0.9.10.ebuild:
+ 0.9.10 version bump. Kill usb USE flag for bug 126337 and make libusb and
+ hotplug hardcoded dependencies, as they are no longer optional.
*hplip-0.9.9 (12 Mar 2006)
diff --git a/net-print/hplip/Manifest b/net-print/hplip/Manifest
index 9ac38d24fe64..5653ac0f54c7 100644
--- a/net-print/hplip/Manifest
+++ b/net-print/hplip/Manifest
@@ -1,9 +1,11 @@
MD5 58c36e964fbfd169948654b00f7aabb4 ChangeLog 4149
+MD5 5d654b351748ab2138472434033a7127 files/digest-hplip-0.9.10 146
MD5 68a5b9bc1ecb54c47e0aec2ea66b457a files/digest-hplip-0.9.7-r3 208
MD5 7bd172767b3400cad05526d58630944b files/digest-hplip-0.9.8-r2 762
MD5 01f28409596071bcd91355ee676d714d files/digest-hplip-0.9.9 145
MD5 dcda3bf144b5f2cd4bebd1719383dd31 files/hplip.init.d 948
+MD5 49b9b486babfdfb189a5201a90b04bae hplip-0.9.10.ebuild 3234
MD5 ada96505e109f3bb23c67a405b63bb48 hplip-0.9.7-r3.ebuild 3334
MD5 e37b7329ad4b862f147bb9861106d2ef hplip-0.9.8-r2.ebuild 3328
-MD5 0280e501e8685c231bdcace1618dcd96 hplip-0.9.9.ebuild 3246
+MD5 49b9b486babfdfb189a5201a90b04bae hplip-0.9.9.ebuild 3234
MD5 26b4b081d538c195dc39bcb2ec8e6f3a metadata.xml 161
diff --git a/net-print/hplip/files/digest-hplip-0.9.10 b/net-print/hplip/files/digest-hplip-0.9.10
new file mode 100644
index 000000000000..a3fc40762ab4
--- /dev/null
+++ b/net-print/hplip/files/digest-hplip-0.9.10
@@ -0,0 +1,2 @@
+MD5 1bf699ebd394c9822086c1fef2937836 foomatic-db-hpijs-1.5-20060211.tar.gz 97873
+MD5 349489b10fb44d1bf105b04ff5352551 hplip-0.9.10.tar.gz 9296866
diff --git a/net-print/hplip/hplip-0.9.10.ebuild b/net-print/hplip/hplip-0.9.10.ebuild
new file mode 100644
index 000000000000..b76fc3985320
--- /dev/null
+++ b/net-print/hplip/hplip-0.9.10.ebuild
@@ -0,0 +1,120 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-print/hplip/hplip-0.9.10.ebuild,v 1.1 2006/04/01 17:33:45 vanquirius Exp $
+
+inherit eutils
+
+DB_V=1.5-20060211
+DESCRIPTION="HP Linux Imaging and Printing System. Includes net-print/hpijs, scanner drivers and service tools."
+HOMEPAGE="http://hpinkjet.sourceforge.net/"
+SRC_URI="mirror://sourceforge/hpinkjet/${P}.tar.gz
+ foomaticdb? ( mirror://gentoo/foomatic-db-hpijs-${DB_V}.tar.gz )"
+ #http://www.linuxprinting.org/download/foomatic/foomatic-db-hpijs-${DB_V}.tar.gz
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE="foomaticdb snmp X qt ppds scanner cups"
+
+DEPEND="dev-lang/python
+ snmp? ( >=net-analyzer/net-snmp-5.0.9 )
+ !net-print/hpijs
+ !net-print/hpoj"
+
+RDEPEND="virtual/ghostscript
+ >=dev-lang/python-2.2.0
+ scanner? (
+ >=media-gfx/sane-backends-1.0.9
+ || (
+ X? ( >=media-gfx/xsane-0.89 )
+ >=media-gfx/sane-frontends-1.0.9
+ )
+ )
+ qt? ( >=dev-python/PyQt-3.11 =x11-libs/qt-3* )
+ >=dev-libs/libusb-0.1.10a
+ sys-apps/hotplug
+ foomaticdb? ( net-print/foomatic )
+ cups? ( net-print/cups )
+ >=net-print/foomatic-filters-3.0.2
+ ${DEPEND}"
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+
+ sed -i -e "s:(uint32_t)0xff000000) >> 24))):(uint32_t)0xff000000) >> 24):" \
+ "${S}"/scan/sane/mfpdtf.h
+
+ # bug 98428
+ sed -i -e "s:/usr/bin/env python:/usr/bin/python:g" \
+ "${S}"/hpssd.py
+}
+src_compile() {
+ myconf="${myconf} --disable-cups-install --disable-foomatic-install"
+
+ use snmp || myconf="${myconf} --disable-network-build"
+
+ econf ${myconf} || die "Error: econf failed!"
+ emake || die "Error: emake failed!"
+}
+
+
+src_install() {
+ make DESTDIR="${D}" install
+
+ newinitd "${FILESDIR}"/hplip.init.d hplip
+
+ if use scanner; then
+ insinto /etc/sane.d
+ echo "hpaio" > dll.conf
+ doins dll.conf
+
+ dodir /usr/lib/sane
+ dosym /usr/lib/libsane-hpaio.la /usr/lib/sane/libsane-hpaio.la
+ dosym /usr/lib/libsane-hpaio.so /usr/lib/sane/libsane-hpaio.so
+ dosym /usr/lib/libsane-hpaio.so.1 /usr/lib/sane/libsane-hpaio.so.1
+ dosym /usr/lib/libsane-hpaio.so.1.0.0 /usr/lib/sane/libsane-hpaio.so.1.0.0
+ else
+ rm -f "${D}"/usr/lib/libsane-hpaio.la
+ rm -f "${D}"/usr/lib/libsane-hpaio.so
+ rm -f "${D}"/usr/lib/libsane-hpaio.so.1
+ rm -f "${D}"/usr/lib/libsane-hpaio.so.1.0.0
+ fi
+
+ # bug 106035
+ if ! use qt ; then
+ rm -f "${D}"/usr/bin/hp-print
+ rm -f "${D}"/usr/bin/hp-toolbox
+ rm -f "${D}"/usr/share/hplip/print
+ rm -f "${D}"/usr/share/hplip/toolbox
+ rm -f "${D}"/usr/share/hplip/data/hplip.desktop
+ rm -f "${D}"/usr/share/applications/hplip.desktop
+ fi
+
+ if use ppds; then
+ dodir /usr/share
+ mv "${S}"/prnt/hpijs/ppd "${D}"/usr/share
+ fi
+
+ if use cups && use ppds ; then
+ dodir /usr/share/cups/model
+ dosym /usr/share/ppd /usr/share/cups/model/foomatic-ppds
+ fi
+
+ [ -e /usr/bin/foomatic-rip ] && rm -f "${D}"/usr/bin/foomatic-rip
+
+ if use foomaticdb ; then
+ cd ../foomatic-db-hpijs-${DB_V}
+ econf || die "econf failed"
+ rm -fR data-generators/hpijs-rss
+ make || die
+ make DESTDIR="${D}" install || die
+ fi
+
+ # desktop entry, bug 122758
+ if use qt; then
+ dodir /usr/share/applications
+ mv "${D}"/usr/share/hplip/data/hplip.desktop \
+ "${D}"/usr/share/applications
+ fi
+}
diff --git a/net-print/hplip/hplip-0.9.9.ebuild b/net-print/hplip/hplip-0.9.9.ebuild
index d6468d3d7f59..f9588fedd63f 100644
--- a/net-print/hplip/hplip-0.9.9.ebuild
+++ b/net-print/hplip/hplip-0.9.9.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2006 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-print/hplip/hplip-0.9.9.ebuild,v 1.1 2006/03/12 17:43:02 vanquirius Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-print/hplip/hplip-0.9.9.ebuild,v 1.2 2006/04/01 17:33:45 vanquirius Exp $
inherit eutils
@@ -14,7 +14,7 @@ SRC_URI="mirror://sourceforge/hpinkjet/${P}.tar.gz
LICENSE="GPL-2"
SLOT="0"
KEYWORDS="~amd64 ~ppc ~x86"
-IUSE="foomaticdb snmp X qt ppds scanner cups usb"
+IUSE="foomaticdb snmp X qt ppds scanner cups"
DEPEND="dev-lang/python
snmp? ( >=net-analyzer/net-snmp-5.0.9 )
@@ -31,7 +31,8 @@ RDEPEND="virtual/ghostscript
)
)
qt? ( >=dev-python/PyQt-3.11 =x11-libs/qt-3* )
- usb? ( >=dev-libs/libusb-0.1.10a sys-apps/hotplug )
+ >=dev-libs/libusb-0.1.10a
+ sys-apps/hotplug
foomaticdb? ( net-print/foomatic )
cups? ( net-print/cups )
>=net-print/foomatic-filters-3.0.2