summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--mail-client/sylpheed/ChangeLog7
-rw-r--r--mail-client/sylpheed/files/digest-sylpheed-2.2.103
-rw-r--r--mail-client/sylpheed/sylpheed-2.2.10.ebuild74
3 files changed, 83 insertions, 1 deletions
diff --git a/mail-client/sylpheed/ChangeLog b/mail-client/sylpheed/ChangeLog
index 665620d19545..324d643aa7aa 100644
--- a/mail-client/sylpheed/ChangeLog
+++ b/mail-client/sylpheed/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for mail-client/sylpheed
# Copyright 2002-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/mail-client/sylpheed/ChangeLog,v 1.205 2006/11/26 12:17:52 hattya Exp $
+# $Header: /var/cvsroot/gentoo-x86/mail-client/sylpheed/ChangeLog,v 1.206 2006/12/01 11:01:14 hattya Exp $
+
+*sylpheed-2.2.10 (01 Dec 2006)
+
+ 01 Dec 2006; Akinori Hattori <hattya@gentoo.org> +sylpheed-2.2.10.ebuild:
+ new upstream release.
26 Nov 2006; Akinori Hattori <hattya@gentoo.org> -sylpheed-2.2.4.ebuild,
sylpheed-2.2.5.ebuild, sylpheed-2.2.6.ebuild, sylpheed-2.2.7.ebuild,
diff --git a/mail-client/sylpheed/files/digest-sylpheed-2.2.10 b/mail-client/sylpheed/files/digest-sylpheed-2.2.10
new file mode 100644
index 000000000000..3a94c91fab24
--- /dev/null
+++ b/mail-client/sylpheed/files/digest-sylpheed-2.2.10
@@ -0,0 +1,3 @@
+MD5 68709cd07d2416c7aaeacf2c6921b1a2 sylpheed-2.2.10.tar.bz2 2579547
+RMD160 072576f178b37e6523ccb9ddbf2e881050a7128c sylpheed-2.2.10.tar.bz2 2579547
+SHA256 6a78274d6a25c8c647f3dc119307ab7364da9a1221c822606902c5477d79c5e2 sylpheed-2.2.10.tar.bz2 2579547
diff --git a/mail-client/sylpheed/sylpheed-2.2.10.ebuild b/mail-client/sylpheed/sylpheed-2.2.10.ebuild
new file mode 100644
index 000000000000..4caf1ac17e2b
--- /dev/null
+++ b/mail-client/sylpheed/sylpheed-2.2.10.ebuild
@@ -0,0 +1,74 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/mail-client/sylpheed/sylpheed-2.2.10.ebuild,v 1.1 2006/12/01 11:01:14 hattya Exp $
+
+WANT_AUTOMAKE=1.4
+
+inherit autotools eutils
+
+IUSE="crypt ipv6 ldap nls pda spell ssl xface"
+
+DESCRIPTION="A lightweight email client and newsreader"
+HOMEPAGE="http://sylpheed.sraoss.jp/"
+SRC_URI="http://sylpheed.sraoss.jp/${PN}/v${PV%.*}/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+KEYWORDS="~alpha ~amd64 ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86"
+SLOT="0"
+
+PROVIDE="virtual/sylpheed"
+
+DEPEND=">=x11-libs/gtk+-2.4
+ nls? ( >=sys-devel/gettext-0.12.1 )
+ crypt? ( >=app-crypt/gpgme-0.4.5 )
+ ldap? ( >=net-nds/openldap-2.0.11 )
+ pda? ( app-pda/jpilot )
+ spell? ( app-text/gtkspell )
+ ssl? ( dev-libs/openssl )
+ xface? ( >=media-libs/compface-1.4 )"
+RDEPEND="${DEPEND}
+ app-misc/mime-types
+ x11-misc/shared-mime-info"
+
+src_unpack() {
+
+ unpack ${A}
+ cd "${S}"
+
+ epatch "${FILESDIR}"/${PN}-2.*.diff
+
+ eautomake
+ elibtoolize
+
+}
+
+src_compile() {
+
+ econf \
+ `use_enable crypt gpgme` \
+ `use_enable ipv6` \
+ `use_enable ldap` \
+ `use_enable nls` \
+ `use_enable pda jpilot` \
+ `use_enable spell gtkspell` \
+ `use_enable ssl` \
+ `use_enable xface compface` \
+ || die
+ emake || die
+
+}
+
+src_install() {
+
+ emake DESTDIR="${D}" install
+
+ dodir /usr/share/pixmaps
+ insinto /usr/share/pixmaps
+ doins *.png
+
+ insinto /usr/share/applications
+ doins sylpheed.desktop
+
+ dodoc AUTHORS ChangeLog* NEWS* README* TODO*
+
+}