summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--app-emulation/softgun/ChangeLog8
-rw-r--r--app-emulation/softgun/files/softgun-0.19-make.patch54
-rw-r--r--app-emulation/softgun/softgun-0.19.ebuild33
3 files changed, 94 insertions, 1 deletions
diff --git a/app-emulation/softgun/ChangeLog b/app-emulation/softgun/ChangeLog
index 76874defc6dd..843539c63bbf 100644
--- a/app-emulation/softgun/ChangeLog
+++ b/app-emulation/softgun/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for app-emulation/softgun
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-emulation/softgun/ChangeLog,v 1.9 2010/01/04 03:33:11 flameeyes Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-emulation/softgun/ChangeLog,v 1.10 2010/11/12 17:15:27 maekke Exp $
+
+*softgun-0.19 (12 Nov 2010)
+
+ 12 Nov 2010; Markus Meier <maekke@gentoo.org> +softgun-0.19.ebuild,
+ +files/softgun-0.19-make.patch:
+ version bump, bug #296238
04 Jan 2010; Diego E. Pettenò <flameeyes@gentoo.org> softgun-0.16.ebuild:
Die when make fails.
diff --git a/app-emulation/softgun/files/softgun-0.19-make.patch b/app-emulation/softgun/files/softgun-0.19-make.patch
new file mode 100644
index 000000000000..8a305149b5d5
--- /dev/null
+++ b/app-emulation/softgun/files/softgun-0.19-make.patch
@@ -0,0 +1,54 @@
+diff -ru softgun-0.19.orig/config.mk softgun-0.19/config.mk
+--- softgun-0.19.orig/config.mk 2010-11-12 15:13:47.000000000 +0100
++++ softgun-0.19/config.mk 2010-11-12 15:14:39.000000000 +0100
+@@ -16,10 +16,10 @@
+ SHAREDCFLAGS=-fPIC -nostdlib -D_SHARED_
+ SHAREDLDFLAGS=-nostdlib -shared
+ ifeq ($(shell uname),Linux)
+-LDFLAGS=-rdynamic -lpthread -ldl -lrt -lm -lz -lasound
++LIBS=-rdynamic -lpthread -ldl -lrt -lm -lz -lasound
+ else
+ ifeq ($(shell uname),FreeBSD)
+- LDFLAGS=-rdynamic -lpthread -lm -lz -lSDL
++ LIBS=-rdynamic -lpthread -lm -lz -lSDL
+ else
+ $(error Unknown architecture)
+ endif
+diff -ru softgun-0.19.orig/Makefile softgun-0.19/Makefile
+--- softgun-0.19.orig/Makefile 2010-11-12 15:13:47.000000000 +0100
++++ softgun-0.19/Makefile 2010-11-12 15:14:27.000000000 +0100
+@@ -116,10 +116,10 @@
+
+
+ wgew: $(OBJS)
+- $(CC) $(CFLAGS) $^ -o $@ $(LDFLAGS)
++ $(CC) $(LDFLAGS) $^ -o $@ $(LIBS)
+
+ softgun_be: $(OBJS_BE)
+- $(CC) $(CFLAGS) $^ -o $@ $(LDFLAGS)
++ $(CC) $(LDFLAGS) $^ -o $@ $(LIBS)
+
+ boards/libboards.a:
+ $(MAKE) -C boards libboards.a
+diff -ru softgun-0.19.orig/printer/module.mk softgun-0.19/printer/module.mk
+--- softgun-0.19.orig/printer/module.mk 2010-11-12 15:13:47.000000000 +0100
++++ softgun-0.19/printer/module.mk 2010-11-12 15:14:59.000000000 +0100
+@@ -5,5 +5,5 @@
+ INSTALL_BINS += pcl3gui2png
+
+ pcl3gui2png: $(PRINTER_OBJS) printer/pcl3gui2png.c
+- $(CC) -o $@ $(PRINTER_OBJS) printer/pcl3gui2png.c
++ $(CC) $(LDFLAGS) -o $@ $(PRINTER_OBJS) printer/pcl3gui2png.c
+
+diff -ru softgun-0.19.orig/tools/Makefile softgun-0.19/tools/Makefile
+--- softgun-0.19.orig/tools/Makefile 2010-11-12 15:13:47.000000000 +0100
++++ softgun-0.19/tools/Makefile 2010-11-12 15:15:19.000000000 +0100
+@@ -1,7 +1,7 @@
+ include ../config.mk
+
+ sg_tunctl: tunctl.c
+- $(CC) $(CFLAGS) tunctl.c -o sg_tunctl
++ $(CC) $(CFLAGS) $(LDFLAGS) tunctl.c -o sg_tunctl
+
+ install:
+ install -m 0755 sg_tunctl $(bindir)
diff --git a/app-emulation/softgun/softgun-0.19.ebuild b/app-emulation/softgun/softgun-0.19.ebuild
new file mode 100644
index 000000000000..ac191d1a5c18
--- /dev/null
+++ b/app-emulation/softgun/softgun-0.19.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-emulation/softgun/softgun-0.19.ebuild,v 1.1 2010/11/12 17:15:27 maekke Exp $
+
+EAPI=2
+
+inherit toolchain-funcs eutils
+
+DESCRIPTION="ARM software emulator"
+HOMEPAGE="http://softgun.sourceforge.net/"
+SRC_URI="mirror://sourceforge/${PN}/${P}.tgz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86 ~ppc"
+IUSE=""
+
+src_prepare() {
+ epatch "${FILESDIR}"/${P}-make.patch
+ sed -i \
+ -e "/^CFLAGS/s:-O9.*-Werror:${CFLAGS}:" \
+ config.mk || die "sed config.mk failed"
+}
+
+src_compile() {
+ emake CC="$(tc-getCC)" || die
+}
+
+src_install() {
+ dodir /usr/bin
+ emake install prefix="${D}/usr" || die
+ dodoc README configs/*.sg
+}