summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--net-www/nspluginwrapper/ChangeLog13
-rw-r--r--net-www/nspluginwrapper/files/nspluginwrapper-1.1.0-quiet-64bit-plugin-warnings.patch17
-rw-r--r--net-www/nspluginwrapper/files/nspluginwrapper-1.1.0-windowless-crash.patch37
-rw-r--r--net-www/nspluginwrapper/nspluginwrapper-1.0.0.ebuild4
-rw-r--r--net-www/nspluginwrapper/nspluginwrapper-1.1.0-r1.ebuild (renamed from net-www/nspluginwrapper/nspluginwrapper-1.1.0.ebuild)14
5 files changed, 81 insertions, 4 deletions
diff --git a/net-www/nspluginwrapper/ChangeLog b/net-www/nspluginwrapper/ChangeLog
index 7af4b9c69178..efeb4bb228a2 100644
--- a/net-www/nspluginwrapper/ChangeLog
+++ b/net-www/nspluginwrapper/ChangeLog
@@ -1,6 +1,17 @@
# ChangeLog for net-www/nspluginwrapper
# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-www/nspluginwrapper/ChangeLog,v 1.18 2008/07/30 19:46:54 chutzpah Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-www/nspluginwrapper/ChangeLog,v 1.19 2008/10/02 03:16:56 chutzpah Exp $
+
+*nspluginwrapper-1.1.0-r1 (02 Oct 2008)
+
+ 02 Oct 2008; Patrick McLean <chutz@gentoo.org>
+ +files/nspluginwrapper-1.1.0-quiet-64bit-plugin-warnings.patch,
+ +files/nspluginwrapper-1.1.0-windowless-crash.patch,
+ nspluginwrapper-1.0.0.ebuild, -nspluginwrapper-1.1.0.ebuild,
+ +nspluginwrapper-1.1.0-r1.ebuild:
+ Revbump 1.1.0, add patch that should fix crash bug and patch to quiet
+ warnings about 64 bit plugins. Drop original revision of 1.1.0. Stabilize
+ 1.0.0.
*nspluginwrapper-1.1.0 (30 Jul 2008)
diff --git a/net-www/nspluginwrapper/files/nspluginwrapper-1.1.0-quiet-64bit-plugin-warnings.patch b/net-www/nspluginwrapper/files/nspluginwrapper-1.1.0-quiet-64bit-plugin-warnings.patch
new file mode 100644
index 000000000000..f5b1ec51f5a7
--- /dev/null
+++ b/net-www/nspluginwrapper/files/nspluginwrapper-1.1.0-quiet-64bit-plugin-warnings.patch
@@ -0,0 +1,17 @@
+This patch suppresses error messages when trying to wrap native plugin:
+*** NSPlugin Viewer *** ERROR: /usr/lib64/browser-plugins/opensc-signer.so: wrong ELF class: ELFCLASS64
+https://bugzilla.novell.com/show_bug.cgi?id=400194
+================================================================================
+--- src/npw-config.c
++++ src/npw-config.c
+@@ -538,6 +538,10 @@
+ if (pid < 0)
+ continue;
+ else if (pid == 0) {
++ if (!g_verbose)
++ {
++ fclose(stderr);
++ }
+ execl(viewer_path, NPW_VIEWER, "--test", "--plugin", filename, NULL);
+ exit(1);
+ }
diff --git a/net-www/nspluginwrapper/files/nspluginwrapper-1.1.0-windowless-crash.patch b/net-www/nspluginwrapper/files/nspluginwrapper-1.1.0-windowless-crash.patch
new file mode 100644
index 000000000000..b80538ff4eb9
--- /dev/null
+++ b/net-www/nspluginwrapper/files/nspluginwrapper-1.1.0-windowless-crash.patch
@@ -0,0 +1,37 @@
+2008-09-30 Gwenole Beauchesne <gb.public@free.fr>
+
+ * src/npw-rpc (do_send_NPSetWindowCallbackStruct): Check for
+ NULL visual.
+ * src/npw-viewer.c (create_window_attributes): Get system
+ visual when we are passed a 0 visual ID.
+
+Index: src/npw-viewer.c
+===================================================================
+--- src/npw-viewer.c (revision 645)
++++ src/npw-viewer.c (revision 646)
+@@ -358,7 +358,11 @@
+ {
+ if (ws_info == NULL)
+ return -1;
+- GdkVisual *gdk_visual = gdkx_visual_get((uintptr_t)ws_info->visual);
++ GdkVisual *gdk_visual;
++ if (ws_info->visual)
++ gdk_visual = gdkx_visual_get((uintptr_t)ws_info->visual);
++ else
++ gdk_visual = gdk_visual_get_system();
+ if (gdk_visual == NULL) {
+ npw_printf("ERROR: could not reconstruct XVisual from visualID\n");
+ return -2;
+Index: src/npw-rpc.c
+===================================================================
+--- src/npw-rpc.c (revision 645)
++++ src/npw-rpc.c (revision 646)
+@@ -381,7 +381,7 @@
+ return error;
+ if ((error = rpc_message_send_int32(message, ws_info->type)) < 0)
+ return error;
+- if ((error = rpc_message_send_uint32(message, XVisualIDFromVisual(ws_info->visual))) < 0)
++ if ((error = rpc_message_send_uint32(message, ws_info->visual ? XVisualIDFromVisual(ws_info->visual) : 0)) < 0)
+ return error;
+ if ((error = rpc_message_send_uint32(message, ws_info->colormap)) < 0)
+ return error;
diff --git a/net-www/nspluginwrapper/nspluginwrapper-1.0.0.ebuild b/net-www/nspluginwrapper/nspluginwrapper-1.0.0.ebuild
index 1a69b5208286..21610edc5073 100644
--- a/net-www/nspluginwrapper/nspluginwrapper-1.0.0.ebuild
+++ b/net-www/nspluginwrapper/nspluginwrapper-1.0.0.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2008 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-www/nspluginwrapper/nspluginwrapper-1.0.0.ebuild,v 1.1 2008/07/05 23:52:53 peper Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-www/nspluginwrapper/nspluginwrapper-1.0.0.ebuild,v 1.2 2008/10/02 03:16:56 chutzpah Exp $
inherit eutils nsplugins flag-o-matic multilib
@@ -10,7 +10,7 @@ SRC_URI="http://www.gibix.net/projects/nspluginwrapper/files/${P}.tar.bz2"
LICENSE="GPL-2"
SLOT="0"
-KEYWORDS="~amd64"
+KEYWORDS="amd64"
IUSE=""
RDEPEND=">=x11-libs/gtk+-2
diff --git a/net-www/nspluginwrapper/nspluginwrapper-1.1.0.ebuild b/net-www/nspluginwrapper/nspluginwrapper-1.1.0-r1.ebuild
index 2e8414030aeb..158d6c84c80a 100644
--- a/net-www/nspluginwrapper/nspluginwrapper-1.1.0.ebuild
+++ b/net-www/nspluginwrapper/nspluginwrapper-1.1.0-r1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2008 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-www/nspluginwrapper/nspluginwrapper-1.1.0.ebuild,v 1.1 2008/07/30 19:46:54 chutzpah Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-www/nspluginwrapper/nspluginwrapper-1.1.0-r1.ebuild,v 1.1 2008/10/02 03:16:56 chutzpah Exp $
inherit eutils nsplugins multilib
@@ -20,6 +20,17 @@ RDEPEND=">=x11-libs/gtk+-2
DEPEND="${RDEPEND}
dev-util/pkgconfig"
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+
+ # should fix some crashing
+ epatch "${FILESDIR}/${P}-windowless-crash.patch"
+
+ # bug #238403
+ epatch "${FILESDIR}/${P}-quiet-64bit-plugin-warnings.patch"
+}
+
src_compile() {
econf --with-biarch \
--with-lib32=$(ABI=x86 get_libdir) \
@@ -27,6 +38,7 @@ src_compile() {
--pkglibdir=/usr/$(get_libdir)/${PN}
emake || die "emake failed"
+
}
src_install() {