summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--net-libs/rb_libtorrent/ChangeLog6
-rw-r--r--net-libs/rb_libtorrent/rb_libtorrent-0.16.5.ebuild6
2 files changed, 10 insertions, 2 deletions
diff --git a/net-libs/rb_libtorrent/ChangeLog b/net-libs/rb_libtorrent/ChangeLog
index 8abea0075f60..1acef5c2c04f 100644
--- a/net-libs/rb_libtorrent/ChangeLog
+++ b/net-libs/rb_libtorrent/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for net-libs/rb_libtorrent
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-libs/rb_libtorrent/ChangeLog,v 1.140 2012/11/08 06:24:13 flameeyes Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-libs/rb_libtorrent/ChangeLog,v 1.141 2012/11/21 20:47:36 hwoarang Exp $
+
+ 21 Nov 2012; Markos Chandras <hwoarang@gentoo.org>
+ rb_libtorrent-0.16.5.ebuild:
+ Enable verbose build. Bug #441842
08 Nov 2012; Diego E. Pettenò <flameeyes@gentoo.org>
rb_libtorrent-0.15.10.ebuild, rb_libtorrent-0.15.5.ebuild,
diff --git a/net-libs/rb_libtorrent/rb_libtorrent-0.16.5.ebuild b/net-libs/rb_libtorrent/rb_libtorrent-0.16.5.ebuild
index 1b41957d7f03..135a22dffb87 100644
--- a/net-libs/rb_libtorrent/rb_libtorrent-0.16.5.ebuild
+++ b/net-libs/rb_libtorrent/rb_libtorrent-0.16.5.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2012 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-libs/rb_libtorrent/rb_libtorrent-0.16.5.ebuild,v 1.3 2012/11/08 06:24:13 flameeyes Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-libs/rb_libtorrent/rb_libtorrent-0.16.5.ebuild,v 1.4 2012/11/21 20:47:36 hwoarang Exp $
EAPI="4"
PYTHON_DEPEND="python? 2:2.6"
@@ -44,6 +44,9 @@ src_prepare() {
src_configure() {
local myconf
+ # bug 441842
+ myconf="--disable-silent-rules"
+
# use multi-threading versions of boost libs
if has_version '>=dev-libs/boost-1.52.0-r1'; then
myconf+=" --with-boost-python=boost_python-${PYTHON_ABI}"
@@ -64,6 +67,7 @@ src_configure() {
${myconf}
}
+
src_install() {
emake DESTDIR="${D}" install
use static-libs || find "${D}" -name '*.la' -exec rm -f {} +