summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--x11-libs/qt/ChangeLog7
-rw-r--r--x11-libs/qt/qt-4.6.0.ebuild39
2 files changed, 45 insertions, 1 deletions
diff --git a/x11-libs/qt/ChangeLog b/x11-libs/qt/ChangeLog
index a17e444b6903..1145e2e69c1f 100644
--- a/x11-libs/qt/ChangeLog
+++ b/x11-libs/qt/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for x11-libs/qt
# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/x11-libs/qt/ChangeLog,v 1.605 2009/11/21 18:24:15 nixnut Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-libs/qt/ChangeLog,v 1.606 2009/12/01 14:46:36 tampakrap Exp $
+
+*qt-4.6.0 (01 Dec 2009)
+
+ 01 Dec 2009; Theo Chatzimichos <tampakrap@gentoo.org> +qt-4.6.0.ebuild:
+ Version Bump to 4.6.0
21 Nov 2009; nixnut <nixnut@gentoo.org> qt-3.3.8b-r2.ebuild:
ppc stable #292929
diff --git a/x11-libs/qt/qt-4.6.0.ebuild b/x11-libs/qt/qt-4.6.0.ebuild
new file mode 100644
index 000000000000..82956ce5919d
--- /dev/null
+++ b/x11-libs/qt/qt-4.6.0.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/x11-libs/qt/qt-4.6.0.ebuild,v 1.1 2009/12/01 14:46:36 tampakrap Exp $
+
+EAPI=2
+DESCRIPTION="The Qt toolkit is a comprehensive C++ application development framework"
+HOMEPAGE="http://www.qtsoftware.com/"
+
+LICENSE="|| ( LGPL-2.1 GPL-3 )"
+SLOT="4"
+KEYWORDS="~amd64 ~x86"
+IUSE="dbus kde opengl qt3support"
+
+DEPEND=""
+RDEPEND="~x11-libs/qt-core-${PV}
+ ~x11-libs/qt-gui-${PV}
+ ~x11-libs/qt-svg-${PV}
+ ~x11-libs/qt-sql-${PV}
+ ~x11-libs/qt-script-${PV}
+ ~x11-libs/qt-xmlpatterns-${PV}
+ dbus? ( ~x11-libs/qt-dbus-${PV} )
+ opengl? ( ~x11-libs/qt-opengl-${PV} )
+ !kde? ( || ( ~x11-libs/qt-phonon-${PV} media-sound/phonon ) )
+ kde? ( media-sound/phonon )
+ qt3support? ( ~x11-libs/qt-qt3support-${PV} )
+ ~x11-libs/qt-webkit-${PV}
+ ~x11-libs/qt-test-${PV}
+ ~x11-libs/qt-multimedia-${PV}
+ ~x11-libs/qt-assistant-${PV}"
+
+pkg_postinst() {
+ echo
+ elog "Please note that this meta package is only provided for convenience."
+ elog "No packages should depend directly on this meta package, but on the"
+ elog "specific split Qt packages needed. This ebuild will be removed in"
+ elog "future versions. Users that want all Qt components installed are"
+ elog "advised to use the set currently available in qting-edge overlay."
+ echo
+}