summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSamuli Suominen <drac@gentoo.org>2007-08-04 13:41:13 +0000
committerSamuli Suominen <drac@gentoo.org>2007-08-04 13:41:13 +0000
commit4af3f73a16774b43c5f736dc9141ccdec3d4d365 (patch)
tree58346836d9f443e82f574690bed1f717b34dcfee /xfce-extra/xfce4-cpugraph
parentFix DEPENDs as per bug 172106. (diff)
downloadgentoo-2-4af3f73a16774b43c5f736dc9141ccdec3d4d365.tar.gz
gentoo-2-4af3f73a16774b43c5f736dc9141ccdec3d4d365.tar.bz2
gentoo-2-4af3f73a16774b43c5f736dc9141ccdec3d4d365.zip
Apply a sizeof patch from bug 187712 by Ondrej Barda, fixing a possible 64bit issue with cpu graph drawing in normal mode.
(Portage version: 2.1.3.3)
Diffstat (limited to 'xfce-extra/xfce4-cpugraph')
-rw-r--r--xfce-extra/xfce4-cpugraph/ChangeLog9
-rw-r--r--xfce-extra/xfce4-cpugraph/files/digest-xfce4-cpugraph-0.3.0-r13
-rw-r--r--xfce-extra/xfce4-cpugraph/files/xfce4-cpugraph-0.3.0-sizeof.patch12
-rw-r--r--xfce-extra/xfce4-cpugraph/xfce4-cpugraph-0.3.0-r1.ebuild22
4 files changed, 45 insertions, 1 deletions
diff --git a/xfce-extra/xfce4-cpugraph/ChangeLog b/xfce-extra/xfce4-cpugraph/ChangeLog
index 455f9dc4eb33..8215c392c21b 100644
--- a/xfce-extra/xfce4-cpugraph/ChangeLog
+++ b/xfce-extra/xfce4-cpugraph/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for xfce-extra/xfce4-cpugraph
# Copyright 1999-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/xfce-extra/xfce4-cpugraph/ChangeLog,v 1.21 2007/03/15 13:45:58 corsair Exp $
+# $Header: /var/cvsroot/gentoo-x86/xfce-extra/xfce4-cpugraph/ChangeLog,v 1.22 2007/08/04 13:41:13 drac Exp $
+
+*xfce4-cpugraph-0.3.0-r1 (04 Aug 2007)
+
+ 04 Aug 2007; Samuli Suominen <drac@gentoo.org>
+ +files/xfce4-cpugraph-0.3.0-sizeof.patch, +xfce4-cpugraph-0.3.0-r1.ebuild:
+ Apply a sizeof patch from bug 187712 by Ondrej Barda, fixing a possible
+ 64bit issue with cpu graph drawing in normal mode.
15 Mar 2007; Markus Rothe <corsair@gentoo.org>
xfce4-cpugraph-0.3.0.ebuild:
diff --git a/xfce-extra/xfce4-cpugraph/files/digest-xfce4-cpugraph-0.3.0-r1 b/xfce-extra/xfce4-cpugraph/files/digest-xfce4-cpugraph-0.3.0-r1
new file mode 100644
index 000000000000..1ef6d7cab54c
--- /dev/null
+++ b/xfce-extra/xfce4-cpugraph/files/digest-xfce4-cpugraph-0.3.0-r1
@@ -0,0 +1,3 @@
+MD5 b2ff93a62845289c4a8ed7d45faa7a1f xfce4-cpugraph-plugin-0.3.0.tar.bz2 102638
+RMD160 99c309b3bf0ab622a9b95df9b568808a6c034055 xfce4-cpugraph-plugin-0.3.0.tar.bz2 102638
+SHA256 eb6c2eee5f3d56a3202a9affb33242c3434bfbaeb0d7fe02cf267e64e85f3825 xfce4-cpugraph-plugin-0.3.0.tar.bz2 102638
diff --git a/xfce-extra/xfce4-cpugraph/files/xfce4-cpugraph-0.3.0-sizeof.patch b/xfce-extra/xfce4-cpugraph/files/xfce4-cpugraph-0.3.0-sizeof.patch
new file mode 100644
index 000000000000..5c59a96f49bd
--- /dev/null
+++ b/xfce-extra/xfce4-cpugraph/files/xfce4-cpugraph-0.3.0-sizeof.patch
@@ -0,0 +1,12 @@
+diff -ur xfce4-cpugraph-plugin-0.3.0.orig/panel-plugin/cpu.c xfce4-cpugraph-plugin-0.3.0/panel-plugin/cpu.c
+--- xfce4-cpugraph-plugin-0.3.0.orig/panel-plugin/cpu.c 2005-10-09 12:06:46.000000000 +0300
++++ xfce4-cpugraph-plugin-0.3.0/panel-plugin/cpu.c 2007-08-04 16:31:31.000000000 +0300
+@@ -626,7 +626,7 @@
+ base->m_CPUUsage = GetCPUUsage (&base->m_OldUsage, &base->m_OldTotal);
+
+ memmove (base->m_History + 1, base->m_History,
+- (base->m_Values - 1) * sizeof (int));
++ (base->m_Values - 1) * sizeof (long));
+ base->m_History[0] = base->m_CPUUsage;
+
+ /* Tooltip */
diff --git a/xfce-extra/xfce4-cpugraph/xfce4-cpugraph-0.3.0-r1.ebuild b/xfce-extra/xfce4-cpugraph/xfce4-cpugraph-0.3.0-r1.ebuild
new file mode 100644
index 000000000000..953c4735753d
--- /dev/null
+++ b/xfce-extra/xfce4-cpugraph/xfce4-cpugraph-0.3.0-r1.ebuild
@@ -0,0 +1,22 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/xfce-extra/xfce4-cpugraph/xfce4-cpugraph-0.3.0-r1.ebuild,v 1.1 2007/08/04 13:41:13 drac Exp $
+
+inherit autotools eutils xfce44
+
+xfce44
+
+DESCRIPTION="CPU load panel plugin"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd"
+
+DEPEND=">=xfce-extra/xfce4-dev-tools-${XFCE_MASTER_VERSION}"
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+ epatch "${FILESDIR}"/${P}-sizeof.patch
+ epatch "${FILESDIR}"/${P}-asneeded.patch
+ AT_M4DIR=/usr/share/xfce4/dev-tools/m4macros eautoreconf
+}
+
+xfce44_goodies_panel_plugin