summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJeremy Olexa <darkside@gentoo.org>2009-10-05 21:04:17 +0000
committerJeremy Olexa <darkside@gentoo.org>2009-10-05 21:04:17 +0000
commit27f28ec0e9a7db41a12104ab871283c3c21d682a (patch)
treea15f8f91d52d3a2e86bc7267dff8d4b2c02d8cca /xfce-base/exo
parentFixed unpacking with newer rpm eclass, closing bug #287748, thanks to Martin ... (diff)
downloadgentoo-2-27f28ec0e9a7db41a12104ab871283c3c21d682a.tar.gz
gentoo-2-27f28ec0e9a7db41a12104ab871283c3c21d682a.tar.bz2
gentoo-2-27f28ec0e9a7db41a12104ab871283c3c21d682a.zip
Port Gentoo Prefix ebuild to gentoo-x86
(Portage version: 2.1.6.13/cvs/Linux x86_64)
Diffstat (limited to 'xfce-base/exo')
-rw-r--r--xfce-base/exo/ChangeLog6
-rw-r--r--xfce-base/exo/exo-0.3.102-r1.ebuild10
-rw-r--r--xfce-base/exo/files/exo-0.3.4-interix.patch108
3 files changed, 121 insertions, 3 deletions
diff --git a/xfce-base/exo/ChangeLog b/xfce-base/exo/ChangeLog
index 9e61b448c969..32a87df0edc3 100644
--- a/xfce-base/exo/ChangeLog
+++ b/xfce-base/exo/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for xfce-base/exo
# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/xfce-base/exo/ChangeLog,v 1.7 2009/09/07 01:17:13 ranger Exp $
+# $Header: /var/cvsroot/gentoo-x86/xfce-base/exo/ChangeLog,v 1.8 2009/10/05 21:04:17 darkside Exp $
+
+ 05 Oct 2009; Jeremy Olexa <darkside@gentoo.org>
+ +files/exo-0.3.4-interix.patch, exo-0.3.102-r1.ebuild:
+ Port Gentoo Prefix ebuild to gentoo-x86
07 Sep 2009; Brent Baude <ranger@gentoo.org> exo-0.3.102-r1.ebuild:
Marking exo-0.3.102-r1 ppc64 for bug 282710
diff --git a/xfce-base/exo/exo-0.3.102-r1.ebuild b/xfce-base/exo/exo-0.3.102-r1.ebuild
index 3dff24f14e32..bae343fed686 100644
--- a/xfce-base/exo/exo-0.3.102-r1.ebuild
+++ b/xfce-base/exo/exo-0.3.102-r1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2009 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/xfce-base/exo/exo-0.3.102-r1.ebuild,v 1.10 2009/09/12 17:23:48 ssuominen Exp $
+# $Header: /var/cvsroot/gentoo-x86/xfce-base/exo/exo-0.3.102-r1.ebuild,v 1.11 2009/10/05 21:04:17 darkside Exp $
EAPI=2
inherit xfconf python multilib
@@ -12,7 +12,7 @@ SRC_URI="mirror://xfce/src/xfce/exo/0.3/${P}.tar.bz2"
LICENSE="GPL-2 LGPL-2"
SLOT="0"
-KEYWORDS="alpha amd64 arm hppa ia64 ppc ppc64 sparc x86 ~x86-fbsd"
+KEYWORDS="alpha amd64 arm hppa ia64 ppc ppc64 sparc x86 ~x86-fbsd ~x86-freebsd ~x86-interix ~amd64-linux ~x86-linux ~x64-solaris ~x86-solaris"
IUSE="debug doc hal libnotify python"
RDEPEND=">=dev-lang/perl-5.6
@@ -40,6 +40,12 @@ src_prepare() {
rm py-compile
touch py-compile
chmod +x py-compile
+
+ epatch "${FILESDIR}"/${PN}-0.3.4-interix.patch
+ if [[ ${CHOST} == *-interix* ]] ; then
+ # configure detects getmntent, which is false!
+ export ac_cv_func_getmntent=no
+ fi
}
pkg_postinst() {
diff --git a/xfce-base/exo/files/exo-0.3.4-interix.patch b/xfce-base/exo/files/exo-0.3.4-interix.patch
new file mode 100644
index 000000000000..73e1926989cd
--- /dev/null
+++ b/xfce-base/exo/files/exo-0.3.4-interix.patch
@@ -0,0 +1,108 @@
+diff -ru -x '*.P[l]o' exo-0.3.4.orig/exo/exo-mount-point.c exo-0.3.4/exo/exo-mount-point.c
+--- exo-0.3.4.orig/exo/exo-mount-point.c 2008-03-13 08:08:55 +0100
++++ exo-0.3.4/exo/exo-mount-point.c 2008-03-13 08:58:10 +0100
+@@ -72,7 +72,10 @@
+ #include <exo/exo-string.h>
+ #include <exo/exo-alias.h>
+
+-
++#if defined(__INTERIX)
++#include <dirent.h>
++#include <sys/statvfs.h>
++#endif
+
+ /* define _PATH_FSTAB if undefined */
+ #ifndef _PATH_FSTAB
+@@ -309,6 +312,45 @@
+ /* release the buffer */
+ free (mntbuf);
+ }
++#elif defined(__INTERIX)
++ DIR* dirp = opendir("/dev/fs");
++ if(dirp == NULL) {
++ g_set_error (error, G_FILE_ERROR, g_file_error_from_errno (errno),
++ _("Failed to open file \"%s\": %s"), "/dev/fs",
++ g_strerror (errno));
++ return NULL;
++ } else {
++ char file_name[9 + NAME_MAX];
++ int saved_errno;
++
++ while(1) {
++ struct statvfs stat_buf;
++ struct dirent entry;
++ struct dirent *result;
++
++ if (readdir_r (dirp, &entry, &result) || result == NULL)
++ break;
++
++ strcpy (file_name, "/dev/fs/");
++ strcat (file_name, entry.d_name);
++
++ if(statvfs(file_name, &stat_buf) == 0)
++ {
++ exo_mount_point_add_if_matches(mask, device, folder, fstype,
++ stat_buf.f_mntfromname,
++ stat_buf.f_mntonname,
++ stat_buf.f_fstypename,
++ ((stat_buf.f_flag & ST_RDONLY) != 0),
++ &mount_points);
++ }
++ else
++ {
++ /* this is ok for now... */
++ }
++ }
++
++ closedir (dirp);
++ }
+ #else
+ #error "Add support for your operating system here."
+ #endif
+@@ -413,6 +455,46 @@
+
+ /* close the file handle */
+ endfsent ();
++#elif defined(__INTERIX)
++ DIR* dirp = opendir("/dev/fs");
++ if(dirp == NULL) {
++ g_set_error (error, G_FILE_ERROR, g_file_error_from_errno (errno),
++ _("Failed to open file \"%s\": %s"), "/dev/fs",
++ g_strerror (errno));
++ return NULL;
++ } else {
++ char file_name[9 + NAME_MAX];
++ int saved_errno;
++
++ while(1) {
++ struct statvfs stat_buf;
++ struct dirent entry;
++ struct dirent *result;
++
++ if (readdir_r (dirp, &entry, &result) || result == NULL)
++ break;
++
++ strcpy (file_name, "/dev/fs/");
++ strcat (file_name, entry.d_name);
++
++ if(statvfs(file_name, &stat_buf) == 0)
++ {
++ exo_mount_point_add_if_matches(mask, device, folder, fstype,
++ stat_buf.f_mntfromname,
++ stat_buf.f_mntonname,
++ stat_buf.f_fstypename,
++ ((stat_buf.f_flag & ST_RDONLY) != 0),
++ &mount_points);
++ }
++ else
++ {
++ /* this is ok for now... */
++ }
++ }
++
++ closedir (dirp);
++ }
++
+ #else
+ #error "Add support for your operating system here."
+ #endif