summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2011-11-10 16:44:47 +0000
committerMike Frysinger <vapier@gentoo.org>2011-11-10 16:44:47 +0000
commit13cc25c3c0edbd6b054c74186e435ad27eefe2b6 (patch)
tree09d3e9543cc221b5303ac49195bfa6de44c7b705 /x11-proto/xcb-proto
parentStable for HPPA (bug #389995). (diff)
downloadgentoo-2-13cc25c3c0edbd6b054c74186e435ad27eefe2b6.tar.gz
gentoo-2-13cc25c3c0edbd6b054c74186e435ad27eefe2b6.tar.bz2
gentoo-2-13cc25c3c0edbd6b054c74186e435ad27eefe2b6.zip
Add pkg-config libdir update from upstream for cross-compiling.
(Portage version: 2.2.0_alpha72/cvs/Linux x86_64)
Diffstat (limited to 'x11-proto/xcb-proto')
-rw-r--r--x11-proto/xcb-proto/ChangeLog8
-rw-r--r--x11-proto/xcb-proto/files/1.6-libdir-pc.patch32
-rw-r--r--x11-proto/xcb-proto/xcb-proto-1.6-r2.ebuild44
3 files changed, 83 insertions, 1 deletions
diff --git a/x11-proto/xcb-proto/ChangeLog b/x11-proto/xcb-proto/ChangeLog
index a3787f65f9b0..ceb8f51215c8 100644
--- a/x11-proto/xcb-proto/ChangeLog
+++ b/x11-proto/xcb-proto/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for x11-proto/xcb-proto
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/x11-proto/xcb-proto/ChangeLog,v 1.62 2011/02/14 14:30:54 xarthisius Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-proto/xcb-proto/ChangeLog,v 1.63 2011/11/10 16:44:47 vapier Exp $
+
+*xcb-proto-1.6-r2 (10 Nov 2011)
+
+ 10 Nov 2011; Mike Frysinger <vapier@gentoo.org> +files/1.6-libdir-pc.patch,
+ +xcb-proto-1.6-r2.ebuild:
+ Add pkg-config libdir update from upstream for cross-compiling.
14 Feb 2011; Kacper Kowalik <xarthisius@gentoo.org>
xcb-proto-1.6-r1.ebuild:
diff --git a/x11-proto/xcb-proto/files/1.6-libdir-pc.patch b/x11-proto/xcb-proto/files/1.6-libdir-pc.patch
new file mode 100644
index 000000000000..f28fe9f8985d
--- /dev/null
+++ b/x11-proto/xcb-proto/files/1.6-libdir-pc.patch
@@ -0,0 +1,32 @@
+taken from upstream git
+
+From 7365eac2ee69125eed33d08a2a179dc99f201090 Mon Sep 17 00:00:00 2001
+From: Mike Frysinger <vapier@gentoo.org>
+Date: Tue, 8 Nov 2011 16:56:03 -0500
+Subject: [PATCH] add libdir/exec_prefix to xcb-xproto.pc
+
+If we want to base other paths off of exec_prefix or libdir (like the
+python path), we can't because the xcb-proto.pc.in file omits those
+variables. Add them so people can leverage them in their own builds.
+
+Signed-off-by: Mike Frysinger <vapier@gentoo.org>
+---
+ xcb-proto.pc.in | 2 ++
+ 1 files changed, 2 insertions(+), 0 deletions(-)
+
+diff --git a/xcb-proto.pc.in b/xcb-proto.pc.in
+index 6cbcf27..d312e6e 100644
+--- a/xcb-proto.pc.in
++++ b/xcb-proto.pc.in
+@@ -1,6 +1,8 @@
+ prefix=@prefix@
++exec_prefix=@exec_prefix@
+ datarootdir=@datarootdir@
+ datadir=@datadir@
++libdir=@libdir@
+ xcbincludedir=@xcbincludedir@
+ pythondir=@pythondir@
+
+--
+1.7.6.1
+
diff --git a/x11-proto/xcb-proto/xcb-proto-1.6-r2.ebuild b/x11-proto/xcb-proto/xcb-proto-1.6-r2.ebuild
new file mode 100644
index 000000000000..ee2a38b3b595
--- /dev/null
+++ b/x11-proto/xcb-proto/xcb-proto-1.6-r2.ebuild
@@ -0,0 +1,44 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/x11-proto/xcb-proto/xcb-proto-1.6-r2.ebuild,v 1.1 2011/11/10 16:44:47 vapier Exp $
+
+EAPI=3
+PYTHON_DEPEND="2:2.5"
+
+inherit python xorg-2
+
+DESCRIPTION="X C-language Bindings protocol headers"
+HOMEPAGE="http://xcb.freedesktop.org/"
+EGIT_REPO_URI="git://anongit.freedesktop.org/git/xcb/proto"
+[[ ${PV} != 9999* ]] && \
+ SRC_URI="http://xcb.freedesktop.org/dist/${P}.tar.bz2"
+
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~x86-fbsd ~x86-freebsd ~x86-interix ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
+IUSE=""
+
+PATCHES=(
+ "${FILESDIR}/1.6-fix_negative.patch"
+ "${FILESDIR}/1.6-libdir-pc.patch"
+)
+
+RDEPEND=""
+DEPEND="${RDEPEND}
+ dev-libs/libxml2"
+
+pkg_setup() {
+ python_set_active_version 2
+}
+
+src_install() {
+ xorg-2_src_install
+ python_clean_installation_image
+}
+
+pkg_postinst() {
+ python_mod_optimize xcbgen
+ ewarn "Please rebuild both libxcb and xcb-util if you are upgrading from version 1.6"
+}
+
+pkg_postrm() {
+ python_mod_cleanup xcbgen
+}