summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSamuli Suominen <ssuominen@gentoo.org>2008-12-22 22:51:03 +0000
committerSamuli Suominen <ssuominen@gentoo.org>2008-12-22 22:51:03 +0000
commit9e942f7f702b253dee240811fd3fb0ab1bc45b95 (patch)
treef19bc0855f5a8f9574bc479a82bcf66701bb49ca /x11-plugins
parentfixup ulgy white space (diff)
downloadgentoo-2-9e942f7f702b253dee240811fd3fb0ab1bc45b95.tar.gz
gentoo-2-9e942f7f702b253dee240811fd3fb0ab1bc45b95.tar.bz2
gentoo-2-9e942f7f702b253dee240811fd3fb0ab1bc45b95.zip
Add version that builds and works wrt #227569 and #251813.
(Portage version: 2.1.6.2/cvs/Linux 2.6.27.7 i686)
Diffstat (limited to 'x11-plugins')
-rw-r--r--x11-plugins/wmmixer/ChangeLog11
-rw-r--r--x11-plugins/wmmixer/files/wmmixer-1.5-respect_flags.patch35
-rw-r--r--x11-plugins/wmmixer/files/wmmixer-1.5-restore_pristine_code.patch74
-rw-r--r--x11-plugins/wmmixer/files/wmmixer-2.0_beta4.gcc.patch24
-rw-r--r--x11-plugins/wmmixer/files/wmmixer-cflags.patch10
-rw-r--r--x11-plugins/wmmixer/wmmixer-1.5.ebuild38
-rw-r--r--x11-plugins/wmmixer/wmmixer-2.0_beta4-r1.ebuild62
7 files changed, 156 insertions, 98 deletions
diff --git a/x11-plugins/wmmixer/ChangeLog b/x11-plugins/wmmixer/ChangeLog
index 3225dbe98d47..566b434d63f3 100644
--- a/x11-plugins/wmmixer/ChangeLog
+++ b/x11-plugins/wmmixer/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for x11-plugins/wmmixer
-# Copyright 2000-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/x11-plugins/wmmixer/ChangeLog,v 1.13 2007/07/22 04:51:32 dberkholz Exp $
+# Copyright 2000-2008 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/x11-plugins/wmmixer/ChangeLog,v 1.14 2008/12/22 22:51:03 ssuominen Exp $
+
+*wmmixer-1.5 (22 Dec 2008)
+
+ 22 Dec 2008; <ssuominen@gentoo.org>
+ +files/wmmixer-1.5-respect_flags.patch,
+ +files/wmmixer-1.5-restore_pristine_code.patch, +wmmixer-1.5.ebuild:
+ Add version that builds and works wrt #227569 and #251813.
22 Jul 2007; Donnie Berkholz <dberkholz@gentoo.org>;
wmmixer-2.0_beta4-r1.ebuild:
diff --git a/x11-plugins/wmmixer/files/wmmixer-1.5-respect_flags.patch b/x11-plugins/wmmixer/files/wmmixer-1.5-respect_flags.patch
new file mode 100644
index 000000000000..df6d5b33aa21
--- /dev/null
+++ b/x11-plugins/wmmixer/files/wmmixer-1.5-respect_flags.patch
@@ -0,0 +1,35 @@
+diff -ur wmmixer-1.5.orig/Makefile wmmixer-1.5/Makefile
+--- wmmixer-1.5.orig/Makefile 2002-06-25 23:13:11.000000000 +0300
++++ wmmixer-1.5/Makefile 2008-12-23 00:34:28.000000000 +0200
+@@ -1,19 +1,12 @@
+ # $Id: wmmixer-1.5-respect_flags.patch,v 1.1 2008/12/22 22:51:03 ssuominen Exp $
+
+-prefix = /usr/local
++prefix = /usr
+ exec_prefix = ${prefix}
+ bindir = ${exec_prefix}/bin
+ mandir = ${prefix}/share/man
+
+-DESTDIR =
+-
+-CXX = g++
+-CXXFLAGS = -O -Wall
+-EXTRA_LIBS = -L/usr/X11R6/lib -lX11 -lXpm -lXext
+-
+-
+-LD = g++
+-LDFLAGS = -o $(EXECUTABLE) $(EXTRA_LIBDIRS) $(EXTRA_LIBS) $(CXXFLAGS)
++CXX ?= g++
++LIBS = -lX11 -lXpm -lXext
+
+ EXECUTABLE = wmmixer
+ OBJS = xhandler.o mixctl.o wmmixer.o exception.o
+@@ -26,7 +19,7 @@
+ $(CXX) $(CXXFLAGS) -c -o $@ $<
+
+ $(EXECUTABLE): $(OBJS)
+- $(LD) $(LDFLAGS) $(OBJS)
++ $(CXX) $(LDFLAGS) $(OBJS) $(LIBS) -o $(EXECUTABLE)
+
+ all: $(EXECUTABLE)
+
diff --git a/x11-plugins/wmmixer/files/wmmixer-1.5-restore_pristine_code.patch b/x11-plugins/wmmixer/files/wmmixer-1.5-restore_pristine_code.patch
new file mode 100644
index 000000000000..d34a300b7ad3
--- /dev/null
+++ b/x11-plugins/wmmixer/files/wmmixer-1.5-restore_pristine_code.patch
@@ -0,0 +1,74 @@
+diff -ur wmmixer-1.5.orig/exception.h wmmixer-1.5/exception.h
+--- wmmixer-1.5.orig/exception.h 2002-06-25 22:22:20.000000000 +0300
++++ wmmixer-1.5/exception.h 2008-12-23 00:24:36.000000000 +0200
+@@ -37,4 +37,4 @@
+ // virtual ~MixerDeviceException();
+ };
+
+-#endif _exception_h__
++#endif //_exception_h__
+diff -ur wmmixer-1.5.orig/mixctl.cc wmmixer-1.5/mixctl.cc
+--- wmmixer-1.5.orig/mixctl.cc 2002-06-25 22:44:55.000000000 +0300
++++ wmmixer-1.5/mixctl.cc 2008-12-23 00:24:36.000000000 +0200
+@@ -243,16 +243,16 @@
+ //----------------------------------------------------------------------
+ bool MixCtl::hasChanged()
+ {
+- struct mixer_info mixer_info;
+- ioctl(mixfd, SOUND_MIXER_INFO, &mixer_info);
++ struct mixer_info mixer_info1;
++ ioctl(mixfd, SOUND_MIXER_INFO, &mixer_info1);
+
+- if (mixer_info.modify_counter == modify_counter)
++ if (mixer_info1.modify_counter == modify_counter)
+ {
+ return false;
+ }
+ else
+ {
+- modify_counter = mixer_info.modify_counter;
++ modify_counter = mixer_info1.modify_counter;
+ return true;
+ }
+ }
+diff -ur wmmixer-1.5.orig/mixctl.h wmmixer-1.5/mixctl.h
+--- wmmixer-1.5.orig/mixctl.h 2002-06-25 23:13:30.000000000 +0300
++++ wmmixer-1.5/mixctl.h 2008-12-23 00:24:36.000000000 +0200
+@@ -23,8 +23,8 @@
+ #ifdef __NetBSD__
+ #include <soundcard.h>
+ #endif
+-#ifdef __FreeBSD__
+-#include <machine/soundcard.h>
++#if defined (__FreeBSD__) || defined(__FreeBSD_kernel__)
++#include <sys/soundcard.h>
+ #endif
+ #ifdef __linux__
+ #include <linux/soundcard.h>
+diff -ur wmmixer-1.5.orig/README wmmixer-1.5/README
+--- wmmixer-1.5.orig/README 2002-06-25 23:20:09.000000000 +0300
++++ wmmixer-1.5/README 2008-12-23 00:24:36.000000000 +0200
+@@ -82,10 +82,10 @@
+ to reduce the size of the window to 56x56 pixels.
+ The "-position position" option has also been added, so you can push
+ wmcdplay off the edge of the screen while it gets swallowed.
+-To put wmmount in your Wharf, add the following line in the appropriate
++To put wmmixer in your Wharf, add the following line in the appropriate
+ part of your .steprc
+
+-*Wharf wmmixer nil MaxSwallow "wmmount" wmmixer -a -g -0-0 &
++*Wharf wmmixer nil MaxSwallow "wmmixer" wmmixer -a -g -0-0 &
+
+ It is also possible (by editing and recompiling the afterstep sources),
+ to make Wharf handle the new 56x56 pixel window properly - yes, I add
+diff -ur wmmixer-1.5.orig/xhandler.cc wmmixer-1.5/xhandler.cc
+--- wmmixer-1.5.orig/xhandler.cc 2002-06-25 23:13:40.000000000 +0300
++++ wmmixer-1.5/xhandler.cc 2008-12-23 00:24:36.000000000 +0200
+@@ -24,6 +24,7 @@
+ strcpy(backcolor_name_, BACKCOLOR);
+
+ button_state_ = 0;
++ icon_list_ = NULL;
+ }
+
+ //--------------------------------------------------------------------
diff --git a/x11-plugins/wmmixer/files/wmmixer-2.0_beta4.gcc.patch b/x11-plugins/wmmixer/files/wmmixer-2.0_beta4.gcc.patch
deleted file mode 100644
index 590c2d1698e2..000000000000
--- a/x11-plugins/wmmixer/files/wmmixer-2.0_beta4.gcc.patch
+++ /dev/null
@@ -1,24 +0,0 @@
-diff -Naur wmmixer-2.0b4/src/dockapp.cc wmmixer-2.0b4.new/src/dockapp.cc
---- wmmixer-2.0b4/src/dockapp.cc 2003-03-12 21:54:16.000000000 +0100
-+++ wmmixer-2.0b4.new/src/dockapp.cc 2006-09-12 14:36:27.000000000 +0200
-@@ -24,7 +24,7 @@
- {
- theme_ = new Theme(theme_file);
- theme_->initImages(getXHandler());
-- icons_ = new unsigned[theme_->icon_num_];
-+ icons_ = new unsigned[mixer->getNumChannels()];
- }
- catch(InvalidThemeException& e)
- {
-diff -Naur wmmixer-2.0b4/src/theme.cc wmmixer-2.0b4.new/src/theme.cc
---- wmmixer-2.0b4/src/theme.cc 2003-03-12 21:48:20.000000000 +0100
-+++ wmmixer-2.0b4.new/src/theme.cc 2006-09-12 14:33:35.000000000 +0200
-@@ -33,8 +33,6 @@
- }
-
-
-- delete config;
-- config = NULL;
-
- }
-
diff --git a/x11-plugins/wmmixer/files/wmmixer-cflags.patch b/x11-plugins/wmmixer/files/wmmixer-cflags.patch
deleted file mode 100644
index 516b4200e0d1..000000000000
--- a/x11-plugins/wmmixer/files/wmmixer-cflags.patch
+++ /dev/null
@@ -1,10 +0,0 @@
---- configure 2004-08-02 12:16:27.093499344 +0200
-+++ configure 2004-08-02 12:24:14.391459256 +0200
-@@ -822,7 +822,6 @@
-
- have_alsa=no
- have_oss=no
--CXXFLAGS='-pedantic -W -Wall -g'
-
-
-
diff --git a/x11-plugins/wmmixer/wmmixer-1.5.ebuild b/x11-plugins/wmmixer/wmmixer-1.5.ebuild
new file mode 100644
index 000000000000..ba8560af6b93
--- /dev/null
+++ b/x11-plugins/wmmixer/wmmixer-1.5.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/x11-plugins/wmmixer/wmmixer-1.5.ebuild,v 1.1 2008/12/22 22:51:03 ssuominen Exp $
+
+inherit eutils toolchain-funcs
+
+DESCRIPTION="A mixer designed for WindowMaker"
+HOMEPAGE="http://packages.qa.debian.org/w/wmmixer.html"
+SRC_URI="mirror://debian/pool/main/w/${PN}/${PN}_${PV}.orig.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~mips ~sparc ~x86"
+IUSE=""
+
+RDEPEND="x11-libs/libX11
+ x11-libs/libXext
+ x11-libs/libXpm"
+DEPEND="${RDEPEND}
+ x11-proto/xproto
+ x11-proto/xextproto"
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+ epatch "${FILESDIR}"/${P}-restore_pristine_code.patch \
+ "${FILESDIR}"/${P}-respect_flags.patch
+}
+
+src_compile() {
+ tc-export CXX
+ emake || die "emake failed."
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die "emake install failed."
+ dodoc CHANGES home.wmmixer README
+}
diff --git a/x11-plugins/wmmixer/wmmixer-2.0_beta4-r1.ebuild b/x11-plugins/wmmixer/wmmixer-2.0_beta4-r1.ebuild
deleted file mode 100644
index adc779a716d1..000000000000
--- a/x11-plugins/wmmixer/wmmixer-2.0_beta4-r1.ebuild
+++ /dev/null
@@ -1,62 +0,0 @@
-# Copyright 1999-2007 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/x11-plugins/wmmixer/wmmixer-2.0_beta4-r1.ebuild,v 1.5 2007/07/22 04:51:32 dberkholz Exp $
-
-inherit eutils
-
-IUSE="alsa"
-
-DESCRIPTION="The next generation of WMMixer with native ALSA and OSS support."
-SRC_URI="http://freakzone.net/gordon/src/${PN}-2.0b4.tar.gz"
-HOMEPAGE="http://freakzone.net/gordon/#wmmixer"
-
-RDEPEND="x11-libs/libX11
- x11-libs/libXext
- x11-libs/libXpm
- x11-proto/xproto
- x11-proto/xextproto
- alsa? ( media-libs/alsa-lib )"
-DEPEND="${RDEPEND}
- >=sys-apps/sed-4"
-
-SLOT="0"
-LICENSE="GPL-2"
-KEYWORDS="~mips sparc x86"
-
-S="${WORKDIR}/${PN}-2.0b4"
-
-src_unpack() {
-
- unpack ${A}
- cd ${S}
- sed -i 's#/usr/local/share#/usr/share#g' src/wmmixer.h example/*
-
- # Allow use of Gentoo CXXFLAGS
- epatch ${FILESDIR}/${PN}-cflags.patch
-
- # Fix compilation issues with recent gcc versions
- epatch ${FILESDIR}/${P}.gcc.patch
-}
-
-src_compile() {
-
- local myconf=""
-
- if use alsa ; then
- myconf="${myconf} --enable-alsa"
- fi
-
- econf "${myconf}" || die
- emake || die
-}
-
-src_install() {
-
- einstall || die
- dodoc README AUTHORS example/home.wmmixerrc example/home.wmmixer
-
- einfo
- einfo "Two sample configuration files have been installed in /usr/share/doc/${PF}/."
- einfo "You can copy one of them to ~/.wmmixerrc and adjust any settings you may need."
- einfo
-}