summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichele Noberasco <s4t4n@gentoo.org>2009-04-17 12:28:19 +0000
committerMichele Noberasco <s4t4n@gentoo.org>2009-04-17 12:28:19 +0000
commit25c1924b1890f4bd0e81108b9c6b9d7d4f890313 (patch)
tree1c70fbe9e2477a0d6037ea3cf32b5ce902f0a3a1 /x11-plugins
parentAutomated update of use.local.desc (diff)
downloadgentoo-2-25c1924b1890f4bd0e81108b9c6b9d7d4f890313.tar.gz
gentoo-2-25c1924b1890f4bd0e81108b9c6b9d7d4f890313.tar.bz2
gentoo-2-25c1924b1890f4bd0e81108b9c6b9d7d4f890313.zip
Initial import. Closes bug #208069.
(Portage version: 2.1.6.7/cvs/Linux i686)
Diffstat (limited to 'x11-plugins')
-rw-r--r--x11-plugins/wmXName/ChangeLog8
-rw-r--r--x11-plugins/wmXName/metadata.xml5
-rw-r--r--x11-plugins/wmXName/wmXName-0.1.ebuild47
3 files changed, 60 insertions, 0 deletions
diff --git a/x11-plugins/wmXName/ChangeLog b/x11-plugins/wmXName/ChangeLog
new file mode 100644
index 000000000000..ebf966b8d3d2
--- /dev/null
+++ b/x11-plugins/wmXName/ChangeLog
@@ -0,0 +1,8 @@
+# ChangeLog for x11-plugins/wmXName
+# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/x11-plugins/wmXName/ChangeLog,v 1.1 2009/04/17 12:28:19 s4t4n Exp $
+
+*wmpower-0.1 (17 Apr 2009)
+
+ 17 Apr 2009; Michele Noberasco <s4t4n@gentoo.org> wmXName-0.1.ebuild:
+ Initial import. Closes bug #208069.
diff --git a/x11-plugins/wmXName/metadata.xml b/x11-plugins/wmXName/metadata.xml
new file mode 100644
index 000000000000..b1a9efc4f2f0
--- /dev/null
+++ b/x11-plugins/wmXName/metadata.xml
@@ -0,0 +1,5 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>desktop-dock</herd>
+</pkgmetadata>
diff --git a/x11-plugins/wmXName/wmXName-0.1.ebuild b/x11-plugins/wmXName/wmXName-0.1.ebuild
new file mode 100644
index 000000000000..ac2406e75e07
--- /dev/null
+++ b/x11-plugins/wmXName/wmXName-0.1.ebuild
@@ -0,0 +1,47 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/x11-plugins/wmXName/wmXName-0.1.ebuild,v 1.1 2009/04/17 12:28:19 s4t4n Exp $
+
+MY_PV="0.01"
+MY_P="${PN}-${MY_PV}"
+
+IUSE=""
+DESCRIPTION="dock-app showing you status of your XName hosted zones"
+SRC_URI="http://source.xname.org/${MY_P}.tgz"
+HOMEPAGE="http://source.xname.org/"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~x86"
+
+COMMON_DEPEND=">=x11-libs/libXpm-3.5.7
+ >=x11-libs/libX11-1.1.4
+ >=x11-libs/libXext-1.0.3"
+
+DEPEND="${COMMON_DEPEND}
+ >=sys-apps/sed-4.1.5-r1"
+
+RDEPEND="${COMMON_DEPEND}
+ >=dev-lang/perl-5.8.8-r5
+ >=www-client/lynx-2.8.6-r2"
+
+S="${WORKDIR}/${MY_P}"
+
+src_unpack() {
+ unpack ${A}
+
+ #some magic sed to fix CFLAGS
+ sed -i "s/-O2 -Wall/$CFLAGS/" "${S}/Makefile"
+
+ #INSTALL file actually contains use instructions
+ mv "${S}/INSTALL" "${S}/README"
+}
+
+src_compile() {
+ emake || die
+}
+
+src_install () {
+ dobin wmXName GrabXName
+ dodoc README config.sample
+}