summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBrad Teaford Cowan <bcowan@gentoo.org>2003-02-19 07:14:55 +0000
committerBrad Teaford Cowan <bcowan@gentoo.org>2003-02-19 07:14:55 +0000
commit21f97ba82074fbde8fe8d6e07440dde9d55c59c6 (patch)
tree09e1713252a97662cf4bdb198e79f7a542d6dd6d /x11-misc/wdm
parentmarked stable fixed some major bugs (diff)
downloadgentoo-2-21f97ba82074fbde8fe8d6e07440dde9d55c59c6.tar.gz
gentoo-2-21f97ba82074fbde8fe8d6e07440dde9d55c59c6.tar.bz2
gentoo-2-21f97ba82074fbde8fe8d6e07440dde9d55c59c6.zip
initial import, closes bug# 15660
Diffstat (limited to 'x11-misc/wdm')
-rw-r--r--x11-misc/wdm/ChangeLog11
-rw-r--r--x11-misc/wdm/files/digest-wdm-1.221
-rw-r--r--x11-misc/wdm/files/wdm8
-rw-r--r--x11-misc/wdm/wdm-1.22.ebuild41
4 files changed, 61 insertions, 0 deletions
diff --git a/x11-misc/wdm/ChangeLog b/x11-misc/wdm/ChangeLog
new file mode 100644
index 000000000000..8cab0a3db7de
--- /dev/null
+++ b/x11-misc/wdm/ChangeLog
@@ -0,0 +1,11 @@
+# ChangeLog for x11-misc/wdm
+# Copyright 2000-2003 Gentoo Technologies, Inc.; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/x11-misc/wdm/ChangeLog,v 1.1 2003/02/19 07:14:55 bcowan Exp $
+
+*wdm-1.22 (19 Feb 2003)
+
+ 19 Feb 2003; Brad Cowan <bcowan@gentoo.org> wdm-1.22.ebuild,
+ ChangeLog, files/digest-wdm-1.22, wdm :
+
+ Initial import. Ebuild submitted by Don Seiler <don@seiler.us>.
+ \ No newline at end of file
diff --git a/x11-misc/wdm/files/digest-wdm-1.22 b/x11-misc/wdm/files/digest-wdm-1.22
new file mode 100644
index 000000000000..5c338946e96c
--- /dev/null
+++ b/x11-misc/wdm/files/digest-wdm-1.22
@@ -0,0 +1 @@
+MD5 b58f968ae13733e2433fcf74b4912ade wdm-1.22.tar.bz2 433330
diff --git a/x11-misc/wdm/files/wdm b/x11-misc/wdm/files/wdm
new file mode 100644
index 000000000000..99a0bdbe7483
--- /dev/null
+++ b/x11-misc/wdm/files/wdm
@@ -0,0 +1,8 @@
+#%PAM-1.0
+auth required /lib/security/pam_stack.so service=system-auth
+auth required /lib/security/pam_nologin.so
+account required /lib/security/pam_stack.so service=system-auth
+password required /lib/security/pam_stack.so service=system-auth
+session required /lib/security/pam_stack.so service=system-auth
+session optional /lib/security/pam_console.so
+
diff --git a/x11-misc/wdm/wdm-1.22.ebuild b/x11-misc/wdm/wdm-1.22.ebuild
new file mode 100644
index 000000000000..de576939c05d
--- /dev/null
+++ b/x11-misc/wdm/wdm-1.22.ebuild
@@ -0,0 +1,41 @@
+# Copyright 1999-2002 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/x11-misc/wdm/wdm-1.22.ebuild,v 1.1 2003/02/19 07:14:55 bcowan Exp $
+IUSE="truetype pam png jpeg gif tiff"
+
+DESCRIPTION="WINGs Display Manager"
+HOMEPAGE="http://voins.program.ru/wdm/"
+SRC_URI="http://voins.program.ru/${PN}/${P}.tar.bz2"
+
+SLOT="0"
+KEYWORDS="~x86"
+LICENSE="GPL-2"
+
+RDEPEND=">=x11-wm/WindowMaker-0.65.1"
+
+DEPEND="${RDEPEND}
+ virtual/x11
+ truetype? ( x11-libs/xft )"
+
+src_compile() {
+ local myconf=""
+ use pam && myconf="${myconf} --enable-pam"
+ use png || myconf="${myconf} --disable-png"
+ use jpeg || myconf="${myconf} --disable-jpeg"
+ use gif || myconf="${myconf} --disable-gif"
+ use tiff || myconf="${myconf} --disable-tiff"
+
+ econf \
+ --exec-prefix=/usr \
+ ${myconf} || die
+
+ emake || die
+}
+
+src_install() {
+ rm ${D}/etc/pam.d/wdm
+ insinto /etc/pam.d
+ doins ${FILESDIR}/wdm
+
+ make DESTDIR=${D} install || die
+}