summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJeroen Roovers <jer@gentoo.org>2014-01-22 15:57:43 +0000
committerJeroen Roovers <jer@gentoo.org>2014-01-22 15:57:43 +0000
commitdeb4d482820ea0f13b45b4f2d9eae4dfab229214 (patch)
tree5393c794066df40608f24ffe50a4b86a8c69f8e9 /x11-misc/tabbed
parentapp-office/impressive: Version Bump, #498882 (diff)
downloadgentoo-2-deb4d482820ea0f13b45b4f2d9eae4dfab229214.tar.gz
gentoo-2-deb4d482820ea0f13b45b4f2d9eae4dfab229214.tar.bz2
gentoo-2-deb4d482820ea0f13b45b4f2d9eae4dfab229214.zip
Version bump.
(Portage version: 2.2.8-r1/cvs/Linux x86_64, signed Manifest commit with key A792A613)
Diffstat (limited to 'x11-misc/tabbed')
-rw-r--r--x11-misc/tabbed/ChangeLog9
-rw-r--r--x11-misc/tabbed/tabbed-0.6.ebuild48
2 files changed, 55 insertions, 2 deletions
diff --git a/x11-misc/tabbed/ChangeLog b/x11-misc/tabbed/ChangeLog
index 045a4f6e4d6d..95690ce64faa 100644
--- a/x11-misc/tabbed/ChangeLog
+++ b/x11-misc/tabbed/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for x11-misc/tabbed
-# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/x11-misc/tabbed/ChangeLog,v 1.7 2013/07/04 15:38:21 jer Exp $
+# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/x11-misc/tabbed/ChangeLog,v 1.8 2014/01/22 15:57:43 jer Exp $
+
+*tabbed-0.6 (22 Jan 2014)
+
+ 22 Jan 2014; Jeroen Roovers <jer@gentoo.org> +tabbed-0.6.ebuild:
+ Version bump.
04 Jul 2013; Jeroen Roovers <jer@gentoo.org> -tabbed-0.4.1.ebuild:
Old.
diff --git a/x11-misc/tabbed/tabbed-0.6.ebuild b/x11-misc/tabbed/tabbed-0.6.ebuild
new file mode 100644
index 000000000000..6f454ee60601
--- /dev/null
+++ b/x11-misc/tabbed/tabbed-0.6.ebuild
@@ -0,0 +1,48 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/x11-misc/tabbed/tabbed-0.6.ebuild,v 1.1 2014/01/22 15:57:43 jer Exp $
+
+EAPI=5
+inherit savedconfig toolchain-funcs
+
+DESCRIPTION="Simple generic tabbed fronted to xembed aware applications"
+HOMEPAGE="http://tools.suckless.org/tabbed"
+SRC_URI="http://dl.suckless.org/tools/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND="x11-libs/libX11"
+DEPEND="
+ x11-proto/xproto
+ ${RDEPEND}
+"
+
+src_prepare() {
+ sed config.mk \
+ -e '/^CC/d' \
+ -e 's|/usr/local|/usr|g' \
+ -e 's|^CFLAGS.*|CFLAGS += -std=c99 -pedantic -Wall $(INCS) $(CPPFLAGS)|g' \
+ -e 's|^LDFLAGS.*|LDFLAGS += $(CFLAGS) $(LIBS)|g' \
+ -e 's|^LIBS.*|LIBS = -lX11|g' \
+ -e 's|{|(|g;s|}|)|g' \
+ -i || die
+
+ sed Makefile \
+ -e 's|{|(|g;s|}|)|g' \
+ -e '/^[[:space:]]*@echo/d' \
+ -e 's|^ @| |g' \
+ -i || die
+
+ restore_config config.h
+}
+
+src_compile() {
+ emake CC=$(tc-getCC)
+}
+src_install() {
+ default
+ save_config config.h
+}