summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBryan Stine <battousai@gentoo.org>2005-07-25 18:09:09 +0000
committerBryan Stine <battousai@gentoo.org>2005-07-25 18:09:09 +0000
commita7592244e2f082c67c1c48253b916ae3cdfcdef4 (patch)
tree9ddf4ad0cf5a1fcad8fcce3519a059ef2d018f8f /x11-misc/synaptics
parentChange qt dep per bug #100235 (diff)
downloadgentoo-2-a7592244e2f082c67c1c48253b916ae3cdfcdef4.tar.gz
gentoo-2-a7592244e2f082c67c1c48253b916ae3cdfcdef4.tar.bz2
gentoo-2-a7592244e2f082c67c1c48253b916ae3cdfcdef4.zip
Add patch to backport sentinel code to included headers. Closes bug #100134.
(Portage version: 2.0.51.22-r1)
Diffstat (limited to 'x11-misc/synaptics')
-rw-r--r--x11-misc/synaptics/ChangeLog8
-rw-r--r--x11-misc/synaptics/files/synaptics-0.14.x-gcc4-the-sentinels-have-attacked.patch16
-rw-r--r--x11-misc/synaptics/synaptics-0.14.1.ebuild4
-rw-r--r--x11-misc/synaptics/synaptics-0.14.2.ebuild4
-rw-r--r--x11-misc/synaptics/synaptics-0.14.3.ebuild4
5 files changed, 32 insertions, 4 deletions
diff --git a/x11-misc/synaptics/ChangeLog b/x11-misc/synaptics/ChangeLog
index 0134b88b756e..cfc639330d7d 100644
--- a/x11-misc/synaptics/ChangeLog
+++ b/x11-misc/synaptics/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for x11-misc/synaptics
# Copyright 2000-2005 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/x11-misc/synaptics/ChangeLog,v 1.42 2005/07/22 23:23:12 battousai Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-misc/synaptics/ChangeLog,v 1.43 2005/07/25 18:09:09 battousai Exp $
+
+ 25 Jul 2005; Bryan Stine <battousai@gentoo.org>
+ +files/synaptics-0.14.x-gcc4-the-sentinels-have-attacked.patch,
+ synaptics-0.14.1.ebuild, synaptics-0.14.2.ebuild, synaptics-0.14.3.ebuild:
+ Add patch to backport X sentinel code into included headers. Thanks to
+ Christoph Brill for posting the patch. Closes bug #100134.
22 Jul 2005; Bryan Stine <battousai@gentoo.org> synaptics-0.14.1.ebuild,
synaptics-0.14.2.ebuild, synaptics-0.14.3.ebuild:
diff --git a/x11-misc/synaptics/files/synaptics-0.14.x-gcc4-the-sentinels-have-attacked.patch b/x11-misc/synaptics/files/synaptics-0.14.x-gcc4-the-sentinels-have-attacked.patch
new file mode 100644
index 000000000000..c8d34ef6ebfb
--- /dev/null
+++ b/x11-misc/synaptics/files/synaptics-0.14.x-gcc4-the-sentinels-have-attacked.patch
@@ -0,0 +1,16 @@
+--- Xincludes/usr/X11R6/include/X11/Xfuncproto.h.orig 2005-07-02 12:50:40.000000000 +0200
++++ Xincludes/usr/X11R6/include/X11/Xfuncproto.h 2005-07-25 08:13:46.000000000 +0200
+@@ -69,4 +69,12 @@
+ #endif
+ #endif /* _XFUNCPROTOBEGIN */
+
++#if defined(__GNUC__) && (__GNUC__ >= 4)
++# define _X_SENTINEL(x) __attribute__ ((__sentinel__(x)))
++# define _X_ATTRIBUTE_PRINTF(x,y) __attribute__((__format__(__printf__,x,y)))
++#else
++# define _X_SENTINEL(x)
++# define _X_ATTRIBUTE_PRINTF(x,y)
++#endif /* GNUC >= 4 */
++
+ #endif /* _XFUNCPROTO_H_ */
+
diff --git a/x11-misc/synaptics/synaptics-0.14.1.ebuild b/x11-misc/synaptics/synaptics-0.14.1.ebuild
index 8cf2ae8e5b1b..a19f9413fecd 100644
--- a/x11-misc/synaptics/synaptics-0.14.1.ebuild
+++ b/x11-misc/synaptics/synaptics-0.14.1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2005 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/x11-misc/synaptics/synaptics-0.14.1.ebuild,v 1.5 2005/07/22 23:23:12 battousai Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-misc/synaptics/synaptics-0.14.1.ebuild,v 1.6 2005/07/25 18:09:09 battousai Exp $
inherit toolchain-funcs eutils
@@ -19,6 +19,8 @@ src_unpack() {
cd ${S}
+ epatch ${FILESDIR}/${PN}-0.14.x-gcc4-the-sentinels-have-attacked.patch
+
# Put stuff into /usr, also switch up the CC and CFLAGS stuff.
sed -i -e "s:BINDIR = \\\$(DESTDIR)/usr/local/bin:BINDIR = ${D}/usr/bin:g" ${S}/Makefile
sed -i -e "s:CC = gcc:CC = $(tc-getCC):g" ${S}/Makefile
diff --git a/x11-misc/synaptics/synaptics-0.14.2.ebuild b/x11-misc/synaptics/synaptics-0.14.2.ebuild
index 8f17650c0029..aac0fa9d185a 100644
--- a/x11-misc/synaptics/synaptics-0.14.2.ebuild
+++ b/x11-misc/synaptics/synaptics-0.14.2.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2005 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/x11-misc/synaptics/synaptics-0.14.2.ebuild,v 1.4 2005/07/22 23:23:12 battousai Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-misc/synaptics/synaptics-0.14.2.ebuild,v 1.5 2005/07/25 18:09:09 battousai Exp $
inherit toolchain-funcs eutils
@@ -19,6 +19,8 @@ src_unpack() {
cd ${S}
+ epatch ${FILESDIR}/${PN}-0.14.x-gcc4-the-sentinels-have-attacked.patch
+
# Put stuff into /usr, also switch up the CC and CFLAGS stuff.
sed -i -e "s:BINDIR = \\\$(DESTDIR)/usr/local/bin:BINDIR = ${D}/usr/bin:g" ${S}/Makefile
sed -i -e "s:CC = gcc:CC = $(tc-getCC):g" ${S}/Makefile
diff --git a/x11-misc/synaptics/synaptics-0.14.3.ebuild b/x11-misc/synaptics/synaptics-0.14.3.ebuild
index 0ec5f32ab60d..407c5fced1f9 100644
--- a/x11-misc/synaptics/synaptics-0.14.3.ebuild
+++ b/x11-misc/synaptics/synaptics-0.14.3.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2005 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/x11-misc/synaptics/synaptics-0.14.3.ebuild,v 1.3 2005/07/22 23:23:12 battousai Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-misc/synaptics/synaptics-0.14.3.ebuild,v 1.4 2005/07/25 18:09:09 battousai Exp $
inherit toolchain-funcs eutils
@@ -19,6 +19,8 @@ src_unpack() {
cd ${S}
+ epatch ${FILESDIR}/${PN}-0.14.x-gcc4-the-sentinels-have-attacked.patch
+
# Put stuff into /usr, also switch up the CC and CFLAGS stuff.
sed -i -e "s:BINDIR = \\\$(DESTDIR)/usr/local/bin:BINDIR = ${D}/usr/bin:g" ${S}/Makefile
sed -i -e "s:CC = gcc:CC = $(tc-getCC):g" ${S}/Makefile