summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorIan Stakenvicius <axs@gentoo.org>2012-11-04 01:02:57 +0000
committerIan Stakenvicius <axs@gentoo.org>2012-11-04 01:02:57 +0000
commitb9d09131526e3add4a35e13fba75055ce3329e1c (patch)
tree86e21019ed5ca3a267cbe25a3d34f10cb9c726d8 /x11-misc/slim/slim-1.3.4-r1.ebuild
parentNew snapshot. (diff)
downloadgentoo-2-b9d09131526e3add4a35e13fba75055ce3329e1c.tar.gz
gentoo-2-b9d09131526e3add4a35e13fba75055ce3329e1c.tar.bz2
gentoo-2-b9d09131526e3add4a35e13fba75055ce3329e1c.zip
made pkg_postinst messages relevant based on emerge context to reduce elog spam
(Portage version: 2.1.11.30/cvs/Linux x86_64, signed Manifest commit with key 2B6559ED)
Diffstat (limited to 'x11-misc/slim/slim-1.3.4-r1.ebuild')
-rw-r--r--x11-misc/slim/slim-1.3.4-r1.ebuild59
1 files changed, 32 insertions, 27 deletions
diff --git a/x11-misc/slim/slim-1.3.4-r1.ebuild b/x11-misc/slim/slim-1.3.4-r1.ebuild
index 8d17a1c30934..550a50636253 100644
--- a/x11-misc/slim/slim-1.3.4-r1.ebuild
+++ b/x11-misc/slim/slim-1.3.4-r1.ebuild
@@ -1,11 +1,11 @@
# Copyright 1999-2012 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/x11-misc/slim/slim-1.3.4-r1.ebuild,v 1.2 2012/10/05 19:22:14 axs Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-misc/slim/slim-1.3.4-r1.ebuild,v 1.3 2012/11/04 01:02:57 axs Exp $
EAPI=4
CMAKE_MIN_VERSION="2.8.8"
-inherit cmake-utils pam eutils
+inherit cmake-utils pam eutils versionator
DESCRIPTION="Simple Login Manager"
HOMEPAGE="http://slim.berlios.de"
@@ -75,32 +75,37 @@ src_install() {
}
pkg_postinst() {
- elog
- elog "The configuration file is located at /etc/slim.conf."
- elog
- elog "If you wish ${PN} to start automatically, set DISPLAYMANAGER=\"${PN}\" "
- elog "in /etc/conf.d/xdm and run \"rc-update add xdm default\"."
- elog
- elog "By default, ${PN} now does proper X session selection, including ~/.xsession"
- elog "support, as well as selection between sessions available in"
- elog "/etc/X11/Sessions/ at login by pressing [F1]."
- elog
- elog "The XSESSION environment variable is still supported as a default"
- elog "if no session has been specified by the user."
- elog
- elog "If you want to use .xinitrc in the user's home directory for session"
- elog "management instead, see README and xinitrc.sample in"
- elog "/usr/share/doc/${PF} and change your login_cmd in /etc/slim.conf"
- elog "accordingly."
- elog
- ewarn "Please note that slim now supports consolekit directly. Please remove any "
- ewarn "existing work-arounds (including all calls to 'ck-launch-session' in "
- ewarn "xinitrc scripts) and enable USE=\"consolekit\""
- elog
+ # note, $REPLACING_VERSIONS will always contain 0 or 1 PV's for slim
+ if [[ -z ${REPLACING_VERSIONS} ]]; then
+ elog
+ elog "The configuration file is located at /etc/slim.conf."
+ elog
+ elog "If you wish ${PN} to start automatically, set DISPLAYMANAGER=\"${PN}\" "
+ elog "in /etc/conf.d/xdm and run \"rc-update add xdm default\"."
+ fi
+ if ! version_is_at_least "1.3.2-r7" "${REPLACING_VERSIONS:-1.0}" ; then
+ elog
+ elog "By default, ${PN} is set up to do proper X session selection, including ~/.xsession"
+ elog "support, as well as selection between sessions available in"
+ elog "/etc/X11/Sessions/ at login by pressing [F1]."
+ elog
+ elog "The XSESSION environment variable is still supported as a default"
+ elog "if no session has been specified by the user."
+ elog
+ elog "If you want to use .xinitrc in the user's home directory for session"
+ elog "management instead, see README and xinitrc.sample in"
+ elog "/usr/share/doc/${PF} and change your login_cmd in /etc/slim.conf"
+ elog "accordingly."
+ elog
+ ewarn "Please note that slim supports consolekit directly. Please do not use any "
+ ewarn "old work-arounds (including calls to 'ck-launch-session' in xinitrc scripts)"
+ ewarn "and enable USE=\"consolekit\" instead."
+ ewarn
+ fi
if ! use pam; then
- elog "You have merged ${PN} without USE=pam, this will cause ${PN} to fall back to"
- elog "the console when restarting your window manager. If this is not"
- elog "desired, then please remerge ${PN} with USE=pam"
+ elog "You have merged ${PN} without USE=\"pam\", this will cause ${PN} to fall back to"
+ elog "the console when restarting your window manager. If this is not desired, then"
+ elog "please remerge ${PN} with USE=\"pam\""
elog
fi
}