summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTristan Heaven <nyhm@gentoo.org>2009-01-22 18:12:53 +0000
committerTristan Heaven <nyhm@gentoo.org>2009-01-22 18:12:53 +0000
commit4dc9087b89acb6e5c5e3bdf4081b583a61c13a0d (patch)
tree60512f621ae526366d8fceb92170986c16875ab8 /x11-misc/revelation
parentFix zone2ldap, bug #253959. (diff)
downloadgentoo-2-4dc9087b89acb6e5c5e3bdf4081b583a61c13a0d.tar.gz
gentoo-2-4dc9087b89acb6e5c5e3bdf4081b583a61c13a0d.tar.bz2
gentoo-2-4dc9087b89acb6e5c5e3bdf4081b583a61c13a0d.zip
Depend on the split gnome-python packages, bug #248786; respect CFLAGS/LDFLAGS
(Portage version: 2.2_rc23/cvs/Linux i686)
Diffstat (limited to 'x11-misc/revelation')
-rw-r--r--x11-misc/revelation/ChangeLog11
-rw-r--r--x11-misc/revelation/files/revelation-0.4.11-build.patch58
-rw-r--r--x11-misc/revelation/revelation-0.4.11-r2.ebuild52
3 files changed, 119 insertions, 2 deletions
diff --git a/x11-misc/revelation/ChangeLog b/x11-misc/revelation/ChangeLog
index a0f2bf85abb9..61d3d3e95f46 100644
--- a/x11-misc/revelation/ChangeLog
+++ b/x11-misc/revelation/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for x11-misc/revelation
-# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/x11-misc/revelation/ChangeLog,v 1.11 2008/10/05 23:16:42 nyhm Exp $
+# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/x11-misc/revelation/ChangeLog,v 1.12 2009/01/22 18:12:53 nyhm Exp $
+
+*revelation-0.4.11-r2 (22 Jan 2009)
+
+ 22 Jan 2009; Tristan Heaven <nyhm@gentoo.org>
+ +files/revelation-0.4.11-build.patch, +revelation-0.4.11-r2.ebuild:
+ Depend on the split gnome-python packages, bug #248786; respect
+ CFLAGS/LDFLAGS
*revelation-0.4.11-r1 (05 Oct 2008)
diff --git a/x11-misc/revelation/files/revelation-0.4.11-build.patch b/x11-misc/revelation/files/revelation-0.4.11-build.patch
new file mode 100644
index 000000000000..0a4fe1a17dfb
--- /dev/null
+++ b/x11-misc/revelation/files/revelation-0.4.11-build.patch
@@ -0,0 +1,58 @@
+--- acinclude.m4
++++ acinclude.m4
+@@ -83,7 +83,6 @@
+ AC_DEFUN([RVL_PYGTK], [
+ PKG_CHECK_MODULES(PYGTK, [pygtk-2.0 >= 2.8.0])
+ PKG_CHECK_MODULES(GNOME_PYTHON, [gnome-python-2.0 >= 2.10.0])
+- PKG_CHECK_MODULES(GNOME_PYTHON_EXTRAS, [gnome-python-extras-2.0 >= 2.10.0])
+
+ AC_PATH_PROG(PYGTK_CODEGEN, pygtk-codegen-2.0, no)
+
+--- configure.ac
++++ configure.ac
+@@ -12,6 +12,7 @@
+
+ dnl check for dependencies
+ AC_PROG_CC()
++AC_PROG_LIBTOOL
+
+ RVL_PYTHON_PATH(2.3)
+ RVL_PYGTK()
+--- src/wrap/crack/crack.c
++++ src/wrap/crack/crack.c
+@@ -24,8 +24,6 @@
+
+ #define FILENAME_MAXLEN 512
+
+-static char DEFAULT_DICTPATH[] = "/usr/local/share/revelation/pwdict";
+-
+ static char crack_FascistCheck_doc [] =
+ "arguments: passwd, dictpath (optional)\n"
+ "\n"
+--- src/wrap/crack/Makefile.am
++++ src/wrap/crack/Makefile.am
+@@ -5,19 +5,9 @@
+ # $Id: revelation-0.4.11-build.patch,v 1.1 2009/01/22 18:12:53 nyhm Exp $
+ #
+
+-module_PROGRAMS = crack.so
+ moduledir = $(pyexecdir)/revelation
+-CLEANFILES = crack.c
+-EXTRA_DIST = crack.c.in
+-
+-crack.c: crack.c.in
+- sed \
+- -e "s|\@CRACK_DICTPATH\@|@CRACK_DICTPATH@|" \
+- crack.c.in >crack.c
+-
+-crack.o: crack.c
+- $(CC) -pthread -fno-strict-aliasing -fPIC -I${PYTHON_INCLUDE} -c crack.c -o crack.o
+-
+-crack.so: crack.o
+- $(CC) -Wl --export-dynamic -pthread -shared crack.o -lcrack -o crack.so
+-
++module_LTLIBRARIES = crack.la
++crack_la_SOURCES = crack.c
++crack_la_CFLAGS = -Wall
++crack_la_CPPFLAGS = -I$(PYTHON_INCLUDE) -DDEFAULT_DICTPATH="\"$(CRACK_DICTPATH)\""
++crack_la_LDFLAGS = -module
diff --git a/x11-misc/revelation/revelation-0.4.11-r2.ebuild b/x11-misc/revelation/revelation-0.4.11-r2.ebuild
new file mode 100644
index 000000000000..58624365a7ff
--- /dev/null
+++ b/x11-misc/revelation/revelation-0.4.11-r2.ebuild
@@ -0,0 +1,52 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/x11-misc/revelation/revelation-0.4.11-r2.ebuild,v 1.1 2009/01/22 18:12:53 nyhm Exp $
+
+inherit autotools eutils multilib python gnome2
+
+DESCRIPTION="A password manager for GNOME"
+HOMEPAGE="http://oss.codepoet.no/revelation/"
+SRC_URI="ftp://oss.codepoet.no/${PN}/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE=""
+
+DEPEND="dev-python/pygtk
+ dev-python/pycrypto
+ dev-python/gnome-applets-python
+ dev-python/gconf-python
+ dev-python/gnome-vfs-python
+ dev-python/libbonobo-python
+ dev-python/libgnome-python
+ sys-libs/cracklib"
+
+DOCS="AUTHORS ChangeLog NEWS README TODO"
+
+src_unpack() {
+ gnome2_src_unpack
+ ln -sf $(type -P true) py-compile
+ epatch \
+ "${FILESDIR}"/${P}-list-index.patch \
+ "${FILESDIR}"/${P}-build.patch
+ eautoreconf
+}
+
+src_compile() {
+ gnome2_src_compile \
+ --disable-dependency-tracking \
+ --disable-desktop-update \
+ --disable-mime-update
+}
+
+pkg_postinst() {
+ gnome2_pkg_postinst
+ python_version
+ python_mod_optimize /usr/$(get_libdir)/python${PYVER}/site-packages/${PN}
+}
+
+pkg_postrm() {
+ gnome2_pkg_postrm
+ python_mod_cleanup
+}