summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorStefan Schweizer <genstef@gentoo.org>2005-12-25 00:26:12 +0000
committerStefan Schweizer <genstef@gentoo.org>2005-12-25 00:26:12 +0000
commit598a5cd448d45ef828377619fe773c145b5e5738 (patch)
tree7a093c9a6bd9fca5c3233c0620d5f3f69821671c /x11-misc/lineakd/lineakd-0.8.4.ebuild
parentversion bump, fix installpath thanks to Vincziczki Gabor <vincziczki.gabor@ne... (diff)
downloadgentoo-2-598a5cd448d45ef828377619fe773c145b5e5738.tar.gz
gentoo-2-598a5cd448d45ef828377619fe773c145b5e5738.tar.bz2
gentoo-2-598a5cd448d45ef828377619fe773c145b5e5738.zip
version bump
(Portage version: 2.1_pre1)
Diffstat (limited to 'x11-misc/lineakd/lineakd-0.8.4.ebuild')
-rw-r--r--x11-misc/lineakd/lineakd-0.8.4.ebuild52
1 files changed, 52 insertions, 0 deletions
diff --git a/x11-misc/lineakd/lineakd-0.8.4.ebuild b/x11-misc/lineakd/lineakd-0.8.4.ebuild
new file mode 100644
index 000000000000..9c7c6f04db98
--- /dev/null
+++ b/x11-misc/lineakd/lineakd-0.8.4.ebuild
@@ -0,0 +1,52 @@
+# Copyright 1999-2005 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/x11-misc/lineakd/lineakd-0.8.4.ebuild,v 1.1 2005/12/25 00:24:00 genstef Exp $
+
+inherit eutils
+
+DESCRIPTION="Linux support for Easy Access and Internet Keyboards features X11 support"
+HOMEPAGE="http://lineak.sourceforge.net/"
+SRC_URI="mirror://sourceforge/lineak/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+IUSE=""
+KEYWORDS="~amd64 ~ppc ~x86"
+
+RDEPEND="|| (
+ ( sys-libs/glibc
+ x11-libs/libICE
+ x11-libs/libSM
+ x11-libs/libX11
+ x11-libs/libXext )
+ virtual/x11
+ )"
+DEPEND="${RDEPEND}
+ || (
+ ( x11-libs/libxkbfile
+ x11-libs/libXt
+ x11-proto/xextproto
+ x11-proto/xproto )
+ virtual/x11
+ )"
+
+src_unpack() {
+ unpack ${A}
+ cd ${S}
+ epatch ${FILESDIR}/lineakd-0.8.4-mandestdir.patch
+}
+
+src_compile() {
+ econf --with-x || die "econf failed"
+ emake || die "emake failed"
+}
+
+src_install () {
+ make DESTDIR=${D} lineakddocdir=/usr/share/doc/${P} install || die "make install failed"
+ dodoc AUTHORS README TODO
+ keepdir /usr/lib/lineakd/plugins
+
+ insinto /etc/lineak
+ doins lineakd.conf.example
+ doins lineakd.conf.kde.example
+}