summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDoug Goldstein <cardoe@gentoo.org>2007-11-21 19:48:33 +0000
committerDoug Goldstein <cardoe@gentoo.org>2007-11-21 19:48:33 +0000
commit6469e4b1df69cb189739e19bbf3d3453b1d1f11f (patch)
treeaa1331c74ae7c5401cc78820b073e57436686271 /x11-libs
parentmask expertimental cairo (diff)
downloadgentoo-2-6469e4b1df69cb189739e19bbf3d3453b1d1f11f.tar.gz
gentoo-2-6469e4b1df69cb189739e19bbf3d3453b1d1f11f.tar.bz2
gentoo-2-6469e4b1df69cb189739e19bbf3d3453b1d1f11f.zip
experimental cairo from the future 1.6 series for Firefox-3 testing. Includes potential support to allow FEATURES=test to work
(Portage version: 2.1.3.19)
Diffstat (limited to 'x11-libs')
-rw-r--r--x11-libs/cairo/ChangeLog8
-rw-r--r--x11-libs/cairo/cairo-1.5.2.ebuild78
-rw-r--r--x11-libs/cairo/files/digest-cairo-1.5.23
3 files changed, 88 insertions, 1 deletions
diff --git a/x11-libs/cairo/ChangeLog b/x11-libs/cairo/ChangeLog
index 431bc41b1d14..caf6c0fc6b8d 100644
--- a/x11-libs/cairo/ChangeLog
+++ b/x11-libs/cairo/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for x11-libs/cairo
# Copyright 2000-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/x11-libs/cairo/ChangeLog,v 1.145 2007/09/22 05:38:16 tgall Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-libs/cairo/ChangeLog,v 1.146 2007/11/21 19:48:32 cardoe Exp $
+
+*cairo-1.5.2 (21 Nov 2007)
+
+ 21 Nov 2007; Doug Klima <cardoe@gentoo.org> +cairo-1.5.2.ebuild:
+ experimental cairo from the future 1.6 series for Firefox-3 testing.
+ Includes potential support to allow FEATURES=test to work
22 Sep 2007; Tom Gall <tgall@gentoo.org> cairo-1.4.10.ebuild:
stable on ppc64
diff --git a/x11-libs/cairo/cairo-1.5.2.ebuild b/x11-libs/cairo/cairo-1.5.2.ebuild
new file mode 100644
index 000000000000..377948b34538
--- /dev/null
+++ b/x11-libs/cairo/cairo-1.5.2.ebuild
@@ -0,0 +1,78 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/x11-libs/cairo/cairo-1.5.2.ebuild,v 1.1 2007/11/21 19:48:32 cardoe Exp $
+
+inherit eutils flag-o-matic libtool
+
+DESCRIPTION="A vector graphics library with cross-device output support"
+HOMEPAGE="http://cairographics.org/"
+SRC_URI="http://cairographics.org/snapshots/${P}.tar.gz"
+
+LICENSE="|| ( LGPL-2.1 MPL-1.1 )"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~x86-fbsd"
+IUSE="debug directfb doc glitz opengl svg X xcb test"
+
+RDEPEND="media-libs/fontconfig
+ >=media-libs/freetype-2.1.4
+ sys-libs/zlib
+ media-libs/libpng
+ >=x11-libs/pixman-0.9.4
+ X? (
+ x11-libs/libXrender
+ x11-libs/libXext
+ x11-libs/libX11
+ virtual/xft
+ xcb? ( x11-libs/libxcb
+ x11-libs/xcb-util )
+ )
+ directfb? ( >=dev-libs/DirectFB-0.9.24 )
+ glitz? ( >=media-libs/glitz-0.5.1 )
+ svg? ( dev-libs/libxml2 )"
+
+DEPEND="${RDEPEND}
+ >=dev-util/pkgconfig-0.19
+ sys-apps/findutils
+ test? (
+ virtual/ghostscript
+ >=app-text/poppler-bindings-0.4.1
+ x11-libs/pango
+ x11-libs/gtk+
+ svg? ( >=gnome-base/librsvg-2.15.0 )
+ )
+ X? ( x11-proto/renderproto
+ xcb? ( x11-proto/xcb-proto ) )
+ doc? (
+ >=dev-util/gtk-doc-1.6
+ ~app-text/docbook-xml-dtd-4.2
+ )"
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+
+ # We need to run elibtoolize to ensure correct so versioning on FreeBSD
+ elibtoolize
+}
+
+src_compile() {
+ #gets rid of fbmmx.c inlining warnings
+ append-flags -finline-limit=1200
+
+ if use glitz && use opengl; then
+ export glitz_LIBS=-lglitz-glx
+ fi
+
+ econf $(use_enable X xlib) $(use_enable doc gtk-doc) $(use_enable directfb) \
+ $(use_enable svg) $(use_enable glitz) $(use_enable X xlib-xrender) \
+ $(use_enable debug test-surfaces) --enable-pdf --enable-png \
+ --enable-freetype --enable-ps $(use_enable xcb) \
+ || die "configure failed"
+
+ emake || die "compile failed"
+}
+
+src_install() {
+ make DESTDIR="${D}" install || die "Installation failed"
+ dodoc AUTHORS ChangeLog NEWS README TODO
+}
diff --git a/x11-libs/cairo/files/digest-cairo-1.5.2 b/x11-libs/cairo/files/digest-cairo-1.5.2
new file mode 100644
index 000000000000..ea1d3dc1229b
--- /dev/null
+++ b/x11-libs/cairo/files/digest-cairo-1.5.2
@@ -0,0 +1,3 @@
+MD5 fe26d4ea259d21710a127c8f87f09172 cairo-1.5.2.tar.gz 3314914
+RMD160 657865d46c9cf992b4415b4312dd53e400b1f3a9 cairo-1.5.2.tar.gz 3314914
+SHA256 81e0bb748e126c65e5df724dca11d3a4c842fc6d050fe375d6ce70083f5c2bfc cairo-1.5.2.tar.gz 3314914