summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarkos Chandras <hwoarang@gentoo.org>2009-02-14 15:46:37 +0000
committerMarkos Chandras <hwoarang@gentoo.org>2009-02-14 15:46:37 +0000
commit3fa1179fa688a7234bf6acecf2ecc24478a18f8c (patch)
treec6a12ce8a620896ccb24346b018de423035029a3 /x11-libs
parentrevbump with qt-copy patches,Thanks to Maciej Mrozowski (reavertm) (diff)
downloadgentoo-2-3fa1179fa688a7234bf6acecf2ecc24478a18f8c.tar.gz
gentoo-2-3fa1179fa688a7234bf6acecf2ecc24478a18f8c.tar.bz2
gentoo-2-3fa1179fa688a7234bf6acecf2ecc24478a18f8c.zip
revbump with qt-copy patches, Thanks to Maciej Mrozowski (reavertm)
(Portage version: 2.1.6.7/cvs/Linux i686)
Diffstat (limited to 'x11-libs')
-rw-r--r--x11-libs/qt-sql/ChangeLog9
-rw-r--r--x11-libs/qt-sql/files/0234-fix-mysql-threaded.diff32
-rw-r--r--x11-libs/qt-sql/qt-sql-4.4.2-r1.ebuild71
3 files changed, 111 insertions, 1 deletions
diff --git a/x11-libs/qt-sql/ChangeLog b/x11-libs/qt-sql/ChangeLog
index 276bf06ebb49..147febcd91f1 100644
--- a/x11-libs/qt-sql/ChangeLog
+++ b/x11-libs/qt-sql/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for x11-libs/qt-sql
# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/x11-libs/qt-sql/ChangeLog,v 1.26 2009/02/11 23:19:38 yngwin Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-libs/qt-sql/ChangeLog,v 1.27 2009/02/14 15:46:37 hwoarang Exp $
+
+*qt-sql-4.4.2-r1 (14 Feb 2009)
+
+ 14 Feb 2009; Markos Chandras <hwoarang@gentoo.org>
+ +files/0234-fix-mysql-threaded.diff, +qt-sql-4.4.2-r1.ebuild:
+ revbump with qt-copy patches. Thanks to Maciej Mrozowski (reavertm)
+ <reavertm@poczta.fm>
*qt-sql-4.5.0_rc1 (11 Feb 2009)
diff --git a/x11-libs/qt-sql/files/0234-fix-mysql-threaded.diff b/x11-libs/qt-sql/files/0234-fix-mysql-threaded.diff
new file mode 100644
index 000000000000..4c5b6136b8c1
--- /dev/null
+++ b/x11-libs/qt-sql/files/0234-fix-mysql-threaded.diff
@@ -0,0 +1,32 @@
+qt-bugs@ issue : N217716
+Trolltech task ID : 217788
+bugs.kde.org number : no report
+applied: no
+author: Tobias Koenig <tokoe@kde.org>
+
+This patch will fix the handling of connections to
+mysql server in a multithreaded environment
+
+--- src/sql/drivers/mysql/qsql_mysql.cpp (revision 804421)
++++ src/sql/drivers/mysql/qsql_mysql.cpp (working copy)
+@@ -1215,6 +1215,10 @@
+ d->preparedQuerysEnabled = false;
+ #endif
+
++#ifndef QT_NO_THREAD
++ mysql_thread_init();
++#endif
++
+ setOpen(true);
+ setOpenError(false);
+ return true;
+@@ -1223,6 +1227,9 @@
+ void QMYSQLDriver::close()
+ {
+ if (isOpen()) {
++#ifndef QT_NO_THREAD
++ mysql_thread_end();
++#endif
+ mysql_close(d->mysql);
+ setOpen(false);
+ setOpenError(false);
diff --git a/x11-libs/qt-sql/qt-sql-4.4.2-r1.ebuild b/x11-libs/qt-sql/qt-sql-4.4.2-r1.ebuild
new file mode 100644
index 000000000000..246c17088e7b
--- /dev/null
+++ b/x11-libs/qt-sql/qt-sql-4.4.2-r1.ebuild
@@ -0,0 +1,71 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/x11-libs/qt-sql/qt-sql-4.4.2-r1.ebuild,v 1.1 2009/02/14 15:46:37 hwoarang Exp $
+
+EAPI="1"
+inherit qt4-build
+
+DESCRIPTION="The SQL module for the Qt toolkit."
+HOMEPAGE="http://www.trolltech.com/"
+
+LICENSE="|| ( GPL-3 GPL-2 )"
+SLOT="4"
+KEYWORDS="~alpha ~amd64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd"
+
+IUSE="firebird mysql odbc postgres +qt3support +sqlite"
+
+DEPEND="
+ ~x11-libs/qt-core-${PV}
+ !<=x11-libs/qt-4.4.0_alpha:${SLOT}
+ firebird? ( dev-db/firebird )
+ sqlite? ( dev-db/sqlite:3 )
+ mysql? ( virtual/mysql )
+ postgres? ( virtual/postgresql-base )
+ odbc? ( dev-db/unixODBC )"
+RDEPEND="${DEPEND}"
+
+QT4_TARGET_DIRECTORIES="src/sql src/plugins/sqldrivers"
+QT4_EXTRACT_DIRECTORIES="${QT4_TARGET_DIRECTORIES}"
+
+pkg_setup() {
+ if ! (use firebird || use mysql || use odbc || use postgres || use sqlite); then
+ ewarn "You need to enable at least one SQL driver. Enable at least"
+ ewarn "one of these USE flags: \"firebird mysql odbc postgres sqlite\""
+ die "Enable at least one SQL driver."
+ fi
+
+ use qt3support && QT4_BUILT_WITH_USE_CHECK="${QT4_BUILT_WITH_USE_CHECK}
+ ~x11-libs/qt-core-${PV} qt3support"
+
+ qt4-build_pkg_setup
+}
+
+src_unpack() {
+ qt4-build_src_unpack
+
+ # Apply bugfix patches from qt-copy (KDE)
+ epatch "${FILESDIR}"/0234-fix-mysql-threaded.diff
+
+ sed -e '/pg_config --libs/d' -i "${S}"/configure \
+ || die 'Sed to fix postgresql usage in ./configure failed.'
+}
+
+src_compile() {
+ local myconf
+ # Don't support sqlite2 anymore
+ myconf="${myconf} -no-sql-sqlite2
+ $(qt_use mysql sql-mysql plugin) $(use mysql && echo "-I/usr/include/mysql -L/usr/$(get_libdir)/mysql ")
+ $(qt_use postgres sql-psql plugin) $(use postgres && echo "-I/usr/include/postgresql/pgsql ")
+ $(qt_use sqlite sql-sqlite plugin) $(use sqlite && echo '-system-sqlite')
+ $(qt_use odbc sql-odbc plugin)
+ $(qt_use qt3support)"
+
+ myconf="${myconf} -no-xkb -no-tablet -no-fontconfig -no-xrender -no-xrandr
+ -no-xfixes -no-xcursor -no-xinerama -no-xshape -no-sm -no-opengl
+ -no-nas-sound -no-dbus -iconv -no-cups -no-nis -no-gif -no-libpng
+ -no-libmng -no-libjpeg -no-openssl -system-zlib -no-webkit -no-phonon
+ -no-xmlpatterns -no-freetype -no-libtiff -no-accessibility -no-fontconfig
+ -no-glib -no-opengl -no-svg"
+
+ qt4-build_src_compile
+}