summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorChí-Thanh Christopher Nguyễn <chithanh@gentoo.org>2014-05-08 12:56:04 +0000
committerChí-Thanh Christopher Nguyễn <chithanh@gentoo.org>2014-05-08 12:56:04 +0000
commit0a593767461d770017a02f4e4edeefc193851a3e (patch)
tree51dd130af7aa8310eed4e79b4c3c03d5cf25041d /x11-libs
parentEnable x11-libs/libxcb[xkb] by default in the desktop profile. (diff)
downloadgentoo-2-0a593767461d770017a02f4e4edeefc193851a3e.tar.gz
gentoo-2-0a593767461d770017a02f4e4edeefc193851a3e.tar.bz2
gentoo-2-0a593767461d770017a02f4e4edeefc193851a3e.zip
Version bump, bug #509550. Add multilib support, bug #496696.
(Portage version: 2.2.8-r1/cvs/Linux x86_64, unsigned Manifest commit)
Diffstat (limited to 'x11-libs')
-rw-r--r--x11-libs/libxkbcommon/ChangeLog8
-rw-r--r--x11-libs/libxkbcommon/libxkbcommon-0.4.1.ebuild39
2 files changed, 46 insertions, 1 deletions
diff --git a/x11-libs/libxkbcommon/ChangeLog b/x11-libs/libxkbcommon/ChangeLog
index 04339ac5ad88..47a2002840b0 100644
--- a/x11-libs/libxkbcommon/ChangeLog
+++ b/x11-libs/libxkbcommon/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for x11-libs/libxkbcommon
# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/x11-libs/libxkbcommon/ChangeLog,v 1.7 2014/04/21 10:30:31 ago Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-libs/libxkbcommon/ChangeLog,v 1.8 2014/05/08 12:56:04 chithanh Exp $
+
+*libxkbcommon-0.4.1 (08 May 2014)
+
+ 08 May 2014; Chí-Thanh Christopher Nguyễn <chithanh@gentoo.org>
+ +libxkbcommon-0.4.1.ebuild:
+ Version bump, bug #509550. Add multilib support, bug #496696.
21 Apr 2014; Agostino Sarubbo <ago@gentoo.org> libxkbcommon-0.3.1.ebuild:
Stable for arm, wrt bug #507568
diff --git a/x11-libs/libxkbcommon/libxkbcommon-0.4.1.ebuild b/x11-libs/libxkbcommon/libxkbcommon-0.4.1.ebuild
new file mode 100644
index 000000000000..90a605a5be75
--- /dev/null
+++ b/x11-libs/libxkbcommon/libxkbcommon-0.4.1.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/x11-libs/libxkbcommon/libxkbcommon-0.4.1.ebuild,v 1.1 2014/05/08 12:56:04 chithanh Exp $
+
+EAPI=5
+XORG_EAUTORECONF="yes"
+XORG_MULTILIB="yes"
+
+if [[ ${PV} = *9999* ]]; then
+ GIT_ECLASS="git-r3"
+ EXPERIMENTAL="true"
+ EGIT_REPO_URI="git://github.com/xkbcommon/${PN}"
+else
+ XORG_BASE_INDIVIDUAL_URI=""
+ SRC_URI="http://xkbcommon.org/download/${P}.tar.xz"
+fi
+
+inherit xorg-2 ${GIT_ECLASS}
+
+DESCRIPTION="X.Org xkbcommon library"
+KEYWORDS="~amd64 ~arm ~x86"
+IUSE="X doc"
+
+DEPEND="sys-devel/bison
+ sys-devel/flex
+ X? ( >=x11-libs/libxcb-1.10[${MULTILIB_USEDEP},xkb] )
+ x11-proto/xproto[${MULTILIB_USEDEP}]
+ >=x11-proto/kbproto-1.0.5[${MULTILIB_USEDEP}]
+ doc? ( app-doc/doxygen )"
+RDEPEND=""
+
+pkg_setup() {
+ XORG_CONFIGURE_OPTIONS=(
+ --with-xkb-config-root="${EPREFIX}/usr/share/X11/xkb"
+ $(use X || use_enable X x11)
+ $(use_with doc doxygen)
+ )
+ xorg-2_pkg_setup
+}