summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTomas Chvatal <scarabeus@gentoo.org>2011-04-26 09:52:27 +0000
committerTomas Chvatal <scarabeus@gentoo.org>2011-04-26 09:52:27 +0000
commit044363edd641f9ddad96ea0bac7afac92500af28 (patch)
treeaf7f3e1366ff8842561cd2107afbc4a1d7acf315 /x11-libs
parentx86 stable per bug 361225 (diff)
downloadgentoo-2-044363edd641f9ddad96ea0bac7afac92500af28.tar.gz
gentoo-2-044363edd641f9ddad96ea0bac7afac92500af28.tar.bz2
gentoo-2-044363edd641f9ddad96ea0bac7afac92500af28.zip
Version bump to 0.3.8. This is first split release.
(Portage version: 2.2.0_alpha30/cvs/Linux x86_64)
Diffstat (limited to 'x11-libs')
-rw-r--r--x11-libs/xcb-util/ChangeLog9
-rw-r--r--x11-libs/xcb-util/xcb-util-0.3.8.ebuild40
2 files changed, 47 insertions, 2 deletions
diff --git a/x11-libs/xcb-util/ChangeLog b/x11-libs/xcb-util/ChangeLog
index 60ecf17fb8f9..8c3497d05eae 100644
--- a/x11-libs/xcb-util/ChangeLog
+++ b/x11-libs/xcb-util/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for x11-libs/xcb-util
-# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/x11-libs/xcb-util/ChangeLog,v 1.50 2010/01/23 21:06:31 scarabeus Exp $
+# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/x11-libs/xcb-util/ChangeLog,v 1.51 2011/04/26 09:52:27 scarabeus Exp $
+
+*xcb-util-0.3.8 (26 Apr 2011)
+
+ 26 Apr 2011; Tomáš Chvátal <scarabeus@gentoo.org> +xcb-util-0.3.8.ebuild:
+ Version bump to 0.3.8. This is first split release.
23 Jan 2010; Tomáš Chvátal <scarabeus@gentoo.org>
-xcb-util-0.3.3.ebuild:
diff --git a/x11-libs/xcb-util/xcb-util-0.3.8.ebuild b/x11-libs/xcb-util/xcb-util-0.3.8.ebuild
new file mode 100644
index 000000000000..48afb1295f83
--- /dev/null
+++ b/x11-libs/xcb-util/xcb-util-0.3.8.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/x11-libs/xcb-util/xcb-util-0.3.8.ebuild,v 1.1 2011/04/26 09:52:27 scarabeus Exp $
+
+EAPI=4
+
+XORG_MODULE=/
+XORG_BASE_INDIVIDUAL_URI=http://xcb.freedesktop.org/dist
+XORG_DOC=doc
+inherit xorg-2
+
+EGIT_REPO_URI="git://anongit.freedesktop.org/git/xcb/util"
+EGIT_HAS_SUBMODULES=yes
+
+DESCRIPTION="X C-language Bindings sample implementations"
+HOMEPAGE="http://xcb.freedesktop.org/"
+
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~x86-fbsd ~x86-freebsd ~x86-interix ~amd64-linux ~ia64-linux ~x86-linux ~ppc-macos ~x86-macos ~sparc-solaris ~x64-solaris"
+IUSE="test"
+
+RDEPEND=">=x11-libs/libxcb-1.7
+ x11-proto/xproto"
+DEPEND="${RDEPEND}
+ >=dev-util/gperf-3.0.1
+ test? ( >=dev-libs/check-0.9.4 )"
+
+PDEPEND="
+ >=x11-libs/xcb-util-image-${PV}
+ >=x11-libs/xcb-util-keysyms-${PV}
+ >=x11-libs/xcb-util-renderutil-${PV}
+ >=x11-libs/xcb-util-wm-${PV}
+"
+
+pkg_setup() {
+ XORG_CONFIGURE_OPTIONS=(
+ $(use_with doc doxygen)
+ )
+
+ xorg-2_pkg_setup
+}