summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorIngmar Vanhassel <ingmar@gentoo.org>2008-03-05 23:12:52 +0000
committerIngmar Vanhassel <ingmar@gentoo.org>2008-03-05 23:12:52 +0000
commitec3b55f45f9d4f4d6d166fddcc8397510236fcca (patch)
treeaefbc009456fbcce207eab40355050f13b2b1a2f /x11-libs/qt-phonon
parentAdded Qt-4.4.0_beta, note that the RC1 is an accidentally mislabelled (diff)
downloadgentoo-2-ec3b55f45f9d4f4d6d166fddcc8397510236fcca.tar.gz
gentoo-2-ec3b55f45f9d4f4d6d166fddcc8397510236fcca.tar.bz2
gentoo-2-ec3b55f45f9d4f4d6d166fddcc8397510236fcca.zip
Added Qt-4.4.0_beta, note that the RC1 is an accidentally mislabelled
`technical preview`, so this will appear as a downgrade if you installed that version. Thanks to David Leverton, Bo Andresen, Bernd Steinhauser & Arfrever Frehtes Taifersar Arahesis Fixes bugs: 206975, 212086, 172219, 212069, 206976 (Portage version: 2.1.4.4)
Diffstat (limited to 'x11-libs/qt-phonon')
-rw-r--r--x11-libs/qt-phonon/ChangeLog12
-rw-r--r--x11-libs/qt-phonon/qt-phonon-4.4.0_beta1.ebuild33
2 files changed, 43 insertions, 2 deletions
diff --git a/x11-libs/qt-phonon/ChangeLog b/x11-libs/qt-phonon/ChangeLog
index 1aa905a7432b..d8a3c066d1f5 100644
--- a/x11-libs/qt-phonon/ChangeLog
+++ b/x11-libs/qt-phonon/ChangeLog
@@ -1,6 +1,14 @@
# ChangeLog for x11-libs/qt-phonon
-# Copyright 1999-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/x11-libs/qt-phonon/ChangeLog,v 1.1 2007/12/20 12:26:40 caleb Exp $
+# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/x11-libs/qt-phonon/ChangeLog,v 1.2 2008/03/05 23:12:52 ingmar Exp $
+
+*qt-phonon-4.4.0_beta1 (05 Mar 2008)
+
+ 05 Mar 2008; Ingmar Vanhassel <ingmar@gentoo.org>
+ +qt-phonon-4.4.0_beta1.ebuild:
+ Added Qt-4.4.0_beta, note that the RC1 is an accidentally mislabelled
+ `technical preview`, so this will appear as a downgrade if you installed
+ that version.
*qt-phonon-4.4.0_rc1 (20 Dec 2007)
diff --git a/x11-libs/qt-phonon/qt-phonon-4.4.0_beta1.ebuild b/x11-libs/qt-phonon/qt-phonon-4.4.0_beta1.ebuild
new file mode 100644
index 000000000000..79e0184ad0dc
--- /dev/null
+++ b/x11-libs/qt-phonon/qt-phonon-4.4.0_beta1.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/x11-libs/qt-phonon/qt-phonon-4.4.0_beta1.ebuild,v 1.1 2008/03/05 23:12:52 ingmar Exp $
+
+inherit qt4-build
+
+DESCRIPTION="The Phonon module for the Qt toolkit."
+HOMEPAGE="http://www.trolltech.com/"
+
+LICENSE="|| ( QPL-1.0 GPL-3 GPL-2 )"
+SLOT="4"
+KEYWORDS="~amd64 ~x86"
+IUSE="dbus"
+
+DEPEND="~x11-libs/qt-gui-${PV}
+ media-libs/gstreamer
+ media-libs/gst-plugins-base
+ dbus? ( =x11-libs/qt-dbus-${PV} )"
+RDEPEND="${DEPEND}"
+
+QT4_TARGET_DIRECTORIES="
+src/phonon
+src/plugins/phonon"
+QCONFIG_ADD="phonon"
+QCONFIG_DEFINE="QT_GSTREAMER"
+
+src_compile() {
+ local myconf
+ myconf="${myconf} -phonon -no-opengl
+ $(qt_use dbus qdbus)"
+
+ qt4-build_src_compile
+}