summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBen de Groot <yngwin@gentoo.org>2012-09-14 08:17:40 +0000
committerBen de Groot <yngwin@gentoo.org>2012-09-14 08:17:40 +0000
commitc2b957c83caa37033cdd223f25db2fcc50276f41 (patch)
tree2d3e4178fa8f74ae9cf57225bd8f91ec0712d7d2 /x11-libs/qt-phonon
parentEAPI bump for Prefix support by Christoph Junghans <ottxor@gentoo.org>. #434782 (diff)
downloadgentoo-2-c2b957c83caa37033cdd223f25db2fcc50276f41.tar.gz
gentoo-2-c2b957c83caa37033cdd223f25db2fcc50276f41.tar.bz2
gentoo-2-c2b957c83caa37033cdd223f25db2fcc50276f41.zip
Version bump. Drop qatomic-x32 patch applied upstream. Drop qpa useflag.
(Portage version: 2.2.0_alpha128/cvs/Linux x86_64)
Diffstat (limited to 'x11-libs/qt-phonon')
-rw-r--r--x11-libs/qt-phonon/ChangeLog7
-rw-r--r--x11-libs/qt-phonon/qt-phonon-4.8.3.ebuild56
2 files changed, 62 insertions, 1 deletions
diff --git a/x11-libs/qt-phonon/ChangeLog b/x11-libs/qt-phonon/ChangeLog
index c9281fa6cd1e..41264111bf75 100644
--- a/x11-libs/qt-phonon/ChangeLog
+++ b/x11-libs/qt-phonon/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for x11-libs/qt-phonon
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/x11-libs/qt-phonon/ChangeLog,v 1.125 2012/09/11 10:47:23 johu Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-libs/qt-phonon/ChangeLog,v 1.126 2012/09/14 08:17:40 yngwin Exp $
+
+*qt-phonon-4.8.3 (14 Sep 2012)
+
+ 14 Sep 2012; Ben de Groot <yngwin@gentoo.org> +qt-phonon-4.8.3.ebuild:
+ Version bump. Drop qatomic-x32 patch applied upstream. Drop qpa useflag.
11 Sep 2012; Johannes Huber <johu@gentoo.org> qt-phonon-4.7.4.ebuild,
qt-phonon-4.8.1.ebuild, qt-phonon-4.8.2.ebuild:
diff --git a/x11-libs/qt-phonon/qt-phonon-4.8.3.ebuild b/x11-libs/qt-phonon/qt-phonon-4.8.3.ebuild
new file mode 100644
index 000000000000..cd443022a63d
--- /dev/null
+++ b/x11-libs/qt-phonon/qt-phonon-4.8.3.ebuild
@@ -0,0 +1,56 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/x11-libs/qt-phonon/qt-phonon-4.8.3.ebuild,v 1.1 2012/09/14 08:17:40 yngwin Exp $
+
+EAPI=4
+
+inherit qt4-build
+
+DESCRIPTION="The Phonon module for the Qt toolkit"
+SLOT="4"
+if [[ ${QT4_BUILD_TYPE} == live ]]; then
+ KEYWORDS=""
+else
+ KEYWORDS="~amd64 ~arm ~hppa ~ia64 ~ppc ~ppc64 ~x86 ~x86-fbsd ~x86-freebsd ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~x64-solaris ~x86-solaris"
+fi
+IUSE="dbus qt3support"
+
+DEPEND="
+ ~x11-libs/qt-gui-${PV}[aqua=,c++0x=,debug=,qt3support=]
+ !kde-base/phonon-kde
+ !kde-base/phonon-xine
+ !media-libs/phonon
+ !media-sound/phonon
+ !aqua? ( media-libs/gstreamer:0.10
+ media-plugins/gst-plugins-meta:0.10 )
+ aqua? ( ~x11-libs/qt-opengl-${PV}[aqua,debug=,qt3support=] )
+ dbus? ( ~x11-libs/qt-dbus-${PV}[aqua=,c++0x=,debug=] )
+"
+RDEPEND="${DEPEND}"
+
+pkg_setup() {
+ QT4_TARGET_DIRECTORIES="
+ src/phonon
+ src/plugins/phonon
+ tools/designer/src/plugins/phononwidgets"
+
+ QT4_EXTRACT_DIRECTORIES="${QT4_TARGET_DIRECTORIES}
+ include
+ src
+ tools"
+
+ QCONFIG_ADD="phonon"
+ QCONFIG_DEFINE="QT_PHONON
+ $(use !aqua && echo QT_GSTREAMER)"
+
+ qt4-build_pkg_setup
+}
+
+src_configure() {
+ myconf+="
+ -phonon -phonon-backend -no-opengl -no-svg
+ $(qt_use dbus qdbus)
+ $(qt_use qt3support)"
+
+ qt4-build_src_configure
+}