summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSeemant Kulleen <seemant@gentoo.org>2003-03-20 12:57:30 +0000
committerSeemant Kulleen <seemant@gentoo.org>2003-03-20 12:57:30 +0000
commit9aa983f32c8b666e42bbc10f2479d4658b0649f3 (patch)
tree1072de7fedf64d1884283c9eb898be21dc71ed94 /x11-libs/libast
parentkde-3.1.1 i18n ebuilds (diff)
downloadgentoo-2-9aa983f32c8b666e42bbc10f2479d4658b0649f3.tar.gz
gentoo-2-9aa983f32c8b666e42bbc10f2479d4658b0649f3.tar.bz2
gentoo-2-9aa983f32c8b666e42bbc10f2479d4658b0649f3.zip
pic nonsense removed
Diffstat (limited to 'x11-libs/libast')
-rw-r--r--x11-libs/libast/libast-0.4-r1.ebuild20
-rw-r--r--x11-libs/libast/libast-0.5.ebuild16
2 files changed, 16 insertions, 20 deletions
diff --git a/x11-libs/libast/libast-0.4-r1.ebuild b/x11-libs/libast/libast-0.4-r1.ebuild
index d2f285df4d94..414ad5b5aca8 100644
--- a/x11-libs/libast/libast-0.4-r1.ebuild
+++ b/x11-libs/libast/libast-0.4-r1.ebuild
@@ -1,27 +1,23 @@
# Copyright 1999-2003 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/x11-libs/libast/libast-0.4-r1.ebuild,v 1.9 2003/02/13 16:58:35 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-libs/libast/libast-0.4-r1.ebuild,v 1.10 2003/03/20 12:57:30 seemant Exp $
S=${WORKDIR}/${P}
DESCRIPTION="LIBrary of Assorted Spiffy Things. Needed for Eterm."
-SRC_URI="http://www.eterm.org/download/${P}.tar.gz"
HOMEPAGE="http://www.eterm.org/download"
-LICENSE="GPL-2"
+SRC_URI="http://www.eterm.org/download/${P}.tar.gz"
+
SLOT="0"
-KEYWORDS="x86 ppc sparc "
+LICENSE="GPL-2"
+KEYWORDS="x86 ppc sparc ~alpha ~mips ~hppa ~arm"
-DEPEND="virtual/glibc
- virtual/x11
- >=media-libs/freetype-1.3"
+DEPEND="virtual/x11
+ >=media-libs/freetype-1.3"
src_compile() {
# always disable mmx because binutils-2.11.92+ seems to be broken for this package
myconf="--disable-mmx"
- ./configure \
- --host=${CHOST} \
- --prefix=/usr \
- --infodir=/usr/share/info \
- --mandir=/usr/share/man "${myconf}" || die "./configure failed"
+ econf || die
emake || die
}
diff --git a/x11-libs/libast/libast-0.5.ebuild b/x11-libs/libast/libast-0.5.ebuild
index 4a24fe997718..f01d44f0410f 100644
--- a/x11-libs/libast/libast-0.5.ebuild
+++ b/x11-libs/libast/libast-0.5.ebuild
@@ -1,24 +1,24 @@
# Copyright 1999-2003 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/x11-libs/libast/libast-0.5.ebuild,v 1.4 2003/03/03 09:31:29 aliz Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-libs/libast/libast-0.5.ebuild,v 1.5 2003/03/20 12:57:30 seemant Exp $
+
+IUSE="imlib"
S=${WORKDIR}/${P}
DESCRIPTION="LIBrary of Assorted Spiffy Things. Needed for Eterm."
-SRC_URI="http://www.eterm.org/download/${P}.tar.gz"
HOMEPAGE="http://www.eterm.org/download/"
-LICENSE="GPL-2"
+SRC_URI="http://www.eterm.org/download/${P}.tar.gz"
+
SLOT="0"
-KEYWORDS="x86 ppc alpha ~sparc"
-IUSE="pic imlib"
+LICENSE="GPL-2"
+KEYWORDS="x86 ppc alpha ~sparc ~alpha ~mips ~hppa ~arm"
-DEPEND="virtual/glibc
- virtual/x11
+DEPEND="virtual/x11
>=media-libs/freetype-1.3"
src_compile() {
# always disable mmx because binutils-2.11.92+ seems to be broken for this package
local myconf="--disable-mmx --with-gnu-ld --with-x"
- use pic && myconf="${myconf} --with-pic"
use imlib && myconf="${myconf} --with-imlib"
econf ${myconf}