summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorChí-Thanh Christopher Nguyễn <chithanh@gentoo.org>2013-04-28 02:00:11 +0000
committerChí-Thanh Christopher Nguyễn <chithanh@gentoo.org>2013-04-28 02:00:11 +0000
commitbc1f29aead0460ce121d75dc8bbc341adb57cdae (patch)
tree80ac86db5253b09bf03f7cfe7358f5c828d7a947 /x11-drivers
parentUse virtual/libintl for runtime nls dependency #398983 by Maxim Kammerer. (diff)
downloadgentoo-2-bc1f29aead0460ce121d75dc8bbc341adb57cdae.tar.gz
gentoo-2-bc1f29aead0460ce121d75dc8bbc341adb57cdae.tar.bz2
gentoo-2-bc1f29aead0460ce121d75dc8bbc341adb57cdae.zip
Update to latest published ucode files.
(Portage version: 2.1.11.55/cvs/Linux x86_64, unsigned Manifest commit)
Diffstat (limited to 'x11-drivers')
-rw-r--r--x11-drivers/radeon-ucode/ChangeLog8
-rw-r--r--x11-drivers/radeon-ucode/radeon-ucode-20130411.ebuild42
2 files changed, 49 insertions, 1 deletions
diff --git a/x11-drivers/radeon-ucode/ChangeLog b/x11-drivers/radeon-ucode/ChangeLog
index 2790668fe12d..ca0ddf4e48a2 100644
--- a/x11-drivers/radeon-ucode/ChangeLog
+++ b/x11-drivers/radeon-ucode/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for x11-drivers/radeon-ucode
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/x11-drivers/radeon-ucode/ChangeLog,v 1.26 2013/04/03 11:25:21 chithanh Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-drivers/radeon-ucode/ChangeLog,v 1.27 2013/04/28 02:00:11 chithanh Exp $
+
+*radeon-ucode-20130411 (28 Apr 2013)
+
+ 28 Apr 2013; Chí-Thanh Christopher Nguyễn <chithanh@gentoo.org>
+ +radeon-ucode-20130411.ebuild:
+ Update to latest published ucode files.
*radeon-ucode-20130402 (03 Apr 2013)
diff --git a/x11-drivers/radeon-ucode/radeon-ucode-20130411.ebuild b/x11-drivers/radeon-ucode/radeon-ucode-20130411.ebuild
new file mode 100644
index 000000000000..8b5f69b07b28
--- /dev/null
+++ b/x11-drivers/radeon-ucode/radeon-ucode-20130411.ebuild
@@ -0,0 +1,42 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/x11-drivers/radeon-ucode/radeon-ucode-20130411.ebuild,v 1.1 2013/04/28 02:00:11 chithanh Exp $
+
+EAPI=5
+
+inherit linux-info
+
+DESCRIPTION="IRQ microcode for r6xx/r7xx/Evergreen/N.Islands/S.Islands Radeon GPUs and APUs"
+HOMEPAGE="http://people.freedesktop.org/~agd5f/radeon_ucode/"
+SRC_URI="mirror://gentoo/${P}.tar.xz"
+
+LICENSE="radeon-ucode"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND="!sys-kernel/linux-firmware[-savedconfig]"
+
+S=${WORKDIR}/${PN/-/_}
+
+src_install() {
+ insinto /lib/firmware/radeon
+ FILES=( *.bin )
+ doins ${FILES[@]} || die "doins failed"
+}
+
+pkg_postinst() {
+ if linux_config_exists && linux_chkconfig_builtin DRM_RADEON; then
+ if ! linux_chkconfig_present FIRMWARE_IN_KERNEL || \
+ ! [[ "$(linux_chkconfig_string EXTRA_FIRMWARE)" == *_rlc.bin* ]]; then
+ ewarn "Your kernel has radeon DRM built-in but not the IRQ microcode."
+ ewarn "For kernel modesetting to work, please set in kernel config"
+ ewarn "CONFIG_FIRMWARE_IN_KERNEL=y"
+ ewarn "CONFIG_EXTRA_FIRMWARE_DIR=\"/lib/firmware\""
+ ewarn "CONFIG_EXTRA_FIRMWARE=\"${FILES[@]/#/radeon/}\""
+ ewarn "You may skip microcode files for which no hardware is installed."
+ ewarn "More information at http://wiki.x.org/wiki/radeonBuildHowTo and"
+ ewarn "http://www.gentoo.org/doc/en/xorg-config.xml"
+ fi
+ fi
+}