summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorKonstantin V. Arkhipov <voxus@gentoo.org>2008-05-02 11:46:12 +0000
committerKonstantin V. Arkhipov <voxus@gentoo.org>2008-05-02 11:46:12 +0000
commit32e191de45f2037b2b22303096ef34cafeed80e6 (patch)
tree59d173e4d81f4681feab7123cdbce1fe1ed41089 /www-servers
parentfix building with gcc-4.3 by Peter Alfredsen in bug #219779; remove old (diff)
downloadgentoo-2-32e191de45f2037b2b22303096ef34cafeed80e6.tar.gz
gentoo-2-32e191de45f2037b2b22303096ef34cafeed80e6.tar.bz2
gentoo-2-32e191de45f2037b2b22303096ef34cafeed80e6.zip
* bump
(Portage version: 2.1.5_rc6)
Diffstat (limited to 'www-servers')
-rw-r--r--www-servers/nginx/ChangeLog8
-rw-r--r--www-servers/nginx/nginx-0.6.30.ebuild104
2 files changed, 111 insertions, 1 deletions
diff --git a/www-servers/nginx/ChangeLog b/www-servers/nginx/ChangeLog
index 2a545bd26569..07185213ba34 100644
--- a/www-servers/nginx/ChangeLog
+++ b/www-servers/nginx/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for www-servers/nginx
# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/www-servers/nginx/ChangeLog,v 1.176 2008/04/11 14:06:07 voxus Exp $
+# $Header: /var/cvsroot/gentoo-x86/www-servers/nginx/ChangeLog,v 1.177 2008/05/02 11:46:12 voxus Exp $
+
+*nginx-0.6.30 (02 May 2008)
+
+ 02 May 2008; Konstantin V. Arkhipov <voxus@gentoo.org>
+ +nginx-0.6.30.ebuild:
+ Version bump.
11 Apr 2008; Konstantin V. Arkhipov <voxus@gentoo.org>
-nginx-0.5.34.ebuild, nginx-0.5.35.ebuild, -nginx-0.6.24.ebuild,
diff --git a/www-servers/nginx/nginx-0.6.30.ebuild b/www-servers/nginx/nginx-0.6.30.ebuild
new file mode 100644
index 000000000000..1eb27f623f08
--- /dev/null
+++ b/www-servers/nginx/nginx-0.6.30.ebuild
@@ -0,0 +1,104 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/www-servers/nginx/nginx-0.6.30.ebuild,v 1.1 2008/05/02 11:46:12 voxus Exp $
+
+inherit eutils ssl-cert
+
+DESCRIPTION="Robust, small and high performance http and reverse proxy server"
+
+HOMEPAGE="http://nginx.net/"
+SRC_URI="http://sysoev.ru/nginx/${P}.tar.gz"
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE="addition debug fastcgi flv imap pcre perl ssl status sub webdav zlib"
+
+DEPEND="dev-lang/perl
+ pcre? ( >=dev-libs/libpcre-4.2 )
+ ssl? ( dev-libs/openssl )
+ zlib? ( sys-libs/zlib )
+ perl? ( >=dev-lang/perl-5.8 )"
+
+pkg_setup() {
+ ebegin "Creating nginx user and group"
+ enewgroup nginx
+ enewuser nginx -1 -1 /dev/null nginx
+ eend ${?}
+}
+
+src_compile() {
+ local myconf
+
+ # threads support is broken atm.
+ #
+ # if use threads; then
+ # einfo
+ # ewarn "threads support is experimental at the moment"
+ # ewarn "do not use it on production systems - you've been warned"
+ # einfo
+ # myconf="${myconf} --with-threads"
+ # fi
+
+ use addition && myconf="${myconf} --with-http_addition_module"
+ use fastcgi || myconf="${myconf} --without-http_fastcgi_module"
+ use fastcgi && myconf="${myconf} --with-http_realip_module"
+ use flv && myconf="${myconf} --with-http_flv_module"
+ use zlib || myconf="${myconf} --without-http_gzip_module"
+ use pcre || {
+ myconf="${myconf} --without-pcre --without-http_rewrite_module"
+ }
+ use debug && myconf="${myconf} --with-debug"
+ use ssl && myconf="${myconf} --with-http_ssl_module"
+ use imap && myconf="${myconf} --with-imap" # pop3/imap4 proxy support
+ use perl && myconf="${myconf} --with-http_perl_module"
+ use status && myconf="${myconf} --with-http_stub_status_module"
+ use webdav && myconf="${myconf} --with-http_dav_module"
+ use sub && myconf="${myconf} --with-http_sub_module"
+
+ ./configure \
+ --prefix=/usr \
+ --conf-path=/etc/${PN}/${PN}.conf \
+ --http-log-path=/var/log/${PN}/access_log \
+ --error-log-path=/var/log/${PN}/error_log \
+ --pid-path=/var/run/${PN}.pid \
+ --http-client-body-temp-path=/var/tmp/${PN}/client \
+ --http-proxy-temp-path=/var/tmp/${PN}/proxy \
+ --http-fastcgi-temp-path=/var/tmp/${PN}/fastcgi \
+ --with-md5-asm --with-md5=/usr/include \
+ --with-sha1-asm --with-sha1=/usr/include \
+ ${myconf} || die "configure failed"
+
+ emake || die "failed to compile"
+}
+
+src_install() {
+ keepdir /var/log/${PN} /var/tmp/${PN}/{client,proxy,fastcgi}
+
+ dosbin objs/nginx
+ cp "${FILESDIR}"/nginx-r1 "${T}"/nginx
+ doinitd "${T}"/nginx
+
+ cp "${FILESDIR}"/nginx.conf-r4 conf/nginx.conf
+
+ dodir "${ROOT}"/etc/${PN}
+ insinto "${ROOT}"/etc/${PN}
+ doins conf/*
+
+ dodoc CHANGES{,.ru} LICENSE README
+
+ use perl && {
+ cd "${S}"/objs/src/http/modules/perl/
+ einstall DESTDIR="${D}"|| die "failed to install perl stuff"
+ }
+}
+
+pkg_postinst() {
+ use ssl && {
+ if [ ! -f "${ROOT}"/etc/ssl/${PN}/${PN}.key ]; then
+ dodir "${ROOT}"/etc/ssl/${PN}
+ insinto "${ROOT}"etc/ssl/${PN}/
+ insopts -m0644 -o nginx -g nginx
+ install_cert /etc/ssl/nginx/nginx
+ fi
+ }
+}