summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBenedikt Boehm <hollow@gentoo.org>2010-03-07 10:43:38 +0000
committerBenedikt Boehm <hollow@gentoo.org>2010-03-07 10:43:38 +0000
commit11afad54888f76b1b12f4ecaaa5bd76f05f1fd55 (patch)
treee8b194373a7c9f31ca7b7172661d3e89b32b2db9 /www-servers/nginx
parentNew ebuild to handle pdb files (diff)
downloadgentoo-2-11afad54888f76b1b12f4ecaaa5bd76f05f1fd55.tar.gz
gentoo-2-11afad54888f76b1b12f4ecaaa5bd76f05f1fd55.tar.bz2
gentoo-2-11afad54888f76b1b12f4ecaaa5bd76f05f1fd55.zip
rewrite ebuild for USE_EXPAND goodies. fixes #286772, #301513, #303205 and #305691
(Portage version: 2.2_rc63/cvs/Linux i686)
Diffstat (limited to 'www-servers/nginx')
-rw-r--r--www-servers/nginx/ChangeLog9
-rw-r--r--www-servers/nginx/files/nginx.conf-r478
-rw-r--r--www-servers/nginx/files/passenger-CFLAGS.patch15
-rw-r--r--www-servers/nginx/metadata.xml9
-rw-r--r--www-servers/nginx/nginx-0.8.34-r1.ebuild260
5 files changed, 328 insertions, 43 deletions
diff --git a/www-servers/nginx/ChangeLog b/www-servers/nginx/ChangeLog
index 3a41b231aaa8..1e11ceeaf9e1 100644
--- a/www-servers/nginx/ChangeLog
+++ b/www-servers/nginx/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for www-servers/nginx
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/www-servers/nginx/ChangeLog,v 1.247 2010/03/04 16:56:07 hollow Exp $
+# $Header: /var/cvsroot/gentoo-x86/www-servers/nginx/ChangeLog,v 1.248 2010/03/07 10:43:37 hollow Exp $
+
+*nginx-0.8.34-r1 (07 Mar 2010)
+
+ 07 Mar 2010; Benedikt Böhm <hollow@gentoo.org> +nginx-0.8.34-r1.ebuild,
+ files/nginx.conf-r4, +files/passenger-CFLAGS.patch, metadata.xml:
+ rewrite ebuild for USE_EXPAND goodies. fixes #286772, #301513, #303205 and
+ #305691
04 Mar 2010; Benedikt Böhm <hollow@gentoo.org> metadata.xml:
take over maintainance wrt #303205
diff --git a/www-servers/nginx/files/nginx.conf-r4 b/www-servers/nginx/files/nginx.conf-r4
index 117c2e55345f..f8c10f27b50a 100644
--- a/www-servers/nginx/files/nginx.conf-r4
+++ b/www-servers/nginx/files/nginx.conf-r4
@@ -9,64 +9,64 @@ events {
}
http {
- include /etc/nginx/mime.types;
- default_type application/octet-stream;
+ include /etc/nginx/mime.types;
+ default_type application/octet-stream;
log_format main
'$remote_addr - $remote_user [$time_local] '
- '"$request" $status $bytes_sent '
+ '"$request" $status $bytes_sent '
'"$http_referer" "$http_user_agent" '
'"$gzip_ratio"';
-
- client_header_timeout 10m;
- client_body_timeout 10m;
- send_timeout 10m;
- connection_pool_size 256;
- client_header_buffer_size 1k;
- large_client_header_buffers 4 2k;
- request_pool_size 4k;
+ client_header_timeout 10m;
+ client_body_timeout 10m;
+ send_timeout 10m;
+
+ connection_pool_size 256;
+ client_header_buffer_size 1k;
+ large_client_header_buffers 4 2k;
+ request_pool_size 4k;
gzip on;
- gzip_min_length 1100;
- gzip_buffers 4 8k;
- gzip_types text/plain;
+ gzip_min_length 1100;
+ gzip_buffers 4 8k;
+ gzip_types text/plain;
- output_buffers 1 32k;
- postpone_output 1460;
+ output_buffers 1 32k;
+ postpone_output 1460;
- sendfile on;
- tcp_nopush on;
- tcp_nodelay on;
+ sendfile on;
+ tcp_nopush on;
+ tcp_nodelay on;
- keepalive_timeout 75 20;
+ keepalive_timeout 75 20;
- ignore_invalid_headers on;
+ ignore_invalid_headers on;
index index.html;
server {
- listen 127.0.0.1;
- server_name localhost;
+ listen 127.0.0.1;
+ server_name localhost;
- access_log /var/log/nginx/localhost.access_log main;
- error_log /var/log/nginx/localhost.error_log info;
+ access_log /var/log/nginx/localhost.access_log main;
+ error_log /var/log/nginx/localhost.error_log info;
root /var/www/localhost/htdocs;
}
- ##ssl portion
- # server {
- # listen 127.0.0.1:443;
- # server_name localhost;
- #
- # ssl on;
- # ssl_certificate /etc/ssl/nginx/nginx.pem;
- # ssl_certificate_key /etc/ssl/nginx/nginx.key;
- #
- # access_log /var/log/nginx/localhost.ssl_access_log main;
- # error_log /var/log/nginx/localhost.ssl_error_log info;
- #
- # root /var/www/localhost/htdocs;
- # }
+ # SSL example
+ #server {
+ # listen 127.0.0.1:443;
+ # server_name localhost;
+
+ # ssl on;
+ # ssl_certificate /etc/ssl/nginx/nginx.pem;
+ # ssl_certificate_key /etc/ssl/nginx/nginx.key;
+
+ # access_log /var/log/nginx/localhost.ssl_access_log main;
+ # error_log /var/log/nginx/localhost.ssl_error_log info;
+
+ # root /var/www/localhost/htdocs;
+ #}
}
diff --git a/www-servers/nginx/files/passenger-CFLAGS.patch b/www-servers/nginx/files/passenger-CFLAGS.patch
new file mode 100644
index 000000000000..bdc848a3cd72
--- /dev/null
+++ b/www-servers/nginx/files/passenger-CFLAGS.patch
@@ -0,0 +1,15 @@
+--- Rakefile.org 2009-10-15 18:45:30.000000000 +0100
++++ Rakefile 2009-10-16 12:17:25.000000000 +0100
+@@ -39,11 +39,7 @@
+ CC = "gcc"
+ CXX = "g++"
+ LIBEXT = PlatformInfo.library_extension
+-if OPTIMIZE
+- OPTIMIZATION_FLAGS = "#{PlatformInfo.debugging_cflags} -O2 -DBOOST_DISABLE_ASSERTS"
+-else
+- OPTIMIZATION_FLAGS = "#{PlatformInfo.debugging_cflags} -DPASSENGER_DEBUG -DBOOST_DISABLE_ASSERTS"
+-end
++OPTIMIZATION_FLAGS = "#{ENV['CXXFLAGS']} -DNDEBUG -DBOOST_DISABLE_ASSERTS"
+
+ # Extra compiler flags that should always be passed to the C/C++ compiler.
+ # Should be included last in the command string, even after PlatformInfo.portability_cflags.
diff --git a/www-servers/nginx/metadata.xml b/www-servers/nginx/metadata.xml
index 099201435771..6acb50871999 100644
--- a/www-servers/nginx/metadata.xml
+++ b/www-servers/nginx/metadata.xml
@@ -13,14 +13,17 @@
<flag name='addition'>Enables HTTP addition filter module</flag>
<flag name='aio'>Enables file AIO support</flag>
<flag name='flv'>Enables special processing module for flv files</flag>
- <flag name='static-gzip'>Enables support for gzipping static content</flag>
+ <flag name='http'>Enable HTTP core support</flag>
+ <flag name='http-cache'>Enable HTTP cache support</flag>
+ <flag name='libatomic'>Use libatomic instead of builtin atomic operations</flag>
<flag name='pop'>Enables POP3 proxy support</flag>
<flag name='random-index'>Enables HTTP random index module</flag>
- <flag name='smtp'>Enables SMTP proxy support</flag>
+ <flag name='realip'>Enables realip module</flag>
<flag name='securelink'>Enable HTTP secure link module</flag>
+ <flag name='smtp'>Enables SMTP proxy support</flag>
+ <flag name='static-gzip'>Enables support for gzipping static content</flag>
<flag name='status'>Enables stub_status module</flag>
<flag name='sub'>Enables sub_filter module</flag>
- <flag name='realip'>Enables realip module</flag>
<flag name='webdav'>Enable webdav support</flag>
</use>
</pkgmetadata>
diff --git a/www-servers/nginx/nginx-0.8.34-r1.ebuild b/www-servers/nginx/nginx-0.8.34-r1.ebuild
new file mode 100644
index 000000000000..be31c0397061
--- /dev/null
+++ b/www-servers/nginx/nginx-0.8.34-r1.ebuild
@@ -0,0 +1,260 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/www-servers/nginx/nginx-0.8.34-r1.ebuild,v 1.1 2010/03/07 10:43:37 hollow Exp $
+
+EAPI="2"
+
+USE_RUBY="ruby18"
+RUBY_OPTIONAL="yes"
+PASSENGER_PV="2.2.11"
+
+inherit eutils ssl-cert toolchain-funcs perl-module ruby-ng flag-o-matic
+
+DESCRIPTION="Robust, small and high performance http and reverse proxy server"
+HOMEPAGE="http://nginx.net/"
+SRC_URI="http://sysoev.ru/nginx/${P}.tar.gz
+ nginx_modules_passenger? ( mirror://rubyforge/passenger/passenger-${PASSENGER_PV}.tar.gz )"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86 ~x86-fbsd"
+
+NGINX_MODULES_STD="access auth_basic autoindex browser charset empty_gif fastcgi
+geo gzip limit_req limit_zone map memcached proxy referer rewrite ssi
+upstream_ip_hash userid"
+NGINX_MODULES_OPT="addition dav degradation flv geoip gzip_static image_filter
+perl random_index realip secure_link stub_status sub xslt"
+NGINX_MODULES_MAIL="imap pop3 smtp"
+NGINX_MODULES_3RD="http_passenger"
+
+IUSE="aio debug +http +http-cache ipv6 libatomic ssl"
+
+for mod in $NGINX_MODULES_STD; do
+ IUSE="${IUSE} +nginx_modules_http_${mod}"
+done
+
+for mod in $NGINX_MODULES_OPT; do
+ IUSE="${IUSE} nginx_modules_http_${mod}"
+done
+
+for mod in $NGINX_MODULES_MAIL; do
+ IUSE="${IUSE} nginx_modules_mail_${mod}"
+done
+
+for mod in $NGINX_MODULES_3RD; do
+ IUSE="${IUSE} nginx_modules_${mod}"
+done
+
+CDEPEND=">=dev-libs/libpcre-4.2
+ arm? ( dev-libs/libatomic_ops )
+ ssl? ( dev-libs/openssl )
+ http-cache? ( userland_GNU? ( dev-libs/openssl ) )
+ nginx_modules_http_geo? ( dev-libs/geoip )
+ nginx_modules_http_gzip? ( sys-libs/zlib )
+ nginx_modules_http_gzip_static? ( sys-libs/zlib )
+ nginx_modules_http_perl? ( >=dev-lang/perl-5.8 )
+ nginx_modules_http_secure_link? ( userland_GNU? ( dev-libs/openssl ) )
+ nginx_modules_http_xslt? ( dev-libs/libxml2 dev-libs/libxslt )
+ nginx_modules_http_passenger? (
+ $(ruby_implementation_depend ruby18)
+ >=dev-ruby/rubygems-0.9.0
+ >=dev-ruby/rake-0.8.1
+ >=dev-ruby/fastthread-1.0.1
+ >=dev-ruby/rack-1.0.0
+ )
+"
+RDEPEND="${RDEPEND} ${CDEPEND}"
+DEPEND="${DEPEND} ${CDEPEND}
+ libatomic? ( dev-libs/libatomic_ops )"
+
+pkg_setup() {
+ ebegin "Creating nginx user and group"
+ enewgroup ${PN}
+ enewuser ${PN} -1 -1 -1 ${PN}
+ eend ${?}
+
+ if use ipv6; then
+ ewarn "Note that ipv6 support in nginx is still experimental."
+ ewarn "Be sure to read comments on gentoo bug #274614"
+ ewarn "http://bugs.gentoo.org/show_bug.cgi?id=274614"
+ fi
+
+ if use libatomic; then
+ ewarn "GCC 4.1+ features built-in atomic operations."
+ ewarn "Using libatomic_ops is only needed if using"
+ ewarn "a different compiler or a GCC prior to 4.1"
+ fi
+
+ if [[ -n $NGINX_ADD_MODULES ]]; then
+ ewarn "You are building custom modules via \$NGINX_ADD_MODULES!"
+ ewarn "This nginx installation is not supported!"
+ ewarn "Please do not file bug reports!"
+ fi
+
+ if use nginx_modules_passenger; then
+ ruby-ng_pkg_setup
+ use debug && append-flags -DPASSENGER_DEBUG
+ fi
+}
+
+src_unpack() {
+ # prevent ruby-ng.eclass from messing with src_unpack
+ default
+}
+
+src_prepare() {
+ sed -i 's/ make/ \\$(MAKE)/' "${S}"/auto/lib/perl/make
+
+ if use nginx_modules_passenger; then
+ cd "${WORKDIR}"/passenger-${PASSENGER_PV}
+ epatch "${FILESDIR}"/passenger-CFLAGS.patch
+ fi
+}
+
+src_configure() {
+ local myconf= http_enabled= mail_enabled=
+
+ use aio && myconf="${myconf} --with-file-aio --with-aio_module"
+ use debug && myconf="${myconf} --with-debug"
+ use ipv6 && myconf="${myconf} --with-ipv6"
+ use libatomic && myconf="${myconf} --with-libatomic"
+
+ # HTTP modules
+ for mod in $NGINX_MODULES_STD; do
+ if use nginx_modules_http_${mod}; then
+ http_enabled=1
+ else
+ myconf="${myconf} --without-http_${mod}_module"
+ fi
+ done
+
+ for mod in $NGINX_MODULES_OPT; do
+ if use nginx_modules_http_${mod}; then
+ http_enabled=1
+ myconf="${myconf} --with-http_${mod}_module"
+ fi
+ done
+
+ if use nginx_modules_http_fastcgi; then
+ myconf="${myconf} --with-http_realip_module"
+ fi
+
+ if use nginx_modules_http_passenger; then
+ http_enabled=1
+ myconf="${myconf} --add-module=${WORKDIR}/passenger-${PASSENGER_PV}/ext/nginx"
+ fi
+
+ if use http || use http-cache; then
+ http_enabled=1
+ fi
+
+ if [ $http_enabled ]; then
+ use http-cache || myconf="${myconf} --without-http-cache"
+ use ssl && myconf="${myconf} --with-http_ssl_module"
+ else
+ myconf="${myconf} --without-http --without-http-cache"
+ fi
+
+ # MAIL modules
+ for mod in $NGINX_MODULES_MAIL; do
+ if use nginx_modules_mail_${mod}; then
+ mail_enabled=1
+ else
+ myconf="${myconf} --without-mail_${mod}_module"
+ fi
+ done
+
+ if [ $mail_enabled ]; then
+ myconf="${myconf} --with-mail"
+ use ssl && myconf="${myconf} --with-mail_ssl_module"
+ fi
+
+ # custom modules
+ for mod in $NGINX_ADD_MODULES; do
+ myconf="${myconf} --add-module=${mod}"
+ done
+
+ # http://bugs.gentoo.org/show_bug.cgi?id=286772
+ export LANG=C LC_ALL=C
+ tc-export CC
+
+ ./configure \
+ --prefix=/usr \
+ --sbin-path=/usr/sbin/nginx \
+ --conf-path=/etc/${PN}/${PN}.conf \
+ --error-log-path=/var/log/${PN}/error_log \
+ --pid-path=/var/run/${PN}.pid \
+ --lock-path=/var/lock/nginx.lock \
+ --user=${PN} --group=${PN} \
+ --with-cc-opt="-I${ROOT}usr/include" \
+ --with-ld-opt="-L${ROOT}usr/lib" \
+ --http-log-path=/var/log/${PN}/access_log \
+ --http-client-body-temp-path=/var/tmp/${PN}/client \
+ --http-proxy-temp-path=/var/tmp/${PN}/proxy \
+ --http-fastcgi-temp-path=/var/tmp/${PN}/fastcgi \
+ --with-pcre \
+ ${myconf} || die "configure failed"
+}
+
+src_compile() {
+ # http://bugs.gentoo.org/show_bug.cgi?id=286772
+ export LANG=C LC_ALL=C
+ emake LINK="${CC} ${LDFLAGS}" OTHERLDFLAGS="${LDFLAGS}" || die "emake failed"
+}
+
+src_install() {
+ keepdir /var/log/${PN} /var/tmp/${PN}/{client,proxy,fastcgi}
+
+ dosbin objs/nginx
+ newinitd "${FILESDIR}"/nginx.init-r2 nginx
+
+ cp "${FILESDIR}"/nginx.conf-r4 conf/nginx.conf
+ rm conf/win-utf conf/koi-win conf/koi-utf
+
+ dodir /etc/${PN}
+ insinto /etc/${PN}
+ doins conf/*
+
+ dodoc CHANGES{,.ru} README
+
+ # logrotate
+ insinto /etc/logrotate.d
+ newins "${FILESDIR}"/nginx.logrotate nginx
+
+ if use nginx_modules_perl; then
+ cd "${S}"/objs/src/http/modules/perl/
+ einstall DESTDIR="${D}" INSTALLDIRS=vendor || die "failed to install perl stuff"
+ fixlocalpod
+ fi
+
+ if use nginx_modules_passenger; then
+ # passengers Rakefile is so horribly broken that we have to do it
+ # manually
+ cd "${WORKDIR}"/passenger-${PASSENGER_PV}
+
+ export RUBY="ruby18"
+
+ insinto $(${RUBY} -rrbconfig -e 'print Config::CONFIG["archdir"]')/phusion_passenger
+ insopts -m 0755
+ doins ext/phusion_passenger/*.so
+ doruby -r lib/phusion_passenger
+
+ exeinto /usr/bin
+ doexe bin/passenger-memory-stats bin/passenger-status
+
+ exeinto /usr/libexec/passenger/bin
+ doexe bin/passenger-spawn-server
+
+ exeinto /usr/libexec/passenger/ext/nginx
+ doexe ext/nginx/HelperServer
+ fi
+}
+
+pkg_postinst() {
+ if use ssl; then
+ if [ ! -f "${ROOT}"/etc/ssl/${PN}/${PN}.key ]; then
+ install_cert /etc/ssl/${PN}/${PN}
+ chown ${PN}:${PN} "${ROOT}"/etc/ssl/${PN}/${PN}.{crt,csr,key,pem}
+ fi
+ fi
+}