summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHans de Graaff <graaff@gentoo.org>2008-12-30 12:43:24 +0000
committerHans de Graaff <graaff@gentoo.org>2008-12-30 12:43:24 +0000
commit712654b3176bcdeabf34f28e551c52576b47f18f (patch)
tree67118d10aabfb04bacbfa9229ed3c5a856f17f02 /www-servers/gorg
parentVersion bump (diff)
downloadgentoo-2-712654b3176bcdeabf34f28e551c52576b47f18f.tar.gz
gentoo-2-712654b3176bcdeabf34f28e551c52576b47f18f.tar.bz2
gentoo-2-712654b3176bcdeabf34f28e551c52576b47f18f.zip
Add apache2 and fastcgi USE flags and clean up the ebuild.
(Portage version: 2.1.6.4/cvs/Linux 2.6.27-gentoo-r7 x86_64)
Diffstat (limited to 'www-servers/gorg')
-rw-r--r--www-servers/gorg/ChangeLog12
-rw-r--r--www-servers/gorg/gorg-0.6.3-r2.ebuild51
2 files changed, 61 insertions, 2 deletions
diff --git a/www-servers/gorg/ChangeLog b/www-servers/gorg/ChangeLog
index 57786722a244..3db0998a6513 100644
--- a/www-servers/gorg/ChangeLog
+++ b/www-servers/gorg/ChangeLog
@@ -1,6 +1,14 @@
# ChangeLog for www-servers/gorg
-# Copyright 1999-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/www-servers/gorg/ChangeLog,v 1.16 2007/09/05 01:29:25 nichoj Exp $
+# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/www-servers/gorg/ChangeLog,v 1.17 2008/12/30 12:43:24 graaff Exp $
+
+*gorg-0.6.3-r2 (30 Dec 2008)
+
+ 30 Dec 2008; Hans de Graaff <graaff@gentoo.org> +gorg-0.6.3-r2.ebuild:
+ Add apache2 and fastcgi USE flags as requested in #251177 and how we handle
+ this for other similar packages. Move to EAPI=2 so that we can handle the
+ mysql USE flag dependency on ruby-dbi better. Don't depend directly on
+ underlying dependencies of ruby-dbi and ruby-fcgi. Fix variable quoting.
05 Sep 2007; Joshua Nichols <nichoj@gentoo.org> gorg-0.5.ebuild,
gorg-0.6.3.ebuild, gorg-0.6.3-r1.ebuild:
diff --git a/www-servers/gorg/gorg-0.6.3-r2.ebuild b/www-servers/gorg/gorg-0.6.3-r2.ebuild
new file mode 100644
index 000000000000..10a78a5711af
--- /dev/null
+++ b/www-servers/gorg/gorg-0.6.3-r2.ebuild
@@ -0,0 +1,51 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/www-servers/gorg/gorg-0.6.3-r2.ebuild,v 1.1 2008/12/30 12:43:24 graaff Exp $
+
+EAPI=2
+
+inherit ruby eutils
+
+DESCRIPTION="Back-end XSLT processor for an XML-based web site"
+HOMEPAGE="http://gentoo.neysx.org/mystuff/gorg/gorg.xml"
+SRC_URI="http://gentoo.neysx.org/mystuff/gorg/${P}.tgz"
+IUSE="apache2 fastcgi mysql"
+
+SLOT="0"
+USE_RUBY="ruby18"
+LICENSE="GPL-2"
+KEYWORDS="~amd64 ~ppc ~x86"
+
+DEPEND="virtual/ruby
+ >=dev-libs/libxml2-2.6.16
+ >=dev-libs/libxslt-1.1.12"
+RDEPEND="${DEPEND}
+ mysql? ( >=dev-ruby/ruby-dbi-0.0.21[mysql] )
+ apache2? ( www-servers/apache )
+ fastcgi? ( >=dev-ruby/ruby-fcgi-0.8.5-r1 )"
+
+pkg_setup() {
+ enewgroup gorg
+ enewuser gorg -1 -1 -1 gorg
+}
+
+src_compile() {
+ # Fix listen issue w/ webrick
+ sed -i -e 's/WEBrick::HTTPServer.new(/WEBrick::HTTPServer.new( :BindAddress=>"127.0.0.1",/' lib/gorg/www.rb
+
+ ruby_src_compile
+}
+
+src_install() {
+ ruby_einstall
+
+ # install doesn't seem to chmod these correctly, forcing it here
+ SITE_LIB_DIR=`$RUBY -r rbconfig -e 'puts Config::CONFIG["sitelibdir"]'`
+ chmod +x "${D}"/${SITE_LIB_DIR}/gorg/cgi-bin/*.cgi
+ chmod +x "${D}"/${SITE_LIB_DIR}/gorg/fcgi-bin/*.fcgi
+
+ keepdir /etc/gorg; insinto /etc/gorg ; doins etc/gorg/*
+ diropts -m0770 -o gorg -g gorg; keepdir /var/cache/gorg
+
+ dodoc Changelog README
+}