summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPeter Alfredsen <loki_val@gentoo.org>2009-04-09 17:31:17 +0000
committerPeter Alfredsen <loki_val@gentoo.org>2009-04-09 17:31:17 +0000
commit7572b8d1b3596f021d7acce5795a382697e9bfe2 (patch)
tree08d158e217a323993a0fbc7c337a531f7e41feae /www-plugins
parentFix build issues. Per bug #265549. (diff)
downloadgentoo-2-7572b8d1b3596f021d7acce5795a382697e9bfe2.tar.gz
gentoo-2-7572b8d1b3596f021d7acce5795a382697e9bfe2.tar.bz2
gentoo-2-7572b8d1b3596f021d7acce5795a382697e9bfe2.zip
Moved to www-plugins per bug 265569.
(Portage version: 2.2_rc28/cvs/Linux x86_64)
Diffstat (limited to 'www-plugins')
-rw-r--r--www-plugins/moonlight/ChangeLog20
-rw-r--r--www-plugins/moonlight/metadata.xml5
-rw-r--r--www-plugins/moonlight/moonlight-1.0.1.ebuild70
-rw-r--r--www-plugins/moonlight/moonlight-1.0.ebuild70
4 files changed, 165 insertions, 0 deletions
diff --git a/www-plugins/moonlight/ChangeLog b/www-plugins/moonlight/ChangeLog
new file mode 100644
index 000000000000..700315d7e5a6
--- /dev/null
+++ b/www-plugins/moonlight/ChangeLog
@@ -0,0 +1,20 @@
+# ChangeLog for net-www/moonlight
+# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/www-plugins/moonlight/ChangeLog,v 1.1 2009/04/09 17:31:17 loki_val Exp $
+
+ 09 Apr 2009; Peter Alfredsen <loki_val@gentoo.org> +metadata.xml,
+ +moonlight-1.0.ebuild, +moonlight-1.0.1.ebuild:
+ Moved to www-plugins per bug 265569.
+
+*moonlight-1.0.1 (07 Mar 2009)
+
+ 07 Mar 2009; Peter Alfredsen <loki_val@gentoo.org>
+ +moonlight-1.0.1.ebuild:
+ Bump
+
+*moonlight-1.0 (25 Jan 2009)
+
+ 25 Jan 2009; Peter Alfredsen <loki_val@gentoo.org> +metadata.xml,
+ +moonlight-1.0.ebuild:
+ Initial commit, ebuild by me.
+
diff --git a/www-plugins/moonlight/metadata.xml b/www-plugins/moonlight/metadata.xml
new file mode 100644
index 000000000000..e01adbb307db
--- /dev/null
+++ b/www-plugins/moonlight/metadata.xml
@@ -0,0 +1,5 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>dotnet</herd>
+</pkgmetadata>
diff --git a/www-plugins/moonlight/moonlight-1.0.1.ebuild b/www-plugins/moonlight/moonlight-1.0.1.ebuild
new file mode 100644
index 000000000000..d7a03171136b
--- /dev/null
+++ b/www-plugins/moonlight/moonlight-1.0.1.ebuild
@@ -0,0 +1,70 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/www-plugins/moonlight/moonlight-1.0.1.ebuild,v 1.1 2009/04/09 17:31:17 loki_val Exp $
+
+EAPI=2
+
+inherit mono multilib nsplugins
+
+MY_P=moon-${PV}
+DESCRIPTION="Moonlight is an open source implementation of Silverlight"
+HOMEPAGE="http://www.mono-project.com/Moonlight"
+SRC_URI="ftp://ftp.novell.com/pub/mono/sources/moon/${MY_P}.tar.bz2"
+LICENSE="LGPL-2 MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="alsa pulseaudio debug test"
+RESTRICT="mirror"
+
+# Needed for Moonlight-2.0 profile:
+#LICENSE+="Ms-PL"
+# +more
+# >=dev-dotnet/rsvg-sharp-2.24.0
+# >=dev-dotnet/gtk-sharp-2.12.7
+# >=dev-lang/mono-2.2-r3[moonlight]
+# >=dev-dotnet/dbus-sharp-0.6.1a
+
+#Moonlight-1.0 is essentially a browser plugin written in pure C.
+RDEPEND="
+ >=x11-libs/gtk+-2.14
+ >=dev-libs/glib-2.18
+ >=dev-libs/dbus-glib-0.60
+ >=x11-libs/cairo-1.8.0
+ >=media-video/ffmpeg-0.4.9_p20090121
+ >=net-libs/xulrunner-1.9.0.5:1.9
+ x11-libs/libXrandr
+ alsa? ( >=media-libs/alsa-lib-1.0.18 )
+ pulseaudio? ( >=media-sound/pulseaudio-0.9.14 )
+ >=media-libs/freetype-2.3.7
+ >=media-gfx/imagemagick-6.2.8
+ >=media-libs/fontconfig-2.6.0
+ "
+DEPEND="${RDEPEND}
+ >=dev-util/pkgconfig-0.23"
+S="${WORKDIR}/${MY_P}"
+
+src_prepare() {
+ sed -i \
+ -e "s:TEST_SUBDIR = test::" \
+ -e "s:TOOLS_SUBDIR = tools::" \
+ Makefile.in
+}
+
+src_configure() {
+ econf --enable-shared \
+ --disable-static \
+ --with-cairo=system \
+ --with-ffmpeg=yes \
+ --with-ff3=yes \
+ --without-ff2 \
+ $(use_with alsa) \
+ $(use_with pulseaudio) \
+ $(use_with debug) \
+ || die "econf failed"
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die "emake install failed"
+ inst_plugin /usr/$(get_libdir)/moon/plugin/libmoonloader.so || die "installing libmoonloader failed"
+ find "${D}" -name '*.la' -exec rm -rf '{}' '+' || die "la removal failed"
+}
diff --git a/www-plugins/moonlight/moonlight-1.0.ebuild b/www-plugins/moonlight/moonlight-1.0.ebuild
new file mode 100644
index 000000000000..fdbfcab503c1
--- /dev/null
+++ b/www-plugins/moonlight/moonlight-1.0.ebuild
@@ -0,0 +1,70 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/www-plugins/moonlight/moonlight-1.0.ebuild,v 1.1 2009/04/09 17:31:17 loki_val Exp $
+
+EAPI=2
+
+inherit mono multilib nsplugins
+
+MY_P=moon-${PV}
+DESCRIPTION="Moonlight is an open source implementation of Silverlight"
+HOMEPAGE="http://www.mono-project.com/Moonlight"
+SRC_URI="ftp://ftp.novell.com/pub/mono/sources/moon/${MY_P}.tar.bz2"
+LICENSE="LGPL-2 MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="alsa pulseaudio debug test"
+RESTRICT="mirror"
+
+# Needed for Moonlight-2.0 profile:
+#LICENSE+="Ms-PL"
+# +more
+# >=dev-dotnet/rsvg-sharp-2.24.0
+# >=dev-dotnet/gtk-sharp-2.12.7
+# >=dev-lang/mono-2.2-r3[moonlight]
+# >=dev-dotnet/dbus-sharp-0.6.1a
+
+#Moonlight-1.0 is essentially a browser plugin written in pure C.
+RDEPEND="
+ >=x11-libs/gtk+-2.14
+ >=dev-libs/glib-2.18
+ >=dev-libs/dbus-glib-0.60
+ >=x11-libs/cairo-1.8.0
+ >=media-video/ffmpeg-0.4.9_p20090121
+ >=net-libs/xulrunner-1.9.0.5:1.9
+ x11-libs/libXrandr
+ alsa? ( >=media-libs/alsa-lib-1.0.18 )
+ pulseaudio? ( >=media-sound/pulseaudio-0.9.14 )
+ >=media-libs/freetype-2.3.7
+ >=media-gfx/imagemagick-6.2.8
+ >=media-libs/fontconfig-2.6.0
+ "
+DEPEND="${RDEPEND}
+ >=dev-util/pkgconfig-0.23"
+S="${WORKDIR}/${MY_P}"
+
+src_prepare() {
+ sed -i \
+ -e "s:TEST_SUBDIR = test::" \
+ -e "s:TOOLS_SUBDIR = tools::" \
+ Makefile.in
+}
+
+src_configure() {
+ econf --enable-shared \
+ --disable-static \
+ --with-cairo=system \
+ --with-ffmpeg=yes \
+ --with-ff3=yes \
+ --without-ff2 \
+ $(use_with alsa) \
+ $(use_with pulseaudio) \
+ $(use_with debug) \
+ || die "econf failed"
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die "emake install failed"
+ inst_plugin /usr/$(get_libdir)/moon/plugin/libmoonloader.so || die "installing libmoonloader failed"
+ find "${D}" -name '*.la' -exec rm -rf '{}' '+' || die "la removal failed"
+}