summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSeemant Kulleen <seemant@gentoo.org>2006-10-20 11:18:14 +0000
committerSeemant Kulleen <seemant@gentoo.org>2006-10-20 11:18:14 +0000
commit521f5a871b1c3dad5b991e20f2adece4cde0d0ad (patch)
tree49a991c40869e8a1fb218377794556b95e15e952 /www-client
parentRemoving xterm-220 and xterm-221 for segfault as shown in bug #152085 by Ciar... (diff)
downloadgentoo-2-521f5a871b1c3dad5b991e20f2adece4cde0d0ad.tar.gz
gentoo-2-521f5a871b1c3dad5b991e20f2adece4cde0d0ad.tar.bz2
gentoo-2-521f5a871b1c3dad5b991e20f2adece4cde0d0ad.zip
Version bump thanks to James Rowe in bug #150945
(Portage version: 2.1.2_pre3-r5)
Diffstat (limited to 'www-client')
-rw-r--r--www-client/surfraw/ChangeLog8
-rw-r--r--www-client/surfraw/files/digest-surfraw-2.1.53
-rw-r--r--www-client/surfraw/files/surfraw-2.1.5-gentoo_pkg_tools.patch37
-rw-r--r--www-client/surfraw/surfraw-2.1.5.ebuild64
4 files changed, 111 insertions, 1 deletions
diff --git a/www-client/surfraw/ChangeLog b/www-client/surfraw/ChangeLog
index 86744058e7bf..8b54ada2268f 100644
--- a/www-client/surfraw/ChangeLog
+++ b/www-client/surfraw/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for www-client/surfraw
# Copyright 2002-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/www-client/surfraw/ChangeLog,v 1.7 2006/06/06 21:02:16 seemant Exp $
+# $Header: /var/cvsroot/gentoo-x86/www-client/surfraw/ChangeLog,v 1.8 2006/10/20 11:18:14 seemant Exp $
+
+*surfraw-2.1.5 (20 Oct 2006)
+
+ 20 Oct 2006; Seemant Kulleen <seemant@gentoo.org>
+ +files/surfraw-2.1.5-gentoo_pkg_tools.patch, +surfraw-2.1.5.ebuild:
+ Version bump thanks to James Rowe in bug #150945
06 Jun 2006; Seemant Kulleen <seemant@gentoo.org> metadata.xml:
Added long description, thanks to James in bug #135489
diff --git a/www-client/surfraw/files/digest-surfraw-2.1.5 b/www-client/surfraw/files/digest-surfraw-2.1.5
new file mode 100644
index 000000000000..c83e10df13bd
--- /dev/null
+++ b/www-client/surfraw/files/digest-surfraw-2.1.5
@@ -0,0 +1,3 @@
+MD5 74d4b307745e3eeeeae1e26cb5762420 surfraw_2.1.5.tar.gz 119824
+RMD160 8821676df2e426375ae7117f4a550b9005f39152 surfraw_2.1.5.tar.gz 119824
+SHA256 39b330fcb8522d3f97ebb79e741508308d03afb8127de54e75514c8f2f8da722 surfraw_2.1.5.tar.gz 119824
diff --git a/www-client/surfraw/files/surfraw-2.1.5-gentoo_pkg_tools.patch b/www-client/surfraw/files/surfraw-2.1.5-gentoo_pkg_tools.patch
new file mode 100644
index 000000000000..4e17de986a73
--- /dev/null
+++ b/www-client/surfraw/files/surfraw-2.1.5-gentoo_pkg_tools.patch
@@ -0,0 +1,37 @@
+ Needs a little more thought, or some method which would allow for an upstream
+push without affecting the non-Gentoo users.
+
+Index: surfraw-2.1.5/surfraw-bash-completion.IN
+===================================================================
+--- surfraw-2.1.5/surfraw-bash-completion.IN {cset 8f95d483-869f-47ba-aba2-f0a12bb9dd07}
++++ surfraw-2.1.5/surfraw-bash-completion.IN {local clone}
+@@ -1,4 +1,20 @@
+ # -*- sh -*- bash programmable completion for Surfraw, v2.2
++_srpkgname()
++{
++ local pd
++ local dir=$(sed -n -e '/^PORTDIR=/ { s/^[^=]\+="\?\([^"]\+\|\S\+\).*/\1/p ; q }' \
++ /etc/make.{conf,globals})/*
++ local cur="$1"
++
++ COMPREPLY=($(compgen -W "$(
++ for pd in $dir
++ do
++ [ ! -d ${pd} ] && continue
++ builtin cd ${pd}
++ echo *
++ done)" -- ${cur})
++ )
++}
+ _surfraw()
+ { COMPREPLY=()
+ local cur=${COMP_WORDS[COMP_CWORD]}
+@@ -14,7 +30,7 @@ _surfraw()
+ then COMPREPLY=( $( compgen -W "$elvi" -- $cur ) )
+ # "sr go<tab>" for google
+ elif [[ $prev == @(alioth|deb@(bugs|contents|packages|pts|sec)|freshmeat|fsfdir|sourceforge) ]]
+- then COMPREPLY=( $(apt-cache --generate pkgnames $cur) )
++ then _srpkgname ${cur}
+ # "sr debbugs 4<tab>" to check 44bsd-rdist bugs...
+ elif [[ -x /usr/bin/look ]] # in bsdmainutils, "important"
+ then COMPREPLY=( $(/usr/bin/look ${cur:-''}) )
diff --git a/www-client/surfraw/surfraw-2.1.5.ebuild b/www-client/surfraw/surfraw-2.1.5.ebuild
new file mode 100644
index 000000000000..376d9b09344f
--- /dev/null
+++ b/www-client/surfraw/surfraw-2.1.5.ebuild
@@ -0,0 +1,64 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/www-client/surfraw/surfraw-2.1.5.ebuild,v 1.1 2006/10/20 11:18:14 seemant Exp $
+
+inherit bash-completion eutils
+
+DESCRIPTION="A fast unix command line interface to WWW"
+HOMEPAGE="http://alioth.debian.org/projects/surfraw/"
+SRC_URI="mirror://debian/pool/main/s/surfraw/${PN}_${PV}.tar.gz"
+
+SLOT="0"
+LICENSE="public-domain"
+KEYWORDS="~amd64 ~ppc ~sparc ~x86"
+IUSE=""
+
+src_unpack() {
+ unpack ${A}; cd ${S}
+
+ epatch ${FILESDIR}/${PN}-2.1.5-gentoo_pkg_tools.patch
+}
+
+src_compile() {
+ econf \
+ --with-elvidir='$(datadir)'/surfraw || die "./configure failed"
+ emake || die "make failed"
+}
+
+src_install() {
+ make DESTDIR=${D} install || die "make install failed"
+ dodoc debian/changelog AUTHORS HACKING NEWS README TODO
+
+ dobashcompletion surfraw-bash-completion
+}
+
+pkg_postinst() {
+ bash-completion_pkg_postinst
+ einfo
+ einfo "You can get a list of installed elvi by just typing 'surfraw' or"
+ einfo "the abbreviated 'sr'."
+ einfo
+ einfo "You can try some searches, for example:"
+ einfo "$ sr ask why is jeeves gay? "
+ einfo "$ sr google -results=100 RMS, GNU, which is sinner, which is sin?"
+ einfo "$ sr rhyme -method=perfect Julian"
+ einfo
+ einfo "The system configuration file is /etc/surfraw.conf"
+ einfo
+ einfo "Users can specify preferences in '~/.surfraw.conf' e.g."
+ einfo "SURFRAW_graphical_browser=mozilla"
+ einfo "SURFRAW_text_browser=w3m"
+ einfo "SURFRAW_graphical=no"
+ einfo
+ einfo "surfraw works with any graphical and/or text WWW browser"
+ einfo
+ if has_version '=www-client/surfraw-1.0.7'; then
+ ewarn "surfraw usage has changed slightly since version 1.0.7, elvi are now called"
+ ewarn "using the 'sr' wrapper script as described above. If you wish to return to"
+ ewarn "the old behaviour you can add /usr/share/surfraw to your \$PATH"
+ fi
+ # This file was always autogenerated, and is no longer needed.
+ if [ -f ${ROOT}/etc/surfraw_elvi.list ]; then
+ rm -f ${ROOT}/etc/surfraw_elvi.list
+ fi
+}