summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPaweł Hajdan <phajdan.jr@gentoo.org>2010-08-28 18:10:20 +0000
committerPaweł Hajdan <phajdan.jr@gentoo.org>2010-08-28 18:10:20 +0000
commit076fe0c80ea18226415dd90865df63a57a733ad4 (patch)
tree35e0065bee4d4bc57278d2cd3faddd9e81e1f2e0 /www-client
parentalpha/ia64/sparc stable wrt #329807 (diff)
downloadgentoo-2-076fe0c80ea18226415dd90865df63a57a733ad4.tar.gz
gentoo-2-076fe0c80ea18226415dd90865df63a57a733ad4.tar.bz2
gentoo-2-076fe0c80ea18226415dd90865df63a57a733ad4.zip
Version bump for beta channel release. Fix bug #334939 by Michal Gorny <gentoo@mgorny.alt.pl>. Remove old.
(Portage version: 2.1.8.3/cvs/Linux i686)
Diffstat (limited to 'www-client')
-rw-r--r--www-client/chromium/ChangeLog12
-rw-r--r--www-client/chromium/chromium-5.0.375.125.ebuild170
-rw-r--r--www-client/chromium/chromium-6.0.472.41.ebuild226
-rw-r--r--www-client/chromium/chromium-6.0.472.51.ebuild (renamed from www-client/chromium/chromium-6.0.472.36.ebuild)8
-rw-r--r--www-client/chromium/chromium-6.0.495.0.ebuild222
-rw-r--r--www-client/chromium/chromium-7.0.503.1.ebuild8
-rw-r--r--www-client/chromium/chromium-9999.ebuild8
7 files changed, 23 insertions, 631 deletions
diff --git a/www-client/chromium/ChangeLog b/www-client/chromium/ChangeLog
index 84f0de7bdfd0..9ff193507a53 100644
--- a/www-client/chromium/ChangeLog
+++ b/www-client/chromium/ChangeLog
@@ -1,6 +1,16 @@
# ChangeLog for www-client/chromium
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/www-client/chromium/ChangeLog,v 1.167 2010/08/26 03:54:09 phajdan.jr Exp $
+# $Header: /var/cvsroot/gentoo-x86/www-client/chromium/ChangeLog,v 1.168 2010/08/28 18:10:20 phajdan.jr Exp $
+
+*chromium-6.0.472.51 (28 Aug 2010)
+
+ 28 Aug 2010; Pawel Hajdan jr <phajdan.jr@gentoo.org>
+ -chromium-5.0.375.125.ebuild, -chromium-6.0.472.36.ebuild,
+ -chromium-6.0.472.41.ebuild, +chromium-6.0.472.51.ebuild,
+ -chromium-6.0.495.0.ebuild, chromium-7.0.503.1.ebuild,
+ chromium-9999.ebuild:
+ Version bump for beta channel release. Fix bug #334939 by Michal Gorny
+ <gentoo@mgorny.alt.pl>. Remove old.
*chromium-7.0.503.1 (26 Aug 2010)
diff --git a/www-client/chromium/chromium-5.0.375.125.ebuild b/www-client/chromium/chromium-5.0.375.125.ebuild
deleted file mode 100644
index 70d2c023ae91..000000000000
--- a/www-client/chromium/chromium-5.0.375.125.ebuild
+++ /dev/null
@@ -1,170 +0,0 @@
-# Copyright 1999-2010 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/www-client/chromium/chromium-5.0.375.125.ebuild,v 1.4 2010/07/31 15:59:41 truedfx Exp $
-
-EAPI="2"
-
-inherit eutils flag-o-matic multilib pax-utils toolchain-funcs
-
-DESCRIPTION="Open-source version of Google Chrome web browser"
-HOMEPAGE="http://chromium.org/"
-SRC_URI="http://build.chromium.org/buildbot/official/${P}.tar.bz2"
-
-LICENSE="BSD"
-SLOT="0"
-KEYWORDS="amd64 ~arm x86"
-IUSE="+plugins-symlink"
-
-RDEPEND="app-arch/bzip2
- >=dev-libs/libevent-1.4.13
- dev-libs/libxml2
- dev-libs/libxslt
- >=dev-libs/nss-3.12.3
- >=gnome-base/gconf-2.24.0
- >=media-libs/alsa-lib-1.0.19
- media-libs/jpeg:0
- media-libs/libpng
- media-video/ffmpeg[threads]
- sys-libs/zlib
- >=x11-libs/gtk+-2.14.7
- x11-libs/libXScrnSaver"
-# dev-db/sqlite:3
-DEPEND="${RDEPEND}
- dev-lang/perl
- >=dev-util/gperf-3.0.3
- >=dev-util/pkgconfig-0.23
- sys-devel/flex"
-RDEPEND+="
- || (
- x11-themes/gnome-icon-theme
- x11-themes/oxygen-molecule
- x11-themes/tango-icon-theme
- x11-themes/xfce4-icon-theme
- )
- x11-apps/xmessage
- x11-misc/xdg-utils
- virtual/ttf-fonts"
-
-src_prepare() {
- # Prevent automatic -march=pentium4 -msse2 enabling on x86, http://crbug.com/9007
- epatch "${FILESDIR}"/${PN}-drop_sse2-r0.patch
-
- # Allow supporting more media types.
- epatch "${FILESDIR}"/${PN}-20100122-ubuntu-html5-video-mimetypes.patch
-
- # Fix build failure with libpng-1.4, bug 310959.
- epatch "${FILESDIR}"/${PN}-libpng-1.4.patch
-}
-
-src_configure() {
- export CHROMIUM_HOME=/usr/$(get_libdir)/chromium-browser
-
- # Workaround for bug #318969.
- # TODO: remove when http://crbug.com/43778 is fixed.
- append-flags -D__STDC_CONSTANT_MACROS
-
- # Fails to build on arm if we don't do this
- use arm && append-flags -fno-tree-sink
-
- # Configuration options (system libraries)
- local myconf="-Duse_system_zlib=1 -Duse_system_bzip2=1 -Duse_system_ffmpeg=1 -Duse_system_libevent=1 -Duse_system_libjpeg=1 -Duse_system_libpng=1 -Duse_system_libxml=1 -Duse_system_libxslt=1"
- # -Duse_system_sqlite=1 : http://crbug.com/22208
- # Others still bundled: icu (not possible?), hunspell (changes required for sandbox support)
-
- # Sandbox paths
- myconf="${myconf} -Dlinux_sandbox_path=${CHROMIUM_HOME}/chrome_sandbox -Dlinux_sandbox_chrome_path=${CHROMIUM_HOME}/chrome"
-
- # Disable the V8 snapshot. It breaks the build on hardened (bug #301880),
- # and the performance gain isn't worth it.
- myconf="${myconf} -Dv8_use_snapshot=0"
-
- # Disable tcmalloc memory allocator. It causes problems,
- # for example bug #320419.
- myconf="${myconf} -Dlinux_use_tcmalloc=0"
-
- # Disable gpu rendering, it is incompatible with nvidia-drivers,
- # bug #319331.
- myconf="${myconf} -Denable_gpu=0"
-
- # Use target arch detection logic from bug #296917.
- local myarch="$ABI"
- [[ $myarch = "" ]] && myarch="$ARCH"
-
- if [[ $myarch = amd64 ]] ; then
- myconf="${myconf} -Dtarget_arch=x64"
- elif [[ $myarch = x86 ]] ; then
- myconf="${myconf} -Dtarget_arch=ia32"
- elif [[ $myarch = arm ]] ; then
- myconf="${myconf} -Dtarget_arch=arm -Ddisable_nacl=1 -Dlinux_use_tcmalloc=0"
- else
- die "Failed to determine target arch, got '$myarch'."
- fi
-
- if [[ "$(gcc-major-version)$(gcc-minor-version)" == "44" ]]; then
- myconf="${myconf} -Dno_strict_aliasing=1 -Dgcc_version=44"
- fi
-
- # Make sure that -Werror doesn't get added to CFLAGS by the build system.
- # Depending on GCC version the warnings are different and we don't want
- # the build to fail because of that.
- myconf="${myconf} -Dwerror="
-
- build/gyp_chromium -f make build/all.gyp ${myconf} --depth=. || die "gyp failed"
-}
-
-src_compile() {
- emake -r V=1 chrome chrome_sandbox BUILDTYPE=Release \
- rootdir="${S}" \
- CC="$(tc-getCC)" \
- CXX="$(tc-getCXX)" \
- AR="$(tc-getAR)" \
- RANLIB="$(tc-getRANLIB)" \
- || die "compilation failed"
-}
-
-src_install() {
- # Chromium does not have "install" target in the build system.
- export CHROMIUM_HOME=/usr/$(get_libdir)/chromium-browser
-
- dodir ${CHROMIUM_HOME}
-
- exeinto ${CHROMIUM_HOME}
- pax-mark m out/Release/chrome
- doexe out/Release/chrome
- doexe out/Release/chrome_sandbox
- fperms 4755 ${CHROMIUM_HOME}/chrome_sandbox
- doexe out/Release/xdg-settings
- doexe "${FILESDIR}"/chromium-launcher.sh
-
- insinto ${CHROMIUM_HOME}
- doins out/Release/chrome.pak
-
- doins -r out/Release/locales
- doins -r out/Release/resources
-
- # chrome.1 is for chromium --help
- newman out/Release/chrome.1 chrome.1
- newman out/Release/chrome.1 chromium.1
-
- # Chromium looks for these in its folder
- # See media_posix.cc and base_paths_linux.cc
- dosym /usr/$(get_libdir)/libavcodec.so.52 ${CHROMIUM_HOME}
- dosym /usr/$(get_libdir)/libavformat.so.52 ${CHROMIUM_HOME}
- dosym /usr/$(get_libdir)/libavutil.so.50 ${CHROMIUM_HOME}
-
- # Plugins symlink, optional wrt bug #301911
- if use plugins-symlink; then
- dosym /usr/$(get_libdir)/nsbrowser/plugins ${CHROMIUM_HOME}/plugins
- fi
-
- # Icon and desktop entry
- newicon out/Release/product_logo_48.png ${PN}-browser.png
- dosym ${CHROMIUM_HOME}/chromium-launcher.sh /usr/bin/chromium
- make_desktop_entry chromium "Chromium" ${PN}-browser "Network;WebBrowser"
- sed -e "/^Exec/s/$/ %U/" -i "${D}"/usr/share/applications/*.desktop \
- || die "desktop file sed failed"
- # Gnome default application entry
- dodir /usr/share/gnome-control-center/default-apps
- insinto /usr/share/gnome-control-center/default-apps
- doins "${FILESDIR}"/chromium.xml
-}
diff --git a/www-client/chromium/chromium-6.0.472.41.ebuild b/www-client/chromium/chromium-6.0.472.41.ebuild
deleted file mode 100644
index be75e9b1ec42..000000000000
--- a/www-client/chromium/chromium-6.0.472.41.ebuild
+++ /dev/null
@@ -1,226 +0,0 @@
-# Copyright 1999-2010 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/www-client/chromium/chromium-6.0.472.41.ebuild,v 1.1 2010/08/21 05:23:12 phajdan.jr Exp $
-
-EAPI="2"
-
-inherit eutils flag-o-matic multilib pax-utils toolchain-funcs
-
-DESCRIPTION="Open-source version of Google Chrome web browser"
-HOMEPAGE="http://chromium.org/"
-SRC_URI="http://build.chromium.org/buildbot/official/${P}.tar.bz2"
-
-LICENSE="BSD"
-SLOT="0"
-KEYWORDS="~amd64 ~arm ~x86"
-IUSE="cups gnome sse2"
-
-RDEPEND="app-arch/bzip2
- >=dev-libs/libevent-1.4.13
- >=dev-libs/nss-3.12.3
- >=gnome-base/gconf-2.24.0
- gnome? ( >=gnome-base/gnome-keyring-2.28.2 )
- >=media-libs/alsa-lib-1.0.19
- media-libs/jpeg:0
- media-libs/libpng
- cups? ( >=net-print/cups-1.4.4 )
- sys-libs/zlib
- >=x11-libs/gtk+-2.14.7
- x11-libs/libXScrnSaver"
-DEPEND="${RDEPEND}
- dev-lang/perl
- >=dev-util/gperf-3.0.3
- >=dev-util/pkgconfig-0.23
- >=gnome-base/gnome-keyring-2.28.2
- sys-devel/flex"
-RDEPEND+="
- || (
- x11-themes/gnome-icon-theme
- x11-themes/oxygen-molecule
- x11-themes/tango-icon-theme
- x11-themes/xfce4-icon-theme
- )
- x11-apps/xmessage
- x11-misc/xdg-utils
- virtual/ttf-fonts"
-
-get_chromium_home() {
- echo "/usr/$(get_libdir)/chromium-browser"
-}
-
-remove_bundled_lib() {
- einfo "Removing bundled library $1 ..."
- local out
- out="$(find $1 -mindepth 1 \! -iname '*.gyp' -print -delete)" \
- || die "failed to remove bundled library $1"
- if [[ -z $out ]]; then
- die "no files matched when removing bundled library $1"
- fi
-}
-
-src_prepare() {
- # Fix compilation, bug #332131.
- epatch "${FILESDIR}"/${PN}-make-3.82-compatibility-r0.patch
-
- # Add Gentoo plugin paths.
- epatch "${FILESDIR}"/${PN}-plugins-path-r0.patch
-
- remove_bundled_lib "third_party/bzip2"
- remove_bundled_lib "third_party/codesighs"
- remove_bundled_lib "third_party/cros"
- remove_bundled_lib "third_party/jemalloc"
- remove_bundled_lib "third_party/lcov"
- remove_bundled_lib "third_party/libevent"
- remove_bundled_lib "third_party/libjpeg"
- remove_bundled_lib "third_party/libpng"
- remove_bundled_lib "third_party/lzma_sdk"
- remove_bundled_lib "third_party/molokocacao"
- remove_bundled_lib "third_party/ocmock"
- remove_bundled_lib "third_party/py"
- remove_bundled_lib "third_party/pyftpdlib"
- remove_bundled_lib "third_party/simplejson"
- remove_bundled_lib "third_party/tlslite"
- # TODO: also remove third_party/libxml and third_party/libxslt when
- # http://crbug.com/29333 is fixed.
- # TODO: also remove third_party/zlib. For now the compilation fails if we
- # remove it (minizip-related).
-}
-
-src_configure() {
- local myconf=""
-
- # Make it possible to build chromium on non-sse2 systems.
- if use sse2; then
- myconf="${myconf} -Ddisable_sse2=0"
- else
- myconf="${myconf} -Ddisable_sse2=1"
- fi
-
- # Use system-provided libraries.
- # TODO: use_system_ffmpeg (http://crbug.com/50678).
- # TODO: use_system_libxml (http://crbug.com/29333).
- # TODO: use_system_sqlite (http://crbug.com/22208).
- # TODO: use_system_icu, use_system_hunspell (upstream changes needed).
- # TODO: use_system_ssl when we have a recent enough system NSS.
- myconf="${myconf}
- -Duse_system_bzip2=1
- -Duse_system_libevent=1
- -Duse_system_libjpeg=1
- -Duse_system_libpng=1
- -Duse_system_zlib=1"
-
- # The dependency on cups is optional, see bug #324105.
- if use cups; then
- myconf="${myconf} -Duse_cups=1"
- else
- myconf="${myconf} -Duse_cups=0"
- fi
-
- if use gnome; then
- myconf="${myconf} -Dlinux_link_gnome_keyring=1"
- else
- # TODO: we should also disable code trying to dlopen
- # gnome-keyring in that case.
- myconf="${myconf} -Dlinux_link_gnome_keyring=0"
- fi
-
- # Enable sandbox.
- myconf="${myconf}
- -Dlinux_sandbox_path=$(get_chromium_home)/chrome_sandbox
- -Dlinux_sandbox_chrome_path=$(get_chromium_home)/chrome"
-
- # Disable the V8 snapshot. It breaks the build on hardened (bug #301880),
- # and the performance gain isn't worth it.
- myconf="${myconf} -Dv8_use_snapshot=0"
-
- # Disable tcmalloc memory allocator. It causes problems,
- # for example bug #320419.
- myconf="${myconf} -Dlinux_use_tcmalloc=0"
-
- # Disable gpu rendering, it is incompatible with nvidia-drivers,
- # bug #319331.
- myconf="${myconf} -Denable_gpu=0"
-
- # Use target arch detection logic from bug #296917.
- local myarch="$ABI"
- [[ $myarch = "" ]] && myarch="$ARCH"
-
- if [[ $myarch = amd64 ]] ; then
- myconf="${myconf} -Dtarget_arch=x64"
- elif [[ $myarch = x86 ]] ; then
- myconf="${myconf} -Dtarget_arch=ia32"
- elif [[ $myarch = arm ]] ; then
- # TODO: check this again after
- # http://gcc.gnu.org/bugzilla/show_bug.cgi?id=39509 is fixed.
- append-flags -fno-tree-sink
-
- myconf="${myconf} -Dtarget_arch=arm -Ddisable_nacl=1 -Dlinux_use_tcmalloc=0"
- else
- die "Failed to determine target arch, got '$myarch'."
- fi
-
- if [[ "$(gcc-major-version)$(gcc-minor-version)" == "44" ]]; then
- myconf="${myconf} -Dno_strict_aliasing=1 -Dgcc_version=44"
- fi
-
- # Work around a likely GCC bug, see bug #331945.
- if [[ "$(gcc-major-version)$(gcc-minor-version)" == "45" ]]; then
- append-flags -fno-ipa-cp
- fi
-
- # Make sure that -Werror doesn't get added to CFLAGS by the build system.
- # Depending on GCC version the warnings are different and we don't want
- # the build to fail because of that.
- myconf="${myconf} -Dwerror="
-
- build/gyp_chromium -f make build/all.gyp ${myconf} --depth=. || die "gyp failed"
-}
-
-src_compile() {
- emake -r V=1 chrome chrome_sandbox BUILDTYPE=Release \
- rootdir="${S}" \
- CC="$(tc-getCC)" \
- CXX="$(tc-getCXX)" \
- AR="$(tc-getAR)" \
- RANLIB="$(tc-getRANLIB)" \
- || die "compilation failed"
-}
-
-src_install() {
- dodir "$(get_chromium_home)"
-
- exeinto "$(get_chromium_home)"
- pax-mark m out/Release/chrome
- doexe out/Release/chrome
- doexe out/Release/chrome_sandbox
- fperms 4755 "$(get_chromium_home)/chrome_sandbox"
- doexe out/Release/xdg-settings
- doexe "${FILESDIR}"/chromium-launcher.sh
-
- insinto "$(get_chromium_home)"
- doins out/Release/chrome.pak || die "installing chrome.pak failed"
- doins out/Release/resources.pak || die "installing resources.pak failed"
-
- doins -r out/Release/locales
- doins -r out/Release/resources
-
- # chrome.1 is for chromium --help
- newman out/Release/chrome.1 chrome.1
- newman out/Release/chrome.1 chromium.1
-
- doexe out/Release/ffmpegsumo_nolink || die
- doexe out/Release/libffmpegsumo.so || die
-
- # Install icon and desktop entry.
- newicon out/Release/product_logo_48.png ${PN}-browser.png
- dosym "$(get_chromium_home)/chromium-launcher.sh" /usr/bin/chromium
- make_desktop_entry chromium "Chromium" ${PN}-browser "Network;WebBrowser" \
- "MimeType=text/html;text/xml;application/xhtml+xml;"
- sed -e "/^Exec/s/$/ %U/" -i "${D}"/usr/share/applications/*.desktop \
- || die "desktop file sed failed"
-
- # Install GNOME default application entry (bug #303100).
- dodir /usr/share/gnome-control-center/default-apps
- insinto /usr/share/gnome-control-center/default-apps
- doins "${FILESDIR}"/chromium.xml
-}
diff --git a/www-client/chromium/chromium-6.0.472.36.ebuild b/www-client/chromium/chromium-6.0.472.51.ebuild
index 3b13a607c3da..0f31af748d51 100644
--- a/www-client/chromium/chromium-6.0.472.36.ebuild
+++ b/www-client/chromium/chromium-6.0.472.51.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2010 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/www-client/chromium/chromium-6.0.472.36.ebuild,v 1.1 2010/08/17 01:14:27 phajdan.jr Exp $
+# $Header: /var/cvsroot/gentoo-x86/www-client/chromium/chromium-6.0.472.51.ebuild,v 1.1 2010/08/28 18:10:20 phajdan.jr Exp $
EAPI="2"
@@ -13,13 +13,13 @@ SRC_URI="http://build.chromium.org/buildbot/official/${P}.tar.bz2"
LICENSE="BSD"
SLOT="0"
KEYWORDS="~amd64 ~arm ~x86"
-IUSE="cups gnome sse2"
+IUSE="cups gnome-keyring sse2"
RDEPEND="app-arch/bzip2
>=dev-libs/libevent-1.4.13
>=dev-libs/nss-3.12.3
>=gnome-base/gconf-2.24.0
- gnome? ( >=gnome-base/gnome-keyring-2.28.2 )
+ gnome-keyring? ( >=gnome-base/gnome-keyring-2.28.2 )
>=media-libs/alsa-lib-1.0.19
media-libs/jpeg:0
media-libs/libpng
@@ -116,7 +116,7 @@ src_configure() {
myconf="${myconf} -Duse_cups=0"
fi
- if use gnome; then
+ if use "gnome-keyring"; then
myconf="${myconf} -Dlinux_link_gnome_keyring=1"
else
# TODO: we should also disable code trying to dlopen
diff --git a/www-client/chromium/chromium-6.0.495.0.ebuild b/www-client/chromium/chromium-6.0.495.0.ebuild
deleted file mode 100644
index 00ac8344d51c..000000000000
--- a/www-client/chromium/chromium-6.0.495.0.ebuild
+++ /dev/null
@@ -1,222 +0,0 @@
-# Copyright 1999-2010 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/www-client/chromium/chromium-6.0.495.0.ebuild,v 1.2 2010/08/19 20:03:17 wired Exp $
-
-EAPI="2"
-
-inherit eutils flag-o-matic multilib pax-utils toolchain-funcs
-
-DESCRIPTION="Open-source version of Google Chrome web browser"
-HOMEPAGE="http://chromium.org/"
-SRC_URI="http://build.chromium.org/buildbot/official/${P}.tar.bz2"
-
-LICENSE="BSD"
-SLOT="0"
-KEYWORDS="~amd64 ~arm ~x86"
-IUSE="cups gnome sse2"
-
-RDEPEND="app-arch/bzip2
- >=dev-libs/libevent-1.4.13
- >=dev-libs/nss-3.12.3
- >=gnome-base/gconf-2.24.0
- gnome? ( >=gnome-base/gnome-keyring-2.28.2 )
- >=media-libs/alsa-lib-1.0.19
- media-libs/jpeg:0
- media-libs/libpng
- cups? ( >=net-print/cups-1.4.4 )
- sys-libs/zlib
- >=x11-libs/gtk+-2.14.7
- x11-libs/libXScrnSaver"
-DEPEND="${RDEPEND}
- dev-lang/perl
- >=dev-util/gperf-3.0.3
- >=dev-util/pkgconfig-0.23
- >=gnome-base/gnome-keyring-2.28.2
- sys-devel/flex"
-RDEPEND+="
- || (
- x11-themes/gnome-icon-theme
- x11-themes/oxygen-molecule
- x11-themes/tango-icon-theme
- x11-themes/xfce4-icon-theme
- )
- x11-apps/xmessage
- x11-misc/xdg-utils
- virtual/ttf-fonts"
-
-get_chromium_home() {
- echo "/usr/$(get_libdir)/chromium-browser"
-}
-
-remove_bundled_lib() {
- einfo "Removing bundled library $1 ..."
- local out
- out="$(find $1 -mindepth 1 \! -iname '*.gyp' -print -delete)" \
- || die "failed to remove bundled library $1"
- if [[ -z $out ]]; then
- die "no files matched when removing bundled library $1"
- fi
-}
-
-src_prepare() {
- # Add Gentoo plugin paths.
- epatch "${FILESDIR}"/${PN}-plugins-path-r0.patch
-
- # gcc 4.5 patch - bug #333345
- epatch "${FILESDIR}"/"${P}"-gcc-4.5.patch
-
- remove_bundled_lib "third_party/bzip2"
- remove_bundled_lib "third_party/codesighs"
- remove_bundled_lib "third_party/cros"
- remove_bundled_lib "third_party/jemalloc"
- remove_bundled_lib "third_party/lcov"
- remove_bundled_lib "third_party/libevent"
- remove_bundled_lib "third_party/libjpeg"
- remove_bundled_lib "third_party/libpng"
- remove_bundled_lib "third_party/lzma_sdk"
- remove_bundled_lib "third_party/molokocacao"
- remove_bundled_lib "third_party/ocmock"
- remove_bundled_lib "third_party/pyftpdlib"
- remove_bundled_lib "third_party/simplejson"
- remove_bundled_lib "third_party/tlslite"
- # TODO: also remove third_party/libxml and third_party/libxslt when
- # http://crbug.com/29333 is fixed.
- # TODO: also remove third_party/zlib. For now the compilation fails if we
- # remove it (minizip-related).
-}
-
-src_configure() {
- local myconf=""
-
- # Make it possible to build chromium on non-sse2 systems.
- if use sse2; then
- myconf="${myconf} -Ddisable_sse2=0"
- else
- myconf="${myconf} -Ddisable_sse2=1"
- fi
-
- # Use system-provided libraries.
- # TODO: use_system_ffmpeg (http://crbug.com/50678).
- # TODO: use_system_libxml (http://crbug.com/29333).
- # TODO: use_system_sqlite (http://crbug.com/22208).
- # TODO: use_system_icu, use_system_hunspell (upstream changes needed).
- # TODO: use_system_ssl when we have a recent enough system NSS.
- myconf="${myconf}
- -Duse_system_bzip2=1
- -Duse_system_libevent=1
- -Duse_system_libjpeg=1
- -Duse_system_libpng=1
- -Duse_system_zlib=1"
-
- # The dependency on cups is optional, see bug #324105.
- if use cups; then
- myconf="${myconf} -Duse_cups=1"
- else
- myconf="${myconf} -Duse_cups=0"
- fi
-
- if use gnome; then
- myconf="${myconf} -Dlinux_link_gnome_keyring=1"
- else
- # TODO: we should also disable code trying to dlopen
- # gnome-keyring in that case.
- myconf="${myconf} -Dlinux_link_gnome_keyring=0"
- fi
-
- # Enable sandbox.
- myconf="${myconf}
- -Dlinux_sandbox_path=$(get_chromium_home)/chrome_sandbox
- -Dlinux_sandbox_chrome_path=$(get_chromium_home)/chrome"
-
- # Disable the V8 snapshot. It breaks the build on hardened (bug #301880),
- # and the performance gain isn't worth it.
- myconf="${myconf} -Dv8_use_snapshot=0"
-
- # Disable tcmalloc memory allocator. It causes problems,
- # for example bug #320419.
- myconf="${myconf} -Dlinux_use_tcmalloc=0"
-
- # Use target arch detection logic from bug #296917.
- local myarch="$ABI"
- [[ $myarch = "" ]] && myarch="$ARCH"
-
- if [[ $myarch = amd64 ]] ; then
- myconf="${myconf} -Dtarget_arch=x64"
- elif [[ $myarch = x86 ]] ; then
- myconf="${myconf} -Dtarget_arch=ia32"
- elif [[ $myarch = arm ]] ; then
- # TODO: check this again after
- # http://gcc.gnu.org/bugzilla/show_bug.cgi?id=39509 is fixed.
- append-flags -fno-tree-sink
-
- myconf="${myconf} -Dtarget_arch=arm -Ddisable_nacl=1 -Dlinux_use_tcmalloc=0"
- else
- die "Failed to determine target arch, got '$myarch'."
- fi
-
- if [[ "$(gcc-major-version)$(gcc-minor-version)" == "44" ]]; then
- myconf="${myconf} -Dno_strict_aliasing=1 -Dgcc_version=44"
- fi
-
- # Work around a likely GCC bug, see bug #331945.
- if [[ "$(gcc-major-version)$(gcc-minor-version)" == "45" ]]; then
- append-flags -fno-ipa-cp
- fi
-
- # Make sure that -Werror doesn't get added to CFLAGS by the build system.
- # Depending on GCC version the warnings are different and we don't want
- # the build to fail because of that.
- myconf="${myconf} -Dwerror="
-
- build/gyp_chromium -f make build/all.gyp ${myconf} --depth=. || die "gyp failed"
-}
-
-src_compile() {
- emake -r V=1 chrome chrome_sandbox BUILDTYPE=Release \
- CC="$(tc-getCC)" \
- CXX="$(tc-getCXX)" \
- AR="$(tc-getAR)" \
- RANLIB="$(tc-getRANLIB)" \
- || die "compilation failed"
-}
-
-src_install() {
- dodir "$(get_chromium_home)"
-
- exeinto "$(get_chromium_home)"
- pax-mark m out/Release/chrome
- doexe out/Release/chrome
- doexe out/Release/chrome_sandbox
- fperms 4755 "$(get_chromium_home)/chrome_sandbox"
- doexe out/Release/xdg-settings
- doexe "${FILESDIR}"/chromium-launcher.sh
-
- insinto "$(get_chromium_home)"
- doins out/Release/chrome.pak || die "installing chrome.pak failed"
- doins out/Release/resources.pak || die "installing resources.pak failed"
-
- doins -r out/Release/locales
- doins -r out/Release/resources
-
- # chrome.1 is for chromium --help
- newman out/Release/chrome.1 chrome.1
- newman out/Release/chrome.1 chromium.1
-
- doexe out/Release/ffmpegsumo_nolink || die
- doexe out/Release/libffmpegsumo.so || die
-
- # Install icon and desktop entry.
- newicon out/Release/product_logo_48.png ${PN}-browser.png
- dosym "$(get_chromium_home)/chromium-launcher.sh" /usr/bin/chromium
- make_desktop_entry chromium "Chromium" ${PN}-browser "Network;WebBrowser" \
- "MimeType=text/html;text/xml;application/xhtml+xml;"
- sed -e "/^Exec/s/$/ %U/" -i "${D}"/usr/share/applications/*.desktop \
- || die "desktop file sed failed"
-
- # Install GNOME default application entry (bug #303100).
- if use gnome; then
- dodir /usr/share/gnome-control-center/default-apps
- insinto /usr/share/gnome-control-center/default-apps
- doins "${FILESDIR}"/chromium.xml
- fi
-}
diff --git a/www-client/chromium/chromium-7.0.503.1.ebuild b/www-client/chromium/chromium-7.0.503.1.ebuild
index 191608402803..615c806e3a30 100644
--- a/www-client/chromium/chromium-7.0.503.1.ebuild
+++ b/www-client/chromium/chromium-7.0.503.1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2010 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/www-client/chromium/chromium-7.0.503.1.ebuild,v 1.1 2010/08/26 03:54:09 phajdan.jr Exp $
+# $Header: /var/cvsroot/gentoo-x86/www-client/chromium/chromium-7.0.503.1.ebuild,v 1.2 2010/08/28 18:10:20 phajdan.jr Exp $
EAPI="2"
@@ -13,14 +13,14 @@ SRC_URI="http://build.chromium.org/buildbot/official/${P}.tar.bz2"
LICENSE="BSD"
SLOT="0"
KEYWORDS="~amd64 ~arm ~x86"
-IUSE="cups gnome sse2"
+IUSE="cups gnome gnome-keyring sse2"
RDEPEND="app-arch/bzip2
>=dev-libs/icu-4.4.1
>=dev-libs/libevent-1.4.13
>=dev-libs/nss-3.12.3
>=gnome-base/gconf-2.24.0
- gnome? ( >=gnome-base/gnome-keyring-2.28.2 )
+ gnome-keyring? ( >=gnome-base/gnome-keyring-2.28.2 )
>=media-libs/alsa-lib-1.0.19
media-libs/jpeg:0
media-libs/libpng
@@ -115,7 +115,7 @@ src_configure() {
myconf="${myconf} -Duse_cups=0"
fi
- if use gnome; then
+ if use "gnome-keyring"; then
myconf="${myconf} -Dlinux_link_gnome_keyring=1"
else
# TODO: we should also disable code trying to dlopen
diff --git a/www-client/chromium/chromium-9999.ebuild b/www-client/chromium/chromium-9999.ebuild
index 06088ca08c19..629abfaea9e4 100644
--- a/www-client/chromium/chromium-9999.ebuild
+++ b/www-client/chromium/chromium-9999.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2010 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/www-client/chromium/chromium-9999.ebuild,v 1.79 2010/08/26 03:54:09 phajdan.jr Exp $
+# $Header: /var/cvsroot/gentoo-x86/www-client/chromium/chromium-9999.ebuild,v 1.80 2010/08/28 18:10:20 phajdan.jr Exp $
EAPI="2"
@@ -15,14 +15,14 @@ EGCLIENT_REPO_URI="http://src.chromium.org/svn/trunk/src/"
LICENSE="BSD"
SLOT="0"
KEYWORDS=""
-IUSE="cups gnome sse2"
+IUSE="cups gnome gnome-keyring sse2"
RDEPEND="app-arch/bzip2
>=dev-libs/icu-4.4.1
>=dev-libs/libevent-1.4.13
>=dev-libs/nss-3.12.3
>=gnome-base/gconf-2.24.0
- gnome? ( >=gnome-base/gnome-keyring-2.28.2 )
+ gnome-keyring? ( >=gnome-base/gnome-keyring-2.28.2 )
>=media-libs/alsa-lib-1.0.19
media-libs/jpeg:0
media-libs/libpng
@@ -160,7 +160,7 @@ src_configure() {
myconf="${myconf} -Duse_cups=0"
fi
- if use gnome; then
+ if use "gnome-keyring"; then
myconf="${myconf} -Dlinux_link_gnome_keyring=1"
else
# TODO: we should also disable code trying to dlopen