summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexey Shvetsov <alexxy@gentoo.org>2012-05-24 16:57:52 +0000
committerAlexey Shvetsov <alexxy@gentoo.org>2012-05-24 16:57:52 +0000
commit7cc86b0a564349d65728420ef94fe8e70d5177a6 (patch)
tree0e0d66719858ce5a3c9424860cea6ee693f54071 /www-apps/rutorrent
parentPull in cxx useflag on merkartor to not fail on build. (not present on stable... (diff)
downloadgentoo-2-7cc86b0a564349d65728420ef94fe8e70d5177a6.tar.gz
gentoo-2-7cc86b0a564349d65728420ef94fe8e70d5177a6.tar.bz2
gentoo-2-7cc86b0a564349d65728420ef94fe8e70d5177a6.zip
[www-apps/rutorrent] Version bump per bug #411273
(Portage version: 2.2.0_alpha107/cvs/Linux x86_64)
Diffstat (limited to 'www-apps/rutorrent')
-rw-r--r--www-apps/rutorrent/ChangeLog9
-rw-r--r--www-apps/rutorrent/rutorrent-3.4.ebuild52
2 files changed, 59 insertions, 2 deletions
diff --git a/www-apps/rutorrent/ChangeLog b/www-apps/rutorrent/ChangeLog
index cc05841f22aa..17bbb30f6c1f 100644
--- a/www-apps/rutorrent/ChangeLog
+++ b/www-apps/rutorrent/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for www-apps/rutorrent
-# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/www-apps/rutorrent/ChangeLog,v 1.3 2011/09/01 17:51:38 alexxy Exp $
+# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/www-apps/rutorrent/ChangeLog,v 1.4 2012/05/24 16:57:52 alexxy Exp $
+
+*rutorrent-3.4 (24 May 2012)
+
+ 24 May 2012; Alexey Shvetsov <alexxy@gentoo.org> +rutorrent-3.4.ebuild:
+ [www-apps/rutorrent] Version bump per bug #411273
01 Sep 2011; Alexey Shvetsov <alexxy@gentoo.org> rutorrent-3.3.ebuild:
Fix bug #378747 and #379249
diff --git a/www-apps/rutorrent/rutorrent-3.4.ebuild b/www-apps/rutorrent/rutorrent-3.4.ebuild
new file mode 100644
index 000000000000..dc870e4e5305
--- /dev/null
+++ b/www-apps/rutorrent/rutorrent-3.4.ebuild
@@ -0,0 +1,52 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/www-apps/rutorrent/rutorrent-3.4.ebuild,v 1.1 2012/05/24 16:57:52 alexxy Exp $
+
+EAPI="4"
+
+inherit webapp eutils depend.php
+
+DESCRIPTION="ruTorrent is a front-end for the popular Bittorrent client rTorrent"
+HOMEPAGE="http://code.google.com/p/rutorrent/"
+SRC_URI="
+ http://rutorrent.googlecode.com/files/${P}.tar.gz
+ http://rutorrent.googlecode.com/files/plugins-${PV}.tar.gz"
+
+LICENSE="GPL-2"
+KEYWORDS="~alpha ~amd64 ~ppc ~x86"
+IUSE=""
+
+need_httpd_cgi
+need_php_httpd
+
+DEPEND="
+ || ( dev-lang/php[xml,gd] dev-lang/php[xml,gd-external] )
+"
+
+S="${WORKDIR}"
+
+pkg_setup() {
+ webapp_pkg_setup
+}
+
+src_install() {
+ webapp_src_preinst
+
+ insinto "${MY_HTDOCSDIR}"
+ mv plugins rutorrent
+ cd rutorrent
+ doins -r .
+
+ webapp_serverowned "${MY_HTDOCSDIR}"/share
+ webapp_serverowned "${MY_HTDOCSDIR}"/share/settings
+ webapp_serverowned "${MY_HTDOCSDIR}"/share/torrents
+ webapp_serverowned "${MY_HTDOCSDIR}"/share/users
+
+ webapp_configfile "${MY_HTDOCSDIR}"/conf/.htaccess
+ webapp_configfile "${MY_HTDOCSDIR}"/conf/config.php
+ webapp_configfile "${MY_HTDOCSDIR}"/conf/access.ini
+ webapp_configfile "${MY_HTDOCSDIR}"/conf/plugins.ini
+ webapp_configfile "${MY_HTDOCSDIR}"/share/.htaccess
+
+ webapp_src_install
+}