summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBenedikt Boehm <hollow@gentoo.org>2009-01-01 14:20:13 +0000
committerBenedikt Boehm <hollow@gentoo.org>2009-01-01 14:20:13 +0000
commit6d60e183a5eb4c29985ec9b64a1be5c05b019ea9 (patch)
tree839d5a13b8b6205155a66f78c5c4dad021dc4bf0 /www-apache/mod_security
parentversion bump wrt #244754, 0.5.1 stable on amd64 & x86 (diff)
downloadgentoo-2-6d60e183a5eb4c29985ec9b64a1be5c05b019ea9.tar.gz
gentoo-2-6d60e183a5eb4c29985ec9b64a1be5c05b019ea9.tar.bz2
gentoo-2-6d60e183a5eb4c29985ec9b64a1be5c05b019ea9.zip
version bump wrt #234424
(Portage version: 2.2_rc18/cvs/Linux 2.6.22-vs2.3.0.34-gentoo x86_64)
Diffstat (limited to 'www-apache/mod_security')
-rw-r--r--www-apache/mod_security/ChangeLog8
-rw-r--r--www-apache/mod_security/mod_security-2.5.7.ebuild65
2 files changed, 72 insertions, 1 deletions
diff --git a/www-apache/mod_security/ChangeLog b/www-apache/mod_security/ChangeLog
index c07ffef214de..0852c39e6dc4 100644
--- a/www-apache/mod_security/ChangeLog
+++ b/www-apache/mod_security/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for www-apache/mod_security
# Copyright 2000-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/www-apache/mod_security/ChangeLog,v 1.16 2009/01/01 14:11:36 hollow Exp $
+# $Header: /var/cvsroot/gentoo-x86/www-apache/mod_security/ChangeLog,v 1.17 2009/01/01 14:20:13 hollow Exp $
+
+*mod_security-2.5.7 (01 Jan 2009)
+
+ 01 Jan 2009; Benedikt Böhm <hollow@gentoo.org>
+ +mod_security-2.5.7.ebuild:
+ version bump wrt #234424
*mod_security-2.5.6 (01 Jan 2009)
diff --git a/www-apache/mod_security/mod_security-2.5.7.ebuild b/www-apache/mod_security/mod_security-2.5.7.ebuild
new file mode 100644
index 000000000000..5d943c3efee4
--- /dev/null
+++ b/www-apache/mod_security/mod_security-2.5.7.ebuild
@@ -0,0 +1,65 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/www-apache/mod_security/mod_security-2.5.7.ebuild,v 1.1 2009/01/01 14:20:13 hollow Exp $
+
+inherit apache-module
+
+MY_P=${P/mod_security-/modsecurity-apache_}
+MY_P=${MY_P/_rc/-rc}
+
+DESCRIPTION="Web application firewall and Intrusion Detection System for Apache."
+HOMEPAGE="http://www.modsecurity.org/"
+SRC_URI="http://www.modsecurity.org/download/${MY_P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~mips ~ppc ~sparc ~x86"
+IUSE="lua"
+
+DEPEND="dev-libs/libxml2
+ lua? ( >=dev-lang/lua-5.1 )"
+RDEPEND="${DEPEND}"
+
+S="${WORKDIR}/${MY_P}"
+
+APACHE2_MOD_FILE="apache2/.libs/${PN}2.so"
+APACHE2_MOD_CONF="2.1.2/99_mod_security"
+APACHE2_MOD_DEFINE="SECURITY"
+
+need_apache2
+
+src_compile() {
+ cd apache2
+
+ econf --with-apxs="${APXS}" \
+ --without-curl \
+ $(use_with lua) \
+ || die "econf failed"
+
+ emake || die "emake failed"
+}
+
+src_install() {
+ apache-module_src_install
+
+ # install rules updater
+ newbin tools/rules-updater.pl rules-updater
+
+ # install documentation
+ dodoc CHANGES
+ newdoc rules/CHANGELOG CHANGES.crs
+ newdoc rules/README README.crs
+ dohtml doc/*.html doc/*.gif doc/*.jpg doc/*.css doc/*.pdf
+ insinto /usr/share/doc/${P}/html/
+ doins -r doc/html-multipage
+
+ # Prepare the core ruleset
+ sed -i -e 's:logs/:/var/log/apache2/:g' "${S}"/rules/*.conf
+ for i in "${S}"/rules/*.conf; do
+ mv $i ${i/modsecurity_crs_/}
+ done
+
+ # Install core ruleset
+ insinto ${APACHE_MODULES_CONFDIR}/mod_security/
+ doins "${S}"/rules/*.conf
+}