summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2014-01-20 06:40:56 +0000
committerMike Frysinger <vapier@gentoo.org>2014-01-20 06:40:56 +0000
commit636e36941dfb4ef73185b5e4d9fbca133d92bad5 (patch)
tree44d6f79a048c95ed1fd948a1d250b8973d200738 /sys-process/lsof
parentDepend on virtual/pkgconfig for ncurses needs #498586 by palme3000. (diff)
downloadgentoo-2-636e36941dfb4ef73185b5e4d9fbca133d92bad5.tar.gz
gentoo-2-636e36941dfb4ef73185b5e4d9fbca133d92bad5.tar.bz2
gentoo-2-636e36941dfb4ef73185b5e4d9fbca133d92bad5.zip
Depend on virtual/pkgconfig when USE=rpc due to libtirpc functionality #498584 by palme3000.
(Portage version: 2.2.8/cvs/Linux x86_64, signed Manifest commit with key D2E96200)
Diffstat (limited to 'sys-process/lsof')
-rw-r--r--sys-process/lsof/ChangeLog7
-rw-r--r--sys-process/lsof/lsof-4.85-r2.ebuild7
-rw-r--r--sys-process/lsof/lsof-4.87-r1.ebuild7
3 files changed, 14 insertions, 7 deletions
diff --git a/sys-process/lsof/ChangeLog b/sys-process/lsof/ChangeLog
index c22b8e0d5e12..247546f94cef 100644
--- a/sys-process/lsof/ChangeLog
+++ b/sys-process/lsof/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for sys-process/lsof
# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-process/lsof/ChangeLog,v 1.97 2014/01/18 03:51:35 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-process/lsof/ChangeLog,v 1.98 2014/01/20 06:40:56 vapier Exp $
+
+ 20 Jan 2014; Mike Frysinger <vapier@gentoo.org> lsof-4.85-r2.ebuild,
+ lsof-4.87-r1.ebuild:
+ Depend on virtual/pkgconfig when USE=rpc due to libtirpc functionality #498584
+ by palme3000.
18 Jan 2014; Mike Frysinger <vapier@gentoo.org> lsof-4.85-r2.ebuild,
lsof-4.87-r1.ebuild:
diff --git a/sys-process/lsof/lsof-4.85-r2.ebuild b/sys-process/lsof/lsof-4.85-r2.ebuild
index c1351ac22a37..b91bb69d4d2c 100644
--- a/sys-process/lsof/lsof-4.85-r2.ebuild
+++ b/sys-process/lsof/lsof-4.85-r2.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2014 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-process/lsof/lsof-4.85-r2.ebuild,v 1.11 2014/01/18 03:51:35 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-process/lsof/lsof-4.85-r2.ebuild,v 1.12 2014/01/20 06:40:56 vapier Exp $
EAPI="2"
@@ -20,7 +20,8 @@ IUSE="examples ipv6 rpc selinux static"
RDEPEND="rpc? ( net-libs/libtirpc )
selinux? ( sys-libs/libselinux )"
-DEPEND="${RDEPEND}"
+DEPEND="${RDEPEND}
+ rpc? ( virtual/pkgconfig )"
S=${WORKDIR}/${MY_P}/${MY_P}_src
@@ -44,7 +45,7 @@ target() { usex kernel_FreeBSD freebsd linux ; }
src_configure() {
use static && append-ldflags -static
- append-cppflags $(usex rpc "$($(tc-getPKG_CONFIG) libtirpc --cflags)" "-DHASNOTRPC -DHASNORPC_H")
+ append-cppflags $(use rpc && $(tc-getPKG_CONFIG) libtirpc --cflags || echo "-DHASNOTRPC -DHASNORPC_H")
append-cppflags $(usex ipv6 -{D,U}HASIPv6)
export LSOF_CFGL="${CFLAGS} ${LDFLAGS} \
diff --git a/sys-process/lsof/lsof-4.87-r1.ebuild b/sys-process/lsof/lsof-4.87-r1.ebuild
index 19e4fc899c60..ea2502641beb 100644
--- a/sys-process/lsof/lsof-4.87-r1.ebuild
+++ b/sys-process/lsof/lsof-4.87-r1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2014 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-process/lsof/lsof-4.87-r1.ebuild,v 1.2 2014/01/18 03:51:35 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-process/lsof/lsof-4.87-r1.ebuild,v 1.3 2014/01/20 06:40:56 vapier Exp $
EAPI="4"
@@ -20,7 +20,8 @@ IUSE="examples ipv6 rpc selinux static"
RDEPEND="rpc? ( net-libs/libtirpc )
selinux? ( sys-libs/libselinux )"
-DEPEND="${RDEPEND}"
+DEPEND="${RDEPEND}
+ rpc? ( virtual/pkgconfig )"
S=${WORKDIR}/${MY_P}/${MY_P}_src
@@ -52,7 +53,7 @@ target() {
src_configure() {
use static && append-ldflags -static
- append-cppflags $(usex rpc "$($(tc-getPKG_CONFIG) libtirpc --cflags)" "-DHASNOTRPC -DHASNORPC_H")
+ append-cppflags $(use rpc && $(tc-getPKG_CONFIG) libtirpc --cflags || echo "-DHASNOTRPC -DHASNORPC_H")
append-cppflags $(usex ipv6 -{D,U}HASIPv6)
export LSOF_CFGL="${CFLAGS} ${LDFLAGS} \