summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJeremy Olexa <darkside@gentoo.org>2008-12-10 18:57:42 +0000
committerJeremy Olexa <darkside@gentoo.org>2008-12-10 18:57:42 +0000
commite2a7a1f497e35e6ffa91a1a9ad519108b0d5c946 (patch)
tree98a31d2f9dbc1c2cf72bcb2307b5af983d64ee97 /sys-power
parentKeyworded on alpha (diff)
downloadgentoo-2-e2a7a1f497e35e6ffa91a1a9ad519108b0d5c946.tar.gz
gentoo-2-e2a7a1f497e35e6ffa91a1a9ad519108b0d5c946.tar.bz2
gentoo-2-e2a7a1f497e35e6ffa91a1a9ad519108b0d5c946.zip
(non maintainer commit) Version bump, bug 225443 with the removal of alsa USE flag because upstream dropped support for it
(Portage version: 2.2_rc17/cvs/Linux 2.6.27.8 x86_64)
Diffstat (limited to 'sys-power')
-rw-r--r--sys-power/pm-utils/ChangeLog8
-rw-r--r--sys-power/pm-utils/pm-utils-1.2.3.ebuild52
2 files changed, 59 insertions, 1 deletions
diff --git a/sys-power/pm-utils/ChangeLog b/sys-power/pm-utils/ChangeLog
index 2fa9174dcb9c..fda5e84e97f7 100644
--- a/sys-power/pm-utils/ChangeLog
+++ b/sys-power/pm-utils/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for sys-power/pm-utils
# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-power/pm-utils/ChangeLog,v 1.8 2008/10/23 15:08:51 remi Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-power/pm-utils/ChangeLog,v 1.9 2008/12/10 18:57:42 darkside Exp $
+
+*pm-utils-1.2.3 (10 Dec 2008)
+
+ 10 Dec 2008; Jeremy Olexa <darkside@gentoo.org> +pm-utils-1.2.3.ebuild:
+ (non maintainer commit) Version bump, bug 225443 with the removal of alsa
+ USE flag because upstream dropped support for it
23 Oct 2008; Rémi Cardona <remi@gentoo.org> pm-utils-1.1.1.ebuild,
pm-utils-1.1.2.1.ebuild:
diff --git a/sys-power/pm-utils/pm-utils-1.2.3.ebuild b/sys-power/pm-utils/pm-utils-1.2.3.ebuild
new file mode 100644
index 000000000000..e7fd1a0f6233
--- /dev/null
+++ b/sys-power/pm-utils/pm-utils-1.2.3.ebuild
@@ -0,0 +1,52 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-power/pm-utils/pm-utils-1.2.3.ebuild,v 1.1 2008/12/10 18:57:42 darkside Exp $
+
+DESCRIPTION="Suspend and hibernation utilties for HAL"
+HOMEPAGE="http://pm-utils.freedesktop.org/"
+SRC_URI="http://pm-utils.freedesktop.org/releases/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="debug networkmanager ntp video_cards_intel video_cards_radeon"
+
+RDEPEND=">=sys-apps/hal-0.5.10
+ >=sys-apps/dbus-1.0.0
+ !sys-power/powermgmt-base
+ >=sys-apps/util-linux-2.13
+ alsa? ( media-sound/alsa-utils )
+ networkmanager? ( net-misc/networkmanager )
+ ntp? ( net-misc/ntp )
+ !video_cards_intel? ( sys-apps/vbetool )
+ video_cards_radeon? ( app-laptop/radeontool )"
+DEPEND="!sys-power/powermgmt-base
+ app-text/xmlto"
+
+src_unpack() {
+ local ignore="01grub"
+
+ unpack ${A}
+ cd "${S}"
+
+ touch "${S}/gentoo"
+
+ use debug && echo 'PM_DEBUG="true"' > "${S}/gentoo"
+
+ use networkmanager || ignore="${ignore} 10NetworkManager"
+ use ntp || ignore="${ignore} 90clock"
+
+ echo "HOOK_BLACKLIST=\"${ignore}\"" > "${S}/gentoo"
+}
+
+src_compile() {
+ econf || die "econf failed"
+ emake || die "emake failed"
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die "emake install failed"
+
+ insinto /etc/pm/config.d/
+ doins "${S}/gentoo"
+}