summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSamuli Suominen <ssuominen@gentoo.org>2014-02-12 20:03:19 +0000
committerSamuli Suominen <ssuominen@gentoo.org>2014-02-12 20:03:19 +0000
commita23dedda5ea288dc96f88541c287ba2caae5f551 (patch)
tree7c3cb632f3a3998a54045453292659ca383e3c0b /sys-power/cpupower
parentVersion bump. (diff)
downloadgentoo-2-a23dedda5ea288dc96f88541c287ba2caae5f551.tar.gz
gentoo-2-a23dedda5ea288dc96f88541c287ba2caae5f551.tar.bz2
gentoo-2-a23dedda5ea288dc96f88541c287ba2caae5f551.zip
old
(Portage version: 2.2.8-r1/cvs/Linux x86_64, signed Manifest commit with key 4868F14D)
Diffstat (limited to 'sys-power/cpupower')
-rw-r--r--sys-power/cpupower/ChangeLog7
-rw-r--r--sys-power/cpupower/cpupower-3.11-r1.ebuild71
-rw-r--r--sys-power/cpupower/cpupower-3.11.ebuild71
-rw-r--r--sys-power/cpupower/cpupower-3.12.ebuild71
-rw-r--r--sys-power/cpupower/files/init.d-r241
-rw-r--r--sys-power/cpupower/files/init.d-r343
6 files changed, 6 insertions, 298 deletions
diff --git a/sys-power/cpupower/ChangeLog b/sys-power/cpupower/ChangeLog
index cf780c5e1d4a..552224e92269 100644
--- a/sys-power/cpupower/ChangeLog
+++ b/sys-power/cpupower/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for sys-power/cpupower
# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-power/cpupower/ChangeLog,v 1.13 2014/02/12 20:02:03 ssuominen Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-power/cpupower/ChangeLog,v 1.14 2014/02/12 20:03:18 ssuominen Exp $
+
+ 12 Feb 2014; Samuli Suominen <ssuominen@gentoo.org> -cpupower-3.11-r1.ebuild,
+ -cpupower-3.11.ebuild, -cpupower-3.12.ebuild, -files/init.d-r2,
+ -files/init.d-r3:
+ old
*cpupower-3.13 (12 Feb 2014)
diff --git a/sys-power/cpupower/cpupower-3.11-r1.ebuild b/sys-power/cpupower/cpupower-3.11-r1.ebuild
deleted file mode 100644
index 1abebeaad31c..000000000000
--- a/sys-power/cpupower/cpupower-3.11-r1.ebuild
+++ /dev/null
@@ -1,71 +0,0 @@
-# Copyright 1999-2013 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-power/cpupower/cpupower-3.11-r1.ebuild,v 1.1 2013/10/20 14:17:59 ssuominen Exp $
-
-EAPI=5
-inherit multilib toolchain-funcs
-
-DESCRIPTION="Shows and sets processor power related values"
-HOMEPAGE="http://www.kernel.org/"
-SRC_URI="mirror://kernel/linux/kernel/v3.x/linux-${PV}.tar.xz"
-
-LICENSE="GPL-2"
-SLOT="0"
-KEYWORDS="~amd64 ~x86"
-IUSE="cpufreq_bench debug nls"
-
-# cpupower should be a USE flag in linux-misc-apps (ditto for usbip!)
-# but only if the maintainer doesn't agree to drop it completely from
-# there in favour of this one which i'll push to users are replacement
-# for the dead cpufreq tools in tree
-# !sys-apps/linux-misc-apps[cpupower]
-
-# header collision with cpufrequtils
-RDEPEND="sys-apps/pciutils
- !sys-apps/linux-misc-apps
- !sys-power/cpufrequtils"
-DEPEND="${RDEPEND}
- virtual/os-headers
- virtual/pkgconfig
- nls? ( sys-devel/gettext )"
-
-S=${WORKDIR}/linux-${PV}/tools/power/${PN}
-
-pkg_setup() {
- myemakeargs=(
- DEBUG=$(usex debug true false)
- V=1
- CPUFREQ_BENCH=$(usex cpufreq_bench true false)
- NLS=$(usex nls true false)
- docdir=/usr/share/doc/${PF}/${PN}
- mandir=/usr/share/man
- libdir=/usr/$(get_libdir)
- AR="$(tc-getAR)"
- CC="$(tc-getCC)"
- LD="$(tc-getCC)"
- STRIP=true
- LDFLAGS="${LDFLAGS}"
- OPTIMIZATION="${CFLAGS}"
- )
-}
-
-src_prepare() {
- # -Wl,--as-needed compat
- local libs="-lcpupower -lrt $($(tc-getPKG_CONFIG) --libs-only-l libpci)"
- sed -i \
- -e "/$libs/{ s,${libs},,g; s,\$, ${libs},g;}" \
- -e "s:-O1 -g::" \
- Makefile || die
-}
-
-src_compile() {
- emake "${myemakeargs[@]}"
-}
-
-src_install() {
- emake DESTDIR="${D}" "${myemakeargs[@]}" install
- dodoc README ToDo
-
- newconfd "${FILESDIR}"/conf.d-r2 ${PN}
- newinitd "${FILESDIR}"/init.d-r3 ${PN}
-}
diff --git a/sys-power/cpupower/cpupower-3.11.ebuild b/sys-power/cpupower/cpupower-3.11.ebuild
deleted file mode 100644
index 0c46db6a32bd..000000000000
--- a/sys-power/cpupower/cpupower-3.11.ebuild
+++ /dev/null
@@ -1,71 +0,0 @@
-# Copyright 1999-2013 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-power/cpupower/cpupower-3.11.ebuild,v 1.1 2013/09/27 11:31:48 ssuominen Exp $
-
-EAPI=5
-inherit multilib toolchain-funcs
-
-DESCRIPTION="Shows and sets processor power related values"
-HOMEPAGE="http://www.kernel.org/"
-SRC_URI="mirror://kernel/linux/kernel/v3.x/linux-${PV}.tar.xz"
-
-LICENSE="GPL-2"
-SLOT="0"
-KEYWORDS="~amd64 ~x86"
-IUSE="cpufreq_bench debug nls"
-
-# cpupower should be a USE flag in linux-misc-apps (ditto for usbip!)
-# but only if the maintainer doesn't agree to drop it completely from
-# there in favour of this one which i'll push to users are replacement
-# for the dead cpufreq tools in tree
-# !sys-apps/linux-misc-apps[cpupower]
-
-# header collision with cpufrequtils
-RDEPEND="sys-apps/pciutils
- !sys-apps/linux-misc-apps
- !sys-power/cpufrequtils"
-DEPEND="${RDEPEND}
- virtual/os-headers
- virtual/pkgconfig
- nls? ( sys-devel/gettext )"
-
-S=${WORKDIR}/linux-${PV}/tools/power/${PN}
-
-pkg_setup() {
- myemakeargs=(
- DEBUG=$(usex debug true false)
- V=1
- CPUFREQ_BENCH=$(usex cpufreq_bench true false)
- NLS=$(usex nls true false)
- docdir=/usr/share/doc/${PF}/${PN}
- mandir=/usr/share/man
- libdir=/usr/$(get_libdir)
- AR="$(tc-getAR)"
- CC="$(tc-getCC)"
- LD="$(tc-getCC)"
- STRIP=true
- LDFLAGS="${LDFLAGS}"
- OPTIMIZATION="${CFLAGS}"
- )
-}
-
-src_prepare() {
- # -Wl,--as-needed compat
- local libs="-lcpupower -lrt $($(tc-getPKG_CONFIG) --libs-only-l libpci)"
- sed -i \
- -e "/$libs/{ s,${libs},,g; s,\$, ${libs},g;}" \
- -e "s:-O1 -g::" \
- Makefile || die
-}
-
-src_compile() {
- emake "${myemakeargs[@]}"
-}
-
-src_install() {
- emake DESTDIR="${D}" "${myemakeargs[@]}" install
- dodoc README ToDo
-
- newconfd "${FILESDIR}"/conf.d-r2 ${PN}
- newinitd "${FILESDIR}"/init.d-r2 ${PN}
-}
diff --git a/sys-power/cpupower/cpupower-3.12.ebuild b/sys-power/cpupower/cpupower-3.12.ebuild
deleted file mode 100644
index 14224ed7d78c..000000000000
--- a/sys-power/cpupower/cpupower-3.12.ebuild
+++ /dev/null
@@ -1,71 +0,0 @@
-# Copyright 1999-2013 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-power/cpupower/cpupower-3.12.ebuild,v 1.1 2013/12/25 11:46:32 ssuominen Exp $
-
-EAPI=5
-inherit multilib toolchain-funcs
-
-DESCRIPTION="Shows and sets processor power related values"
-HOMEPAGE="http://www.kernel.org/"
-SRC_URI="mirror://kernel/linux/kernel/v3.x/linux-${PV}.tar.xz"
-
-LICENSE="GPL-2"
-SLOT="0"
-KEYWORDS="~amd64 ~x86"
-IUSE="cpufreq_bench debug nls"
-
-# cpupower should be a USE flag in linux-misc-apps (ditto for usbip!)
-# but only if the maintainer doesn't agree to drop it completely from
-# there in favour of this one which i'll push to users are replacement
-# for the dead cpufreq tools in tree
-# !sys-apps/linux-misc-apps[cpupower]
-
-# header collision with cpufrequtils
-RDEPEND="sys-apps/pciutils
- !sys-apps/linux-misc-apps
- !sys-power/cpufrequtils"
-DEPEND="${RDEPEND}
- virtual/os-headers
- virtual/pkgconfig
- nls? ( sys-devel/gettext )"
-
-S=${WORKDIR}/linux-${PV}/tools/power/${PN}
-
-pkg_setup() {
- myemakeargs=(
- DEBUG=$(usex debug true false)
- V=1
- CPUFREQ_BENCH=$(usex cpufreq_bench true false)
- NLS=$(usex nls true false)
- docdir=/usr/share/doc/${PF}/${PN}
- mandir=/usr/share/man
- libdir=/usr/$(get_libdir)
- AR="$(tc-getAR)"
- CC="$(tc-getCC)"
- LD="$(tc-getCC)"
- STRIP=true
- LDFLAGS="${LDFLAGS}"
- OPTIMIZATION="${CFLAGS}"
- )
-}
-
-src_prepare() {
- # -Wl,--as-needed compat
- local libs="-lcpupower -lrt $($(tc-getPKG_CONFIG) --libs-only-l libpci)"
- sed -i \
- -e "/$libs/{ s,${libs},,g; s,\$, ${libs},g;}" \
- -e "s:-O1 -g::" \
- Makefile || die
-}
-
-src_compile() {
- emake "${myemakeargs[@]}"
-}
-
-src_install() {
- emake DESTDIR="${D}" "${myemakeargs[@]}" install
- dodoc README ToDo
-
- newconfd "${FILESDIR}"/conf.d-r2 ${PN}
- newinitd "${FILESDIR}"/init.d-r4 ${PN}
-}
diff --git a/sys-power/cpupower/files/init.d-r2 b/sys-power/cpupower/files/init.d-r2
deleted file mode 100644
index 5f748d7397d7..000000000000
--- a/sys-power/cpupower/files/init.d-r2
+++ /dev/null
@@ -1,41 +0,0 @@
-#!/sbin/runscript
-# Copyright 1999-2013 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-power/cpupower/files/init.d-r2,v 1.1 2013/09/27 11:31:48 ssuominen Exp $
-
-change() {
- local c ret=0 opts="$1"
- shift
- if [ -n "$opts" ] ; then
- ebegin "Running cpupower -c all frequency-set ${opts}"
- cpupower -c all frequency-set ${opts} >/dev/null 2>&1
- : $(( ret += $? ))
- eend ${ret}
-
- if [ $# -gt 0 ] ; then
- c=1
- einfo "Setting extra options: $*"
- if cd /sys/devices/system/cpu/cpufreq ; then
- local o v
- for o in "$@" ; do
- v=${o#*=}
- o=${o%%=*}
- echo ${v} > ${o} || break
- done
- c=0
- fi
- eend ${c}
- : $(( ret += c ))
- fi
- fi
-
- return ${ret}
-}
-
-start() {
- change "${START_OPTS}" "${SYSFS_EXTRA}"
-}
-
-stop() {
- change "${STOP_OPTS}"
-}
diff --git a/sys-power/cpupower/files/init.d-r3 b/sys-power/cpupower/files/init.d-r3
deleted file mode 100644
index 7e4621c4baff..000000000000
--- a/sys-power/cpupower/files/init.d-r3
+++ /dev/null
@@ -1,43 +0,0 @@
-#!/sbin/runscript
-# Copyright 1999-2013 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-power/cpupower/files/init.d-r3,v 1.1 2013/10/20 14:17:59 ssuominen Exp $
-
-CPUFREQ_SYSFS=/sys/devices/system/cpu/cpufreq
-
-change() {
- local c ret=0 opts="$1"
- shift
- if [ -n "$opts" ] ; then
- ebegin "Running cpupower -c all frequency-set ${opts}"
- cpupower -c all frequency-set ${opts} >/dev/null 2>&1
- : $(( ret += $? ))
- eend ${ret}
-
- if [ -d ${CPUFREQ_SYSFS} ] && [ $# -gt 0 ] ; then
- c=1
- einfo "Setting extra options: $*"
- if cd ${CPUFREQ_SYSFS} ; then
- local o v
- for o in "$@" ; do
- v=${o#*=}
- o=${o%%=*}
- echo ${v} > ${o} || break
- done
- c=0
- fi
- eend ${c}
- : $(( ret += c ))
- fi
- fi
-
- return ${ret}
-}
-
-start() {
- change "${START_OPTS}" "${SYSFS_EXTRA}"
-}
-
-stop() {
- change "${STOP_OPTS}"
-}