summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMark Loeser <halcy0n@gentoo.org>2008-07-31 01:03:00 +0000
committerMark Loeser <halcy0n@gentoo.org>2008-07-31 01:03:00 +0000
commit342cce515d7246c755521695872dec7f37cd5827 (patch)
treed2f2d33e915aa265252456dabee6a6561c9f19dc /sys-libs/timezone-data
parentRemoving dev-util/livecd-kconfigs, since the kernel configs are now available... (diff)
downloadgentoo-2-342cce515d7246c755521695872dec7f37cd5827.tar.gz
gentoo-2-342cce515d7246c755521695872dec7f37cd5827.tar.bz2
gentoo-2-342cce515d7246c755521695872dec7f37cd5827.zip
Version bump; bug #233180
(Portage version: 2.2_rc1/cvs/Linux 2.6.24.5 x86_64)
Diffstat (limited to 'sys-libs/timezone-data')
-rw-r--r--sys-libs/timezone-data/ChangeLog7
-rw-r--r--sys-libs/timezone-data/timezone-data-2008e.ebuild96
2 files changed, 102 insertions, 1 deletions
diff --git a/sys-libs/timezone-data/ChangeLog b/sys-libs/timezone-data/ChangeLog
index e15c8223a1ca..f76cc65697ac 100644
--- a/sys-libs/timezone-data/ChangeLog
+++ b/sys-libs/timezone-data/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for sys-libs/timezone-data
# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-libs/timezone-data/ChangeLog,v 1.141 2008/06/23 16:45:03 jer Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-libs/timezone-data/ChangeLog,v 1.142 2008/07/31 01:03:00 halcy0n Exp $
+
+*timezone-data-2008e (31 Jul 2008)
+
+ 31 Jul 2008; Mark Loeser <halcy0n@gentoo.org> +timezone-data-2008e.ebuild:
+ Version bump; bug #233180
23 Jun 2008; Jeroen Roovers <jer@gentoo.org> timezone-data-2008c.ebuild:
Stable for HPPA (bug #228675).
diff --git a/sys-libs/timezone-data/timezone-data-2008e.ebuild b/sys-libs/timezone-data/timezone-data-2008e.ebuild
new file mode 100644
index 000000000000..1b18fabded54
--- /dev/null
+++ b/sys-libs/timezone-data/timezone-data-2008e.ebuild
@@ -0,0 +1,96 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-libs/timezone-data/timezone-data-2008e.ebuild,v 1.1 2008/07/31 01:03:00 halcy0n Exp $
+
+inherit eutils toolchain-funcs flag-o-matic
+
+code_ver=${PV/c/a}
+data_ver=${PV}
+DESCRIPTION="Timezone data (/usr/share/zoneinfo) and utilities (tzselect/zic/zdump)"
+HOMEPAGE="ftp://elsie.nci.nih.gov/pub/"
+SRC_URI="ftp://elsie.nci.nih.gov/pub/tzdata${data_ver}.tar.gz
+ ftp://elsie.nci.nih.gov/pub/tzcode${code_ver}.tar.gz
+ mirror://gentoo/tzdata${data_ver}.tar.gz
+ mirror://gentoo/tzcode${code_ver}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~sparc-fbsd ~x86 ~x86-fbsd"
+IUSE="nls elibc_FreeBSD elibc_glibc"
+
+DEPEND=""
+
+S=${WORKDIR}
+
+src_unpack() {
+ unpack ${A}
+ epatch "${FILESDIR}"/${PN}-2005n-makefile.patch
+ tc-is-cross-compiler && cp -pR "${S}" "${S}"-native
+}
+
+src_compile() {
+ tc-export CC
+ use elibc_FreeBSD && append-flags -DSTD_INSPIRED #138251
+ if use nls ; then
+ use elibc_glibc || append-ldflags -lintl #154181
+ export NLS=1
+ else
+ export NLS=0
+ fi
+ emake || die "emake failed"
+ if tc-is-cross-compiler ; then
+ emake -C "${S}"-native CC=$(tc-getBUILD_CC) CFLAGS="${BUILD_CFLAGS}" zic || die
+ fi
+}
+
+src_install() {
+ local zic=""
+ tc-is-cross-compiler && zic="zic=${S}-native/zic"
+ emake install ${zic} DESTDIR="${D}" || die
+ rm -rf "${D}"/usr/share/zoneinfo-leaps
+ dodoc README Theory
+ dohtml *.htm *.jpg
+}
+
+pkg_config() {
+ # make sure the /etc/localtime file does not get stale #127899
+ local tz src
+
+ if has_version '<sys-apps/baselayout-2' ; then
+ src="/etc/conf.d/clock"
+ tz=$(unset TIMEZONE ; source "${ROOT}"/etc/conf.d/clock ; echo ${TIMEZONE-FOOKABLOIE})
+ else
+ src="/etc/timezone"
+ if [[ -e ${ROOT}/etc/timezone ]] ; then
+ tz=$(<"${ROOT}"/etc/timezone)
+ else
+ tz="FOOKABLOIE"
+ fi
+ fi
+ [[ -z ${tz} ]] && return 0
+
+ if [[ ${tz} == "FOOKABLOIE" ]] ; then
+ elog "You do not have TIMEZONE set in ${src}."
+
+ if [[ ! -e ${ROOT}/etc/localtime ]] ; then
+ cp -f "${ROOT}"/usr/share/zoneinfo/Factory "${ROOT}"/etc/localtime
+ elog "Setting /etc/localtime to Factory."
+ else
+ elog "Skipping auto-update of /etc/localtime."
+ fi
+ return 0
+ fi
+
+ if [[ ! -e ${ROOT}/usr/share/zoneinfo/${tz} ]] ; then
+ elog "You have an invalid TIMEZONE setting in ${src}"
+ elog "Your /etc/localtime has been reset to Factory; enjoy!"
+ tz="Factory"
+ fi
+ einfo "Updating /etc/localtime with /usr/share/zoneinfo/${tz}"
+ [[ -L ${ROOT}/etc/localtime ]] && rm -f "${ROOT}"/etc/localtime
+ cp -f "${ROOT}"/usr/share/zoneinfo/"${tz}" "${ROOT}"/etc/localtime
+}
+
+pkg_postinst() {
+ pkg_config
+}