summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTravis Tilley <lv@gentoo.org>2004-05-25 17:00:46 +0000
committerTravis Tilley <lv@gentoo.org>2004-05-25 17:00:46 +0000
commit3a53f410e5a20070ffc1dd970b37e782d2fbc800 (patch)
treed086d58097717c9d8abfb68082028802872c4b0d /sys-libs/libstdc++-v3
parentamd64 (Manifest recommit) (diff)
downloadgentoo-2-3a53f410e5a20070ffc1dd970b37e782d2fbc800.tar.gz
gentoo-2-3a53f410e5a20070ffc1dd970b37e782d2fbc800.tar.bz2
gentoo-2-3a53f410e5a20070ffc1dd970b37e782d2fbc800.zip
changed directory so that it doesnt clash with gcc 3.3.3
Diffstat (limited to 'sys-libs/libstdc++-v3')
-rw-r--r--sys-libs/libstdc++-v3/ChangeLog5
-rw-r--r--sys-libs/libstdc++-v3/Manifest4
-rw-r--r--sys-libs/libstdc++-v3/libstdc++-v3-3.3.3-r1.ebuild11
3 files changed, 14 insertions, 6 deletions
diff --git a/sys-libs/libstdc++-v3/ChangeLog b/sys-libs/libstdc++-v3/ChangeLog
index 953d2dd16bbe..8bf1f722f380 100644
--- a/sys-libs/libstdc++-v3/ChangeLog
+++ b/sys-libs/libstdc++-v3/ChangeLog
@@ -1,6 +1,9 @@
# ChangeLog for sys-libs/libstdc++-v3
# Copyright 2000-2004 Gentoo Technologies, Inc.; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-libs/libstdc++-v3/ChangeLog,v 1.2 2004/05/24 21:17:43 lv Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-libs/libstdc++-v3/ChangeLog,v 1.3 2004/05/25 17:00:46 lv Exp $
+
+ 27 May 2004; Travis Tilley <lv@gentoo.org> libstdc++-v3-3.3.3-r1.ebuild:
+ changed directory so that it doesnt clash with gcc 3.3.3
*libstdc++-v3-3.3.3-r1 (24 May 2004)
diff --git a/sys-libs/libstdc++-v3/Manifest b/sys-libs/libstdc++-v3/Manifest
index f2e172002bf7..a51e7694ecf0 100644
--- a/sys-libs/libstdc++-v3/Manifest
+++ b/sys-libs/libstdc++-v3/Manifest
@@ -1,5 +1,5 @@
+MD5 783f59ce0b1d0388daabd0ab0e94eca3 libstdc++-v3-3.3.3-r1.ebuild 6063
MD5 79f41a90231d46c5a5dc22e92cd11641 ChangeLog 789
-MD5 08a4605b6a9cb6a41a4a6762e3171dff libstdc++-v3-3.3.3-r1.ebuild 5792
MD5 b6c1db1060c4e856b248a22adec1ff53 metadata.xml 220
-MD5 14f4d6619c938dbb907e2420c0eeefd9 files/digest-libstdc++-v3-3.3.3-r1 64
MD5 b2a96584f4cee72362695ba44c911c40 files/libstdc++_amd64_multilib_hack.patch 350
+MD5 14f4d6619c938dbb907e2420c0eeefd9 files/digest-libstdc++-v3-3.3.3-r1 64
diff --git a/sys-libs/libstdc++-v3/libstdc++-v3-3.3.3-r1.ebuild b/sys-libs/libstdc++-v3/libstdc++-v3-3.3.3-r1.ebuild
index e35914d1eafc..e70215e8c68e 100644
--- a/sys-libs/libstdc++-v3/libstdc++-v3-3.3.3-r1.ebuild
+++ b/sys-libs/libstdc++-v3/libstdc++-v3-3.3.3-r1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2004 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-libs/libstdc++-v3/libstdc++-v3-3.3.3-r1.ebuild,v 1.1 2004/05/24 21:17:43 lv Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-libs/libstdc++-v3/libstdc++-v3-3.3.3-r1.ebuild,v 1.2 2004/05/25 17:00:46 lv Exp $
IUSE="nls"
@@ -201,14 +201,19 @@ src_install() {
LIBPATH="${LIBPATH}" \
install-target-libstdc++-v3 || die
+ # we'll move this into a directory we can put at the end of ld.so.conf
+ # other than the normal versioned directory, so that it doesnt conflict
+ # with gcc 3.3.3
+ mkdir -p ${D}/${LOC}/lib/libstdc++-v3/
+ mv ${D}/${LIBPATH}/lib* ${D}/${LOC}/lib/libstdc++-v3/
# we dont want the headers...
- rm -rf ${D}/${STDCXX_INCDIR}
+ rm -rf ${D}/${LOC}/lib/gcc*
# or locales...
rm -rf ${D}/${LOC}/share
# or anything other than the .so files, really.
find ${D} | grep -e c++.la$ -e c++.a$ | xargs rm -f
mkdir -p ${D}/etc/env.d/
- echo "LDPATH=\"${LIBPATH}\"" >> ${D}/etc/env.d/99libstdc++
+ echo "LDPATH=\"${LOC}/lib/libstdc++-v3/\"" >> ${D}/etc/env.d/99libstdc++
}