summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2013-07-03 18:38:26 +0000
committerAlexis Ballier <aballier@gentoo.org>2013-07-03 18:38:26 +0000
commit7a7c3a5b1d407e4ef6d05ac741dd0798c48db4ac (patch)
treec3b45d627ac1d1d2a404c4891f7b714231644165 /sys-libs/libcxx
parentVersion bump. EAPI=5. Add ruby19. (diff)
downloadgentoo-2-7a7c3a5b1d407e4ef6d05ac741dd0798c48db4ac.tar.gz
gentoo-2-7a7c3a5b1d407e4ef6d05ac741dd0798c48db4ac.tar.bz2
gentoo-2-7a7c3a5b1d407e4ef6d05ac741dd0798c48db4ac.zip
inherit base before subversion to get a correct src_unpack, bug #475598 by Michael Weber
(Portage version: 2.2.0_alpha186/cvs/Linux x86_64, signed Manifest commit with key 160F534A)
Diffstat (limited to 'sys-libs/libcxx')
-rw-r--r--sys-libs/libcxx/ChangeLog6
-rw-r--r--sys-libs/libcxx/libcxx-9999.ebuild4
2 files changed, 7 insertions, 3 deletions
diff --git a/sys-libs/libcxx/ChangeLog b/sys-libs/libcxx/ChangeLog
index fac9aace9cbd..def2890458e7 100644
--- a/sys-libs/libcxx/ChangeLog
+++ b/sys-libs/libcxx/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for sys-libs/libcxx
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-libs/libcxx/ChangeLog,v 1.21 2013/07/02 21:56:24 aballier Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-libs/libcxx/ChangeLog,v 1.22 2013/07/03 18:38:26 aballier Exp $
+
+ 03 Jul 2013; Alexis Ballier <aballier@gentoo.org> libcxx-9999.ebuild:
+ inherit base before subversion to get a correct src_unpack, bug #475598 by
+ Michael Weber
02 Jul 2013; Alexis Ballier <aballier@gentoo.org>
libcxx-0.0_p20130531-r1.ebuild, libcxx-9999.ebuild:
diff --git a/sys-libs/libcxx/libcxx-9999.ebuild b/sys-libs/libcxx/libcxx-9999.ebuild
index 44a9b5a6e778..853b7863c625 100644
--- a/sys-libs/libcxx/libcxx-9999.ebuild
+++ b/sys-libs/libcxx/libcxx-9999.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2013 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-libs/libcxx/libcxx-9999.ebuild,v 1.13 2013/07/02 21:56:24 aballier Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-libs/libcxx/libcxx-9999.ebuild,v 1.14 2013/07/03 18:38:26 aballier Exp $
EAPI=5
@@ -8,7 +8,7 @@ ESVN_REPO_URI="http://llvm.org/svn/llvm-project/libcxx/trunk"
[ "${PV%9999}" != "${PV}" ] && SCM="subversion" || SCM=""
-inherit cmake-utils ${SCM} base flag-o-matic toolchain-funcs multilib
+inherit cmake-utils base ${SCM} flag-o-matic toolchain-funcs multilib
DESCRIPTION="New implementation of the C++ standard library, targeting C++11"
HOMEPAGE="http://libcxx.llvm.org/"